Origin-Projektdatei öffnen, schließen und durch Backup sichern

Projektdatei öffnen

  • Wählen Sie im Origin-Menü Datei: Öffnen. Stellen Sie sicher, dass für den Dateityp die Option Origin-Dateien (*.opju, *.opj, .og?, *.ot?) gewählt ist. Wählen Sie die Projektdatei und klicken Sie auf Öffnen. Dies schließt alles im aktuellen Arbeitsbereich, und die ausgewählte .OPJ-Datei wird geladen. Wenn Änderungen an dem aktuellen Projekt nicht gespeichert wurden, wird Origin Sie auffordern, Ihre Arbeit zu speichern.
  • Wählen Sie im Menü Datei: Anhängen. Sie können mehrere Projektdateien auswählen. Die ausgewählten Projektdateien werden zum aktuellen Arbeitsbereich hinzugefügt. Sie werden gefragt, ob Sie sie (a) als Unterordner in den aktuellen Ordner des Projekt Explorers oder (b) direkt in den aktuellen Ordner einfügen möchten. Hinweis: Jeder Unterfenstername innerhalb eines Projekts muss eindeutig sein. Deshalb kann es passieren, dass Unterfenster in angehängten OPJs durch Nummerierung umbenannt werden.
  • Ziehen Sie eine Projektdatei per Drag&Drop aus dem Windows Explorer in den Origin-Arbeitsbereich. Wenn der Arbeitsbereich standardmäßig der Arbeitsbereich Untitled ist, ist dies das Äquivalent zu Datei: Öffnen. Wenn eine benannte Projektdatei im aktuellen Arbeitsbereich geöffnet ist, wird die per Maus gezogene Projektdatei an den existierenden Arbeitsbereich angehängt und Sie werden aufgefordert, (a) einen neuen Ordner zu erstellen oder (b) sie zum aktuellen Ordner hinzuzufügen.
  • Durch einen Doppelklick auf eine Projektdatei im Windows Explorer wird eine neue Instanz von Origin mit der geladenen Projektdatei gestartet.

Um eine Projektdatei zu speichern:

  • Wählen Sie Datei: Projekt speichern oder klicken Sie auf Projekt speichern Button Save Project.png auf der Symbolleiste Standard. Dies speichert alles im aktuellen Origin-Arbeitsbereich unter dem Dateinamen, der in der Titelleiste des Origin-Arbeitsbereich gezeigt wird. Hinweis: Der Ordner des Projekt Explorers, der beim Speichern der OPJ-Datei aktiv ist, ist der Ordner, der beim erneuten Öffnen der OPJ-Datei geöffnet wird.
  • Wählen Sie Datei: Projekt speichern unter... und legen Sie einen Pfad, einen Dateinamen und unter Dateityp *opju oder *.opj fest.
  • Klicken Sie mit der rechten Maustaste auf einen Ordner oder einen Unterordner im Projekt Explorer, um nur diesen Ordner und seine Unterordner in einer separaten Projektdatei zu speichern.

Sie können Origin konfigurieren, um eine benutzerdefinierte Projektdatei beim Start zu öffnen. Wählen Sie Einstellungen: Optionen, klicken Sie auf die Registerkarte Öffnen/Schließen und setzen Sie Neues Projekt öffnen auf Origin.opj. Klicken Sie bei der Befehlsaufforderung auf "Ja". Speichern Sie dann Ihr benutzerdefiniertes Projekt im Hauptordner Ihres Anwenderdateiordners und verwenden Sie dafür den Namen Origin.opj. Jedes Mal, wenn Sie Origin ausführen, wird Ihr benutzerdefiniertes Projekt automatisch geladen.

Origin 2018 enthält neue Dateiformate für Projekte, Unterfensterdateien und Vorlagen. Wenn Sie eine Datei speichern, haben Sie die Option, eine Datei mit oder ohne ein am Dateityp angehängtes "u" zu speichern (*.opj oder *.opju).

  • Wenn Sie beabsichtigen, die Datei nur in der neuesten Version von Origin zu verwenden, sollten Sie den neuen OPJU-Dateityp verwenden, da er einige Vorteile hinsichtlich der Performance zeigt.
  • Wenn Sie das Projekt mit Kollegen teilen möchten, die ältere Versionen von Origin verwenden, sollten Sie das Projekt in dem älteren OPJ-Dateityp speichern.
  • Wenn Sie möchten, dass Origin standardmäßig im älteren OPJ-Format (und/oder im Diagrammfensterformat OGG) speichert, öffnen Sie das Skriptfenster (Fenster: Skriptfenster) und ändern Sie den Wert der "@"-Systemvariable @OPJ.

Was wird (nicht) mit der Origin-Projektdatei gespeichert?

Gespeichert
NICHT gespeichert

Aktuelles Projekt klonen

Wenn ein gespeichertes Projekt geöffnet und aktualisiert wurde, können Sie das Projekt "klonen" und die geklonte Projektdatei dann verwenden, um die zugehörigen Operationen mit anderen Daten oder den gleichen, aber zukünftig geänderten Daten zu wiederholen. Wir bezeichnen dieses geklonte Projekt als ein Analysevorlagenprojekt, das heißt, es kann als Arbeitsroutine eingesetzt werden genauso wie allgemeine Analysevorlagen.

Um ein Projekt zu klonen, erstellen Sie ein Analysevorlagenprojekt.

  1. Wählen Sie Datei: Aktuelles Projekt klonen.
  2. Im Dialog Data Manipulation: clrAllData
Clone opj dialog.png
werden der aktuelle Projektname und der vollständige Pfad gezeigt, falls das Projekt gespeichert wurde. Sie können wählen,
  • Datenkonnektoren zu den Arbeitsblättern hinzuzufügen, die noch keine Konnektoren haben. Bitte beachten Sie, dass Datenkonnektoren hinzufügen nur verfügbar ist, wenn das aktuelle Projekt gespeichert wurde. Die Datenquelle des neu hinzugefügten Datenkonnektors ist die aktuelle Projektdatei, genauso wie Sie die Quelldaten durch Auswahl von Daten: Mit Datei verbinden: Origin-Datei importieren.
  • Löschen Sie alle Daten oder nur die importierten Daten (einschließlich der Daten, die über das Menü Daten: Aus Datei importieren importiert wurden).
  • Falls das aktuelle Projekt die Neuberechnung beinhaltet, können Sie wählen, die neu berechenbaren Spalten zu löschen oder die Neuberechnung auf Keine zu setzen.

Auf diese Weise wird ein Duplikat des vorhandenen Projekts mit dem Namen UNTITLED.opju erstellt und geöffnet, in dem alle Fenster und Operationen des ursprünglichen Projekts aufbewahrt werden. Gleichzeitig werden alle importierten Daten gelöscht, aber die Verbindung zwischen der Datenquelle und dem Zielarbeitsblatt bleibt erhalten. Sie können dann einfach die Datenquelle aktualisieren, und alle Arbeitsblätter und Diagramme werden automatisch mit aktualisiert.

Projektsicherung und -wiederherstellung

Origin hat drei unterschiedliche Funktionen zur Datenwiederherstellung, die über Einstellungen: Optionen aktiviert bzw. deaktiviert werden können:

Project recovery tools options.png
  1. Das Backup ist die älteste Origin-Wiederherstellungsfunktion und kann nützlich sein, wenn Sie eine Projektdatei haben, die sich nicht öffnen lässt. Diese Datei sollte den Projektinhalt zum Zeitpunkt der zuletzt erfolgreich gespeicherten Datei enthalten.
  2. Die automatische Speicherung ist nützlich zum Wiederherstellen nach Programmabstürzen und Stromausfällen. Die Datei wird automatisch zu einem vordefinierten Intervall gespeichert (Standard ist alle 12 Minuten).
  3. Ungespeichert ist nützlich zum Wiederherstellen von Daten, die Sie beim Schließen der Datei oder des Programm nicht gespeichert haben (sowohl Untitled und Dateien mit Namen).

Neue Projekte

Wenn Sie Origin starten, wird der Origin-Fenstertitel standardmäßig mit UNTITLED angezeigt, um darauf hinzuweisen, dass es sich um ein leeres neues Projekt handelt. Diese Datei behält den Namen UNTITLED, bis Sie im Menü Datei: Projekt speichern oder Datei: Projekt speichern unter wählen. In beiden Fällen öffnet sich beim Speichern von UNTITLED der Dialog Speichern unter, in dem Sie einen Pfad wählen können, einen Dateinamen und einen Dateityp.

Ungespeicherte Projekte automatisch speichern

Wenn Sie Änderungen an einem geöffneten Projekt vornehmen - egal, ob es ein Projekt mit Name oder UNTITLED ist -- wird ein Sternchen ("*") neben dem Dateinamen in der Titelleiste von Origin angezeigt.

File modify indicator.png

Sobald eine Datei modifiziert wurde, veranlasst der Versuch, die Datei zu schließen oder Origin zu verlassen, bevor Sie Datei: Projekt speichern oder Datei: Projekt speichern unter gewählt haben, die Anzeige einer Befehlsaufforderung, die Änderungen am Projekt zu speichern.

Wenn Sie seit Origin 2018 NEIN sagen und (1) Ungespeicherte Projekte automatisch speichern aktiviert ist (Standard) und (2) die Projektdateigröße kleiner als der Wert der LabTalk-Systemvariable @USM ist (Standard = 20 MB), dann wird die Projektdatei automatisch vor em Schließen gespeichert (siehe Hinweise).

Tools autosave unsaved.png
  • Wenn der Name des Projekts UNTITLED war, wird der Projektinhalt unter C:\UsersUser\Documents\OriginLab\Unsaved\UNTITLED gespeichert.
  • Wenn das Projekt bereits einen Namen hat, wird der Projektinhalt unter C:\UsersUser\Documents\OriginLab\Unsaved\Projektname gespeichert.

Um ein ungespeichertes Projekt wiederherzustellen:

  1. Starten Sie Origin.
  2. Klicken Sie auf Hilfe: Ordner öffnen: Ungespeicherte Projekte.
  3. Durchsuchen Sie den Ordner nach Ihrer ungespeicherten Datei.

Die andere Möglichkeit, Ordner zu finden, die mit der Datenwiederherstellung verbunden sind, besteht darin, Einstellungen: Optionen zu wählen und auf die Registerkarte Systempfad zu klicken. Hier finden Sie die Pfade für automatisch gespeicherte, Backup- und ungespeicherte Dateien.

Recovery folders system path-vNext.png



Hinweise zu ungespeicherten Projekten

  • Die maximale Größe für ungespeicherte Dateien wird von der LabTalk-Systemvariable @USM gesteuert. Der Standardwert für @USM ist 20 MB. Ungespeicherte Dateien, die größer als der Schwellenwert von @USM sind, werden NICHT gespeichert, wenn Sie das Programm ohne Speichern verlassen.
  • Es kann nur eine \Unsaved\UNTITLED-Datei geben. Falls Sie sich entscheiden, den Inhalt von UNTITLED wiederherzustellen, sollten Sie die Datei öffnen und sofort mit einem aussagekräftigen Namen speichern, da UNTITLED überschrieben wird, wenn Sie ein weiteres Projekt ohne Namen öffnen und beim Schließen oder Verlassen des Programms nicht speichern.
  • Standard ist, dass Projekte 7 Tage aufbewahrt werden. Das Einhalten der Zeit wird von der LabTalk-Systemvariable @USKT gesteuert.

Projekt automatisch alle xx Minute(n) speichern

Tools autosave every xxminutes.png

Origin verfügt auch über eine Funktion Projekt alle xx Minuten automatisch speichern, die standardmäßig eingeschaltet ist. Wenn sie aktiviert ist, wird der Projektinhalt in benutzerdefinierten Intervallen in eine temporäre Datei im Anwenderordner \Documents\OriginLab\Autosave gespeichert. Während der Sitzung werden Dateien mit Namen im Ordner \Autosave mit projectFilenNme-xxxxxxxxx aufgelistet. UNTITLED-Projekte werden mit UNTITLED-xxxxxxxxx aufgeführt. Wenn Sie das Origin-Projekt speichern oder das Programm normal beenden, räumt Origin auf, indem es diese temporären Dateien löscht. Wenn ein benanntes und modifiziertes Projekt oder ein UNTITLED-Projekt ohne Speichern geschlossen wird, wird die zuletzt automatisch gespeicherte Datei als Autosave\Last-AutoSave.opju oder opj gespeichert. Im Fall eines Programmabsturzes sollten sowohl Dateien mit und ohne Namen in ihrem zuletzt automatisch gespeicherten Zustand aufbewahrt sein, als projectFilenNme-xxxxxxxxx bzw. UNTITLED-xxxxxxxxx.

  • Automatisches Speichern ist standardmäßig für UNTITLED-Projekte sowie für Projekte mit Namen eingeschaltet.
  • Um die automatische Speicherung von UNTITLED-Projekten zu deaktivieren, setzen Sie @DASU = 1.


Automatisch gespeicherte Dateien öffnen:

  1. Navigieren Sie zum Ordner Autosave, indem Sie eine der folgenden Optionen wählen:
    • Wählen Sie Hilfe: Ordner öffnen: Automatisch Speichern im Menü, um den Ordner zu öffnen.
    • Öffnen Sie Einstellungen: Optionen. Die Registerkarte Systempfad führt alle Pfade auf, die von Origin erstellt wurden, einschließlich Autosave (Beachten Sie, dass Sie auf dieser Registerkarte den Speicherort Ihres Autosave-Ordners ändern können, indem Sie Autosave markieren und auf die Schaltfläche Ändern klicken).
  2. Öffnen Sie Last-AutoSave.opju/opj mit einem (a) Doppelklick auf das Projektsymbol im Windows-Dateiexplorer, durch (b) Verwenden von Origins Menü Datei: Öffnen oder durch (c) Drag&Drop der Datei in Ihren Origin-Arbeitsbereich.

Einstellungen der automatischen Speicherung festlegen

Um diese Funktion der regelmäßigen automatischen Speicherung zu aktivieren, deaktivieren oder die Zeitabstände zwischen den automatischen Speicherungen anzupassen:

  1. Wählen Sie im Menü Einstellungen: Optionen, um den Dialog Optionen zu öffnen.
  2. Gehen Sie zur Registerkarte Öffnen/Schließen und aktivieren bzw. deaktivieren Sie das Kontrollkästchen Automatisches Speichern des Projekts alle x Minute(n). Passen Sie die Speicherzeitabstände nach Bedarf an.

Hinweise zu automatisch gespeicherten Projekten

  • Wenn die aktuelle Projektgröße 20 MB überschreitet (Standardwert, der von der "@"-Systemvariablen @ASC gesteuert wird), hat das automatische Speichern den folgenden Warndialog zur Folge:
Autosave prompt.png
  • Da das automatische Speichern von Dateien Ihre Arbeit verlangsamen kann, können Sie über diesen Dialog die automatische Speicherung für das aktuelle Projekt oder für jedes Projekt, das den Schwellenwert überschreitet, ausschalten. Tun Sie nur nach sorgfältiger Überlegung.
  • Zusätzlich haben Sie die Option, diesen Warndialog dauerhaft zu deaktivieren ("Nicht erneut fragen ..."). Nach seiner Deaktivierung können Sie den Warndialog wiederherstellen, indem Sie das Skriptfenster öffnen (Fenster: Skriptfenster) und den folgenden Befehl eingeben, bevor Sie <Enter> drücken:
doc -ca

Wenn Origin das nächste Mal automatisch eine Projektdatei speichert, wird dieser Warndialog geöffnet, falls die Schwellenwertgröße von @ASC überschritten wurde (siehe den Befehl doc -ca).

  • Die Zeitdauer, die ein automatisch gespeichertes (abgestürztes) Projekt aufbewahrt wird, wird von der "@"-Systemvariable @ASKH gesteuert. Der Standard ist "Aufbewahrungsstunden" = 12, aber Sie können diesen Wert im Skriptfenster (Fenster: Skriptfenster) ändern. Wenn Sie Dateien nicht automatisch aus dem Ordner Autosave entfernen möchten, setzen Sie @ASKH = -1.

Vor dem Speichern Sicherungskopie erstellen

Tools backup.png

Wenn Sie manuell eine Origin-Projektdatei mit Namen speichern möchten, wird eine Kopie der Datei, wie sie zum Zeitpunkt der letzten Speicherung bestand, im Ordner Projektsicherungsordner gespeichert. Wenn Ihre aktuelle Datei aus irgendeinem Grund beschädigt werden sollte, sollte es möglich sein, die vorherige Version der Datei wiederherzustellen, indem Sie die Datei unter \Backup öffnen. Diese Funktion ist standardmäßig aktiviert und unabhängig von den Funktionen "Automatische Speicherung" und "Ungespeichert".

Hinweis: Der Sicherungsordner ist in Origin 2018b eingeführt.

Bei älteren Versionen sichert Origin die vorherige Version der aktuellen Projektdatei durch Speichern einer BACKUP.OPJ(U)-Datei in Ihrem Anwenderdateiordner (UFF). Es gibt nur eine Datei BACKUP.OPJ(U). Wenn Sie also später eine andere OPJ(U)-Datei erneut öffnen und die OPJ(U) manuell gespeichert haben, ist BACKUP.OPJ(U) die neue Backup-Datei.

Um die Sicherungskopie der Projektdatei zu öffnen:

  1. Starten Sie Origin.
  2. Wählen Sie Hilfe: Ordner öffnen: Projekt-Backup.
    Oder:
    Öffnen Sie den Dialog Einstellungen: Optionen, um den \Backup-Pfad auf der Registerkarte Systempfad zu kopieren und ihn in der Adressleiste des Windows-Dateiexplorers einzufügen.
  3. Suchen Sie die Projektdatei und öffnen Sie sie.

Um die Erstellung der Datei BACKUP.opj zu deaktivieren:

  1. Wählen Sie im Menü Einstellungen: Optionen, um den Dialog Optionen zu öffnen.
  2. Gehen Sie zur Registerkarte Öffnen/Schließen und deaktivieren Sie das Kontrollkästchen Backup vor dem Speichern.

Hinweise zu Backup-Projekten

  • Ab 2018b lässt Origin das Speichern von mehreren Sicherungsdateien zu, eine für jedes Projekt mit Namen. Diese Dateien werden über die Zeit gesammelt und benötigen beträchtliche Speicherkapazitäten. Standardmäßig zeigt Origin eine regelmäßige Erinnerungsmeldung zu den anwachsenden Sicherungsdateien an. Diese Meldung wird über die "@"-Systemvariable @BFS gesteuert.
Backup attention message.png