18 Publishing and Export


Grand image graphic export.png

The Master Page

The Master Page feature is used to add one or more common objects to exported or printed graphs. Use the master page to add a set of properties and objects -- a custom background, a company logo, text labels, images, etc. -- to selected graph windows in your project.

Master items applied.png

To make use of this feature, you must first create your Master Page. The Master Page should contain only the properties and objects that you want to display on your selected graph windows:

  1. From the menu, choose File: New: Master Page. If you are not in the project root folder when selecting this menu item, you will be asked to switch to the project root folder.
  2. Customize the Master Template. Note that the comments that show beneath the Save Master Template button are "hidden" and will not be applied to your graph windows.
  3. Click the Save Master Template button. When you save, the Master Template will be saved to the User Files Folder as "name of active window".otpu (e.g. "C:\Users\YourName\Documents\OriginLab\User Files\Master.otpu").


Things to know about the Master Page:

  • Master items will only show in graphs pages of the same dimensions as the template. Apply Dimension to All Graphs applies Master Template page dimensions to all graphs of the same aspect ratio.
  • If you create a graph and modify page size, then choose File: New: Master Page and load a Master Template into the workspace, the Master Template will be loaded with the page dimensions of your modified graph page.
  • The Rotate button swaps the Master Template page dimensions (toggles orientation between landscape and portrait).
  • When you click Apply Dimension to All Graphs you are prompted to apply dimensions only to graphs of the same aspect ratio, or to all graphs of the same orientation (portrait or landscape).
  • Master Page items on a graph with portrait orientation will not show on a graph with landscape orientation and vice versa.
  • Edit: Copy Page normally copies an Origin graph object to the Clipboard. When the object is pasted into an MS Word document and the user subsequently double-clicks on the graph object, the graph opens in an OLE instance of Origin, where it can be edited. When Master Items are present on the graph, Edit: Copy Page places an image object (EMF) on the Clipboard, not the usual graph object.
  • Send Graphs to PowerPoint does not support Insert Graphs as Embedded Object if the graph contains Master Items (see previous bullet). Insert Graphs as Picture does support Master Items.
  • There is a mechanism for selectively excluding Master Items in your exported or printed page. Any object that you do not want to appear in the exported or printed page should begin with "NoExport" (e.g. open an arrow object's Properties dialog and on the Programming tab, rename "Arrow" to "NoExport_Arrow").
  • When you customize and save your Master Page to the User Files Folder, the next time you choose File: New: Master Page, you load your customized template.
  • If you don't want to show Master Items in the workspace, click View: Show: Master Items and remove the check mark. The exported graph will still contain the Master Items (they just won't show in the workspace).
  • If you want to remove Master Items from a graph in both the workspace and exported images, click Format: Page..., Display tab and clear the Use Master Items check box.

You could use the Text tool to add project and system information to your Master Template as static text objects, but since the idea is to build a template for re-use, consider "soft-coding" information in your text labels. To learn more, see these topics:

The Export Margin Offsets Dialog Box

By default, the margins of your copied or exported graph are determined by the Margin Control in Copy Page Settings group of Preferences: Options (Copy actions) or the Export Settings branch of Export Graphs (Export actions). You can interactively modify the default margins using the Export Margin Offsets Dialog Box.

Export margin control.png
  1. Click on the graph window (to activate) and choose Edit: Export Margin Offsets. This opens the Export Margin Offsets dialog.
  2. Drag the green selection handles that appear at the page margins; or enter values into the dialog edit boxes and click Apply.

Fit Page to Layer and Layer to Page

There are two small dialog boxes -- one new, one that has been part of Origin for some time -- that are also helpful for removing white space or placing a margin around your graph before exporting:

  • Fit Page to Layers: Choose Graph: Fit Page to Layers to open the pfit2l dialog box.
  • Fit Layers to Page: Choose Graph: Fit Layers to Page to open the gfitp dialog box.
DB pfit2l 1 small.png

Both dialogs can be used to remove white space. Both can perform resizing, with or without changing graph aspect ratio. You can view the documentation for both to decide which might work best for you but basically it boils down to whether you need to keep a particular page size (Fit Layers to Page); if not, either tool should do the job.

Copying and Pasting Graphs to Other Applications

There are two ways you can include Origin graphs in another application's files (e.g. Microsoft Word): as a Picture, or as an Origin Graph Object.

  1. Click on your Origin graph to activate it, then ...
    • To copy the graph as a picture, choose Edit: Copy Graph as Picture.
    • To copy the graph as an editable Origin graph object, choose Edit: Copy Page.
  2. In your target application choose Paste or press CTRL+V.


When you paste as a picture, the graph is inserted as an image. In MS Word, for instance, double-clicking on the image launches Word's picture-editing tools, but this method does not allow for further graph edits in your Origin software.

When you paste as a graph object, you can later double-click on the object in the target application to launch a new instance of Origin. The graph, and any associated data sheets, will be available for editing. After editing, use Origin's File: Exit and Return to... menu item to update the embedded object, close Origin and return to the host application.

There are several settings in the Options dialog (Preferences: Options, Page tab) that determine how the graph page is copied. These settings work with the newer Export Margin Offset dialog, to determine such things as graph copied size and page margins. Please review the Copy Page Settings and the Export Margin Offset dialog box.

Note: For more information, please refer to the:

Help: Origin: Origin Help > Exporting and Publishing Graphs > Pasting or Embedding Graphs in Other Applications

Organizing Your Graphs for Presentation or Export

If your Origin project file contains a large number of graphs that you plan to export or use in an Origin slide show, you can make things easier by adding shortcuts to your graphs to a Project Explorer Favorites folder and arranging them there:

  • Right-click on a window and choose Add Shortcuts to Favorites. This will add a shortcut to each graph window, to a new Favorites subfolder (visible in Project Explorer).
  • When sending graphs to PowerPoint or creating an Origin slideshow, you can (1) set slide order in the corresponding dialog box or (2) set slide order following this procedure.

If you are preparing a manuscript for publication, you may want to see FAQ-441 How do I export graphs with exact size and resolution as specified by publishers?

Exporting Graphs and Layout Pages to an Image File

To export a graph or a layout page as an image file, select the menu File:Export Graphs. This will open the expGraph dialog box. The expGraph dialog offers options for customizing the output size by scaling the height or width of the page, various settings that are specific to the chosen file format, options for naming the output file, and options to perform batch exporting of multiple pages.

Origin supports 14 export file formats:

Raster Formats BMP, GIF, JPG, PCX, PNG, TGA, PSD, TIF;
Vector Formats CGM, DXF, EPS, EMF, PDF, WMF

As is the case with most Origin dialog boxes, you can save your custom settings to a Theme file for repeat use. Once you have customized your settings:

  • Click the arrow to the right of Dialog Theme and choose one of the Theme save options.
  • Using any group of custom settings creates a temporary default Theme called <Last used>. This Theme then becomes available for loading your last used settings and you can access it from the expGraph dialog box or from the File: Recent Exports menu item.
ExpGraph Last used.png
Note: For more information, please refer to the:

Help: Origin: Origin Help > Exporting and Publishing Graphs > Exporting Your Graph or Layout Page to an Image File

Exporting to raster formats such as TIFF and specifying a high resolution (e.g. 600 DPI or above) can produce a very large output file size, depending on the page size. To reduce the file size, consider reducing the size of the page before export. Consult with your publisher to determine the actual width of a print column in your journal.

You can export multiple graphs, such as all graphs in a folder or all graphs in a project file, to a single, multi-page PDF file. Choose File: Export Graphs and open the Export Graphs dialog box. Set Image Type to Portable Document Format (*.pdf) and Select Graph(s) to one of the following options and you will see a checkbox for Export as multi-page PDF file.

Export as multipage PDF.png

Send Graphs to PowerPoint

You can send a group of Origin graphs to MS PowerPoint as pictures or as embedded objects (see limitations of embedded objects and Master Items, explained above). Graphs inserted as an embedded objects can be edited, as needed, in your Origin software. Double-click on the graph in PowerPoint to open the graph in an OLE instance of Origin.

There are two Send Graphs to PowerPoint tools in Origin -- the older, built-in tool and a newer Send Graphs to PowerPoint App that is installed with more recent versions of the Origin software. As most users favor the App, it will be discussed here. Documentation of the older, built-in tool, is found here and here.

To launch the App, click the Send Graphs to PowerPoint icon in the Apps Gallery, docked to the right-side or your Origin workspace. If you do not see the Apps Gallery, click View: Apps or press ALT + 9.

Tutorial: Send Graphs to PowerPoint

  1. Run Origin and open the sample file <Origin EXE Folder>\Samples\Graphing\Column and Bar.opju.
  2. Click on the Send Graphs to PowerPoint App icon to run the App.
  3. Click the Select Graphs button and choose Specified.
  4. Select all except Graph5B in the left panel and move them to the right panel by clicking the Button Add Files.png in the middle of the dialog box. Click OK. A scrollable list of graphs is added to the left panel in the App.
  5. Set Insert Graph as = Picture.
  6. Set the Slide Margin top dimension as 8% and leave the others as 0.
  7. Set Title Line = Top of Slide, and Title = Window Long Name.
  8. Set Starting Slide Index = 3 and Slide Mode = Start New.
  9. Use the browse button beside Load File/Template (optional) to load the file <Origin EXE Folder>\Samples\Import and Export\Column_Plots_in_Sample_OPJ.pptx.
  10. Specify a Save File as (optional) output path for the resulting PPTX file.

There is also a Send Graphs to Word App that is available free-of-charge from the OriginLab File Exchange. This App is particularly useful for batch export of graphs to a book-marked MS Word document.

Slide Show of Graphs

Origin has a built-in slideshow utility for viewing or presenting your graphs while running Origin. The slide show can be started in two ways:

  • Right-click on any folder in Project Explorer and select Slide Show of Graphs...

or

  • Click the Slide Show of Graphs button Button Slide Show Graphs.png on the Standard toolbar.

A dialog box opens offering options to set slide order, slide cycle time, whether to include graphs in sub folders, etc. The dialog also lists shortcut keys for use during the slide show (e.g. G = go to the actual graph window of the currently displayed slide).

Tutorial: Slide Show of Graphs

  1. Use the File: Open Sample Projects: 2D and Contour Graphs menu to open the sample project.
  2. Click on the Slide Show of Graphs button in the Standard Toolbar.
  3. Accept default settings in the dialog that opens, and press OK to start the slide show.
  4. You can use the up/down arrow keys or the mouse wheel to flip thru the slides.

Creating Movies

Origin provides a Video Builder tool, accessible from the Open Video Builder button Button Open Video Builder.png on the Standard Toolbar. This tool can be used to manually capture a series of graph windows, and write one frame at a time to a video (.AVI) file.

Videos can be created using LabTalk script or Origin C code, by programmatically computing or updating data and then writing out the graph as a frame in the video, at each step during the computation.

Note: For more information, please refer to the:

Help: Origin: Origin Help > Exporting and Publishing Graphs > Creating Graph Animation

For specific examples of programmatically created movies, including Origin Projects and code, please visit www.originlab.com/animation.

Exporting Worksheets and Matrices

Exporting Worksheets

Export your Origin workbook as a multi-page MS Excel workbook.


With a worksheet active, the File: Export menu item provides the following options:

  • ASCII, NI TDM (TDM, TDMS), and Sound (WAV)
    This option is available only for sheets containing data columns, and is not available when report sheets such as those created by the Nonlinear Fitting tool are active. The exported file will contain only data from the worksheet columns. Floating or embedded graphs placed in the worksheet will be ignored.
  • Excel
    Export books of worksheet columns with text and numeric data to an MS Excel file (XLS, XSLX, XSLM). Note that analysis report sheets with their hierarchical tables, and things such as embedded graphs and images, are not exported to the Excel file. Analysis results that are output to regular Origin worksheets are exported.
  • As Multipage PDF File
    This option is available only on sheets with data columns, and not for report sheets. Use the View: Page Break Preview Lines menu item to view the vertical and horizontal page break lines that determine which columns and rows will be included in each page of the export. Floating or embedded graphs placed in the worksheet will be included in the exported image.
  • As Image File
    This option is available on both data and report sheets. In the dialog that opens, you can select whether to export the entire sheet, visible area, or selection. Image file formats including PDF are supported. Floating or embedded graphs placed in the worksheet will be included in the exported image.
  • As PDF File
    This option is available for both data and report sheets. In the dialog that opens, you can opt for exporting the entire sheet, the visible area, or a selection. Floating or embedded graphs are included in the exported PDF.

When creating a custom report from a worksheet that combines data, numeric results and graphs, the best option is to export the entire sheet as a PDF file, or export the sheet as a multi-page PDF file.

Exporting a Matrix

Origin matrix data can be exported in these two formats:

  • ASCII
    This will create an ASCII file of the data contained in the active matrix object.
  • Image
    This option will export the image view of the active matrix object, as a raster file.
Note: For more information, please refer to the:

Help: Origin: Origin Help > Importing and Exporting Data > Exporting Worksheets and Matrices

HTML Reports from Notes Windows

Beginning with Origin 2019b, you can create HTML reports using Notes windows. You can build your HTML report using placeholders that link to report sheet elements such as metadata, statistical results or graphs. The resulting HTML report can be printed or exported; or it can be incorporated into your Analysis Template.

Reports can also be created using Markdown syntax instead of HTML. If Markdown syntax is used, optional HTML syntax can be also included for advanced customization.

To use this feature, the user should have some basic familiarity with HTML or Markdown, and as with most things, the more proficient the user is, the easier it will be to create professional-looking output. However, the skill needed to generate a basic report can be easily mastered. See this OriginLab blog post for guidance.

HTML Reports.png


The basic steps of creating reports using an Origin Notes window, are as follows:

  1. Create your project to include graphing and analysis results.
  2. Click the New Notes button Button New Notes.png to add a Notes window.
  3. From the menu, choose HTML: Syntax, then choose HTML or Markdown (Hint: You can toggle between text/view and markup modes by pressing CTRL+M and you can choose the default syntax by setting LabTalk System Variable @NPS).
  4. You can write your code in the Notes window's markup mode or you can use a text editor such as Notepad++, then copy and paste it to your Notes window. If you have no experience with HTML or Markdown, you may want to load samples by activating your Notes window and clicking HTML: Load Samples (HTML = ".html", Markdown = ".md").
  5. You will likely want to incorporate graphing and analysis results from the current project, into your report. The simplest way to do this is to insert "placeholders" for each Origin object that you intend to include in your report, into your code. These placeholders can be named using any string that makes sense to you and they should be enclosed in double-curly braces (e.g. {{MyR-SquareValue}}).
  6. Right-click on the Notes window title bar and choose Edit Placeholders. Placeholders that you have incorporated into your code will be picked up and added to a Placeholders worksheet in the workbook. The sheet will list, in column A, all of the placeholders found in your code. A second column -- Column B -- is blank and is reserved for adding the associated Origin objects (i.e. the variables, analysis and graphing results, etc.) that you want to include in your report.
  7. For each placeholder in column A, find the associated Origin object and copy it to the Clipboard (e.g. if it is a numeric quantity in a sheet resulting from some statistical analysis, select the cell quantity, right-click and choose Copy, or press CTRL+C on your keyboard).
  8. Return to the Placeholders sheet, right-click in column B, beside the associated placeholder and choose Paste-Link. This associates your placeholder with the intended Origin object.
  9. If you intend to include your HTML report in an Analysis Template, you can right-click on a workbook tab in your Analysis Template and choose Add Notes as Sheet. This inserts your Notes window into workbook and you can now choose File: Save Workbook as Analysis Template.

When a Notes window is active, you can click the HTML menu and load a sample HTML file into the Notes window.

HTML load samples.png

Using Your HTML Report

As you fill in your Placeholders sheet, you should see your HTML report take shape in the Notes window. Once completed, you can do various things with your HTML report, including:

  • Print to hard-copy or to PDF (File: Print).
  • Export the window as a webpage (HTML: Export to Webpage).
  • Click the embed button in the upper-right corner of the Notes window to embed the content into your workbook, then save the workbook as an Analysis Template (File: Save Workbook As Analysis Template).

Topics for Further Reading