OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis                     
 
Skip Navigation Links

6 The Origin Interface

The Origin Workspace

This chapter contains basic information on navigating the Origin workspace. Long-time Origin users can skim this chapter.

GSB Origin Interface.png

Windows File Explorer Previews

While not part of the Origin interface, you can use Windows File Explorer (previously "Windows Explorer") to preview graphs in a project file.

Interface Windows Explorer2.png
  • Windows Explorer's Large or Extra large icons views (right-click in File Explorer and choose View: Large Icons or Extra Large Icons or select from the Explorer View menu) will show an image of the last active graph before the project file was saved.
  • Open the Preview Pane (ALT + P) and scroll through all graphs in the project file.

Origin Menus and Menu Commands

  • Context-sensitivity of menu bar and menus: The menu bar and menu commands are context-sensitive; they change as you change window type (from worksheet to graph to matrix, for instance). Only menus pertinent to the active window will display.
  • Menu bitmaps, toolbar buttons and shortcut keys: Some menu commands also have bitmaps that display to the left of the command. Additionally, you may see a shortcut key combination listed to the right of a menu command. The button bitmap and the shortcut keys indicate alternate ways to access the same functionality.
  • Shortcut menu commands: Many commands are available from shortcut menus. To open a shortcut menu, right-click on an Origin object (worksheet window, graph axis, text object, etc.). Only pertinent menu commands will show.
  • Collapsible menus: By default, main and shortcut menus in Origin are "collapsed", meaning they display an abbreviated set of commands. When you use a menu item which isn't included, it is added to the menu.
  • Most frequently used analysis menu commands: Most-recently used menu commands will appear at the bottom of the analysis menus (Worksheet, Analysis, Statistics, Image, etc.). This gives you quick access to tools when performing repeat operations.
  • Custom Menu Organizer: Since Origin 8.1, Origin users have been able to use the Custom Menu Organizer to add or remove menu items. To learn more, see the chapter Customizing Origin, later in this Guide.

Origin Toolbars

Use the Customize Toolbar dialog box (View: Toolbars) to control toolbar display and reset or reinitialize toolbars.

  • Customize toolbar button appearance: Use controls on the Options tab of the Customize Toolbars dialog box to modify button and toolbar appearance.
  • Dock/Float a toolbar: Toolbars can be undocked and made to float on the workspace. To float a toolbar, hover over the left-end of the toolbar. When the pointer becomes a four-headed arrow, drag the toolbar off of the toolbar space. To return the toolbar to its former docked position, double-click the toolbar title bar.
  • Hide/Show a toolbar: Clicking the Close button on a toolbar removes the toolbar from view. To restore a hidden toolbar, open the Customize Toolbars dialog box and select the toolbar.
  • Hide/Show a button: Clicking the tiny arrow at the end of toolbar to turn on/off some buttons on a toolbar.
  • Move button location: Alt+drag a button to move it to a new location within or among toolbars. Alt+drag to blank workspace to create a new toolbar. Alt+drag a button to child window till X shows to remove a button.

Origin Central

Origin Central is a "startup" dialog intended to give you quick access to key files and support information. Origin Central was introduced in Origin 2017 and was updated for 2018.

To open the dialog, choose Help: Origin Central or press F11.

ORG-14520-75PC.png
  • Create a new workbook or matrix book.
  • View and load sample graphs, including sample data and notes on re-creating the graph.
  • Load analysis samples and templates.
  • Quick links to recent Origin files, including Unsaved Files†.
  • Browse the Learning Center tab for tutorials and videos.
  • Move files from your previous User Files Folder to your new User Files Folder.

† If you have closed a project without saving your changes, you may be able to recover your work if you have Autosave Unsaved Project enabled (default setting in Tools: Options > Open/Close tab). Open Origin Central and click on the Projects tab and look for your file under Unsaved Files. Alternately, click Help: Open Folder: Autosave Folder and look for your file. By default, projects are kept for 7 days.

Project Explorer

Project Explorer (PE) is a tool to help you organize the contents of your Origin project files (OPJ).

PE window features2.png

Project Explorer is split into two panels. The primary panel shows the OPJ folder structure. The sub-panel shows windows contained in the folder that is highlighted in the primary panel.

  • Right-click the PE title bar or click the drop-down menu to display the panels stacked (Vertical Alignment) or side-by-side (Horizontal Alignment).
  • Context menus in both panels provide options to delete, hide, print, etc. Menu options vary depending on what is selected or where you have right-clicked.
  • Multiple-selection of windows in the sub-panel is supported (press Shift or Ctrl while clicking with your mouse).
  • The sub-panel supports differing views of windows: Details (default), List, Small Icons, Large Icons, Extra Large Icons.

In any view, mousing over a window icon shows a popup preview of the graph, worksheet, matrix or layout window. Notes window content is shown in a tooltip.

PE Preview on Hover.png

When displaying windows as Extra Large Icons, the PE sub-panel displays a thumbnail of graphs, layout windows, workbooks and matrix books. Notes window content is shown in a tooltip.

PE XLicons and tooltip3 600.png

To disable PE previews, open the Script Window (Window: Script Window) and type one or both of the following, then highlight the text and press Enter:

@PESS=-1; //turn off window preview in PE, show window comments as tooltip
@PESH=0; //turn off window comments tooltip

When you set the value of a system variable using the Script Window, you are altering Origin's behavior for the current session only. To set the value of a system variable across sessions, see this FAQ.

  1. Select Help: Open Folder: Program Folder, click the Samples subfolder, then drag the file Tutorial Data.opj to your Origin workspace.
  2. By default, Project Explorer is docked to the left side of the Origin workspace in auto-hide mode. Mouse over the Project Explorer tab to show the PE window.
    PE tab mouseover.png
  3. Click on the "push pin" icon on the PE title bar to pin the window in the docked position.
    PE tab pushpin.png
  4. By default the sub-panel is in Details view. In this view, window metadata such as Name, Size and Comments show below these column headings. Try dragging column headers to reorder them.
    PE headings.png
  5. Right-click on the column headings and show or hide any of the headings by checking or unchecking the box beside each.
    PE hide show headers.png
  6. To add a comment in the Comments field, click once, pause briefly and click a second time. This puts you into edit mode. Enter a comment.
    PE add comments.png
  7. To change the Name of a window, right-click in the row and choose Rename. By default, the Name field displays the window Short Name (all windows must have a Short Name; Long Names are optional). To have the Name field display the window Long Name, click the SN button to the right-side of the editable Name field. If the Long Name does not exist, you can enter one.
    PE rename.png
  8. In the top panel of Project Explorer, scroll to the folder 3D Surface with Point Label and click on it. The sub-panel shows that there are three windows in the folder. Note that the worksheet window eastcali3053 is bold indicating that it is the "active" window - the window that is being acted upon as well as the window that determines what operations are available. There is also a Notes window and a matrix window named MBook4.
    PE active window.png
  9. In the sub-panel, double-click on MBook4 and note that it is now bold and has a magenta "halo", indicating that it is the active window. You will also see that the whole window(in the workspace) displays with a halo which can be customized in color with the system variable @AWC-- another indicator that this is the "active" window. Double-click on this MBook4 icon again and note that the icon is now dimmed. Note also that the actual window disappears from the workspace. This is because MBook4 is now hidden. Double-click the MBook4 icon again and the window is restored and made active.
    PE window hidden.png
  10. With MBook4 active, click Plot > 3D: Surface: 3D Colormap. This creates a 3D colormap surface graph (close the attention message). Note also that a new window -- Graph1 -- has been added to the sub-panel of Project Explorer.
  11. Right-click in an empty portion of the sub-panel and choose View: Extra Large Icons. Note that Graph1 now displays a graph thumbnail.
    PE XLarge Icons.png
  12. Right-click again and choose View: Large Icons. Note that windows are now represented by icons but if you hover on them, you can see the window contents as a pop-up.
    PE large icon popup.png

Apps Gallery and App Center

Apps are add-on applications for Origin that perform specific graphing and/or analysis tasks. A small number of Apps that are broadly applicable to science and engineering fields are pre-installed with your Origin software.
LaTeX apps gallery.png

Origin 2018 introduced the App Center dialog for browsing, updating or downloading Origin Apps. This new dialog gives you direct access to all of the Apps on the OriginLab File Exchange without you having to open a browser and navigate there.
Interface App Central.png


To launch the App Center, click the Add Apps button that appears on all tabs of the Apps Gallery, docked at the right-side of your Origin workspace.

  • Installed and Up-to-date Apps will appear in the App Center with a green check mark beside them AC OK Icon.png
  • Installed Apps for which there is a newer version will appear with an Update icon beside them AC Update Icon.png
  • Those not installed will appear with a clickable Download and Install icon beside them AC Download Icon.png


You can also see a list of installed Apps by browsing the Apps Gallery. Click View: Apps to open the Gallery if it is not open.

For more information on Apps, please visit www.originlab.com/apps.

Object Manager

The Object Manager is a dockable panel that opens to the right side of the workspace, by default. Use the Object Manager for quick manipulation of graph layers and data plots in the active graph window:

  • Select an element (layer, plot group, data plot or special point) in the Object Manager to select the corresponding element in the graph window and vice versa.
  • Hide or show plot elements by clearing or selecting the corresponding check box in the Object Manager.
Object Manager general.png

Right-click on an element in the Object Manager panel and choose from additional actions, including:

  • At the graph level, change Object Manager list order.
  • At the layer level, change layer order.
  • At the plot level, show or hide plots of the same name.
  • Within a plot group (labeled as gN), ungroup, toggle plot dependency, change plot type or re-order plots by dragging or by shortcut menu command.
  • Remove a plot from the graph window (not the same as hiding).
  • Access the Plot Details, Layer Contents and Plot Setup dialog boxes.

Origin Child Windows

Beginning with Origin 2018b, active windows -- the window that will be acted upon by graphing and analysis operations -- displays a colored frame to make the active window more obvious. You can customize the active window indicator properties (frame color, where the frame shows, frame line style) with "@ System Variables" @AWC (color) and @AWI (style).

Active window halo.png
  • Origin Workbooks: The Origin workbook provides a framework for importing, organizing, analyzing, transforming, and plotting your data. The tabbed workbook contains between 1 and 1,024 sheets. Each sheet may contain more millions of rows and more than 65,000 columns of data. In addition to your data, workbook windows may also store graphs, annotations, column-based functions, scripts and programmable button objects, LabTalk variables and import filters.
  • Origin Matrix Books: Like the worksheet, a matrix sheet is a grid of cells, arranged in rows and columns. The primary difference is that in the worksheet, each column is a dataset and each dataset can be configured to contain various types of data (text, text & numeric, numeric (double), numeric (int), etc). In contrast, the matrix is a single, numerical dataset of Z values, related in the XY plane by row (Y) and column (X) index numbers. The matrix book contains between 1 and 1,024 sheets. Each sheet can contain multiple matrix objects (up to 65,504 on a 64-bit OS).
  • Graphs: The graph window is the primary container for your data plots. Origin supports over 100 chart types, chosen specifically for their applications in various technical fields. Each chart is created using a built-in, user-modifiable graph template that can be saved with your custom settings. In addition to data plots, the graph may also contain annotations (text and drawing objects) or button objects that, when triggered, perform some custom graphing or analysis task. Graph windows can be inserted into worksheet cells or "floated" on worksheets (outside the grid) in a workbook window.
  • Function Graphs: The function graph is a specialized graph window that displays a curve described by a function. The function graph differs from other Origin graphs in that it is not produced from a dataset of discreet values (though you can generate data after plotting).
  • Layout Pages: The layout window allows you to combine and arrange graph and worksheet windows and various annotations onto a single "display panel." It is used primarily for creating presentations.
  • Excel workbooks. Excel workbooks can be opened or created in Origin. Workbooks can be saved separately or as part of your Origin project file.
  • Notes: The Notes window is a text-only window used for recording analysis procedures, making notes to students and colleagues, and cutting and pasting text from other applications.
Note: For more information on Origin's child windows, see

Help: Origin: Origin Help > Origin Basics > Elements of the Origin Workspace > Creating a Child Window

Help: Origin: Origin Help > Origin Basics > Elements of the Origin Workspace > Basic Child Window Operations



To save an Origin child window independently of the Origin project file:

  • Select File: Save Window As... to save active window. File extensions OGW(U), OGG(U), OGM(U) are for Origin Workbook, Graph and Matrix windows, respectively.
  • Right-click any window title bar and choose Save as... context menu.

Note: To save an Excel window as an external Excel file, right-click the Excel window title in Origin and choose Save Workbook as... context menu.

Origin 2018 added Unicode (UTF-8) support for Origin projects, child windows and templates. When you save a window file, you will have the option of saving a file with or without a "u" appended to the file type (*.opj or *.opju). If you intend to use the file only in the latest version of Origin, you should choose the Unicode-compliant (appended "u") option as it offers some performance advantages.


To open a worksheet, graph, matrix, or notes window that was saved to a file:

  • Select File: Open or click the Open button Button Open.png on the Standard toolbar to open window files.
  • Select File: Recent Books, File: Recent Graphs to open recently saved workbook and graph window files.

Note: Origin supports window Short Name, Long Name and Comments and the Short Name must be unique in the Origin project. The window Short Name will be renamed if such a name has already exists in the project. If you open window file in the current project, then save the project, the window will be included in the project.


To open an Excel workbook file:

  • Select File: Open Excel menu to open a external Excel file. Or, you can click Import Excel button in the Standard toolbar or select File: Import: Excel (XLS, XLSX, XLSM)... from the main menu to import the Excel file.

Note: If you choose Open Excel, the Excel file is opened as an Excel workbook, in an Excel session that runs inside Origin. In this mode, you have only limited access to Origin features. If you choose Import Excel, the Excel file is imported into an Origin workbook and all Origin features are available.

The Command Window and Script Window

The Command Window can be used to issue LabTalk commands to Origin, to do simple mathematical calculations, or to check the value of LabTalk variables. The Command Window maintains a time-stamped command history that can be carried over from session to session, and intellisense which provides auto-completion features when writing x-function command.

The Command Window is dockable and has two panels. The left-hand panel displays the command history, while the right-hand panel provides the command line.

The Script Window provides some of the same functionality as the Command Window. It lacks some of the Command Window's features (no intellisense, no command prompt, no command history) but it is handy for issuing LabTalk commands and running Python scripts. The window's Tools menu also opens the LabTalk Variables and Functions dialog box where you can view a list of Origin variables, functions, macros, loose datasets, etc.


To open the Command Window:

  • Click the Command Window button Button Command Window.png on the Standard toolbar. Alternately, select Window: Command Window menu or press ALT+3.


To open the Script Window:

  • Select Window: Script Window menu or press SHIFT+ALT+3.

The Status Bar

The Status Bar-1.png

The Status Bar is located at the bottom of the Origin workspace. It reports multiple parameters, including:

  • Help messages and tool descriptions.
  • Statistics on the current workbook, matrix or graph selection.
  • Whether the AutoUpdate analysis feature is turned on.
  • The name of the System Theme, if any.
  • Information pertinent to the active window.
  • Angular unit (radians, degrees, or gradians).
  • Tool tips for functions listed in the Set Values F(x) menu.
  • Notifications from OriginLab, represented by a small red flag to the right side of the Status Bar.
The Status Bar-2.png
Note: You can select what shows in the Status Bar by right-clicking on the Bar and selecting (or clearing) items from the context menu. You can copy displayed statistical values by selecting Copy Statistics from the context menu. The copied data are TAB separated between quantity and values, with each key value pair separated by a CRLF delimiter.

Smart Hints and the Smart Hint Log

Smart Hints are triggered by user actions and are intended to give the user help with current task. These hints may appear briefly inside a dialog box, as in this example.

Smart Hint1.png



Alternately, Smart Hints may appear in the lower left corner of the Origin workspace, as in this example.

Smart Hint2.png


Unless you hover over a Hint, it will quickly fade. You can prevent display of individual Smart Hints by checking the "Do not show this message in the future" box at the bottom of a Smart Hint.

Hints are logged for the current Origin session and can be reviewed by clicking the Smart Hint Log tab, docked at the edge of the Origin workspace (Note that in-dialog Hints are not logged).

Smart Hint3.png


To open (and close) the Smart Hint Log window:

  1. From the Origin menu, select View: Smart Hint Log or press ALT+7.

To prevent a particular Smart Hint from displaying again in the current session, right-click on the hint in the Smart Hint Log window and check Do not show this hint again from the context menu. A message asks you to confirm that you do not want to show or log this message.

To turn off all Smart Hint display in the session, open the Script Window and type the following:

@SHS = 0;

To turn on Smart Hint display (including those were individually hidden), type @SHS = 1, and click Help: Reactivate All Hints.

You can customize general properties of Smart Hints by setting system variables @SHG and @SHO. See the system variable list for details.

When you set the value of a system variable using the Script Window, you are altering Origin's behavior for the current session only. To set the value of a system variable across sessions, see this FAQ.

Code Builder

Origin's programming language is called Origin C. Origin C's integrated development environment (IDE) is called Code Builder. Code Builder provides tools for writing, compiling, and debugging your Origin C functions.Origin C, IDE

To open Code Builder:

  1. From the Origin menu, select View: Code Builder. Alternately, click the Code Builder button Button Code Builder.png on the Standard toolbar or press ALT+4.

Quick Help

As the name implies, the Quick Help window is intended to provide help with specific Origin tasks.


To open (and close) the Quick Help window:

  1. From the Origin menu, select View: Quick Help or press ALT+5.

To use the Quick Help window, start typing in the Find box. Generally speaking, typing in a few keywords works best. Like several other Origin tools, the Quick Help window can be floated, docked or set to auto-hide.

Messages Log

The Messages Log window shows messages about operations including Output Information, Results and Errors. It displays messages that are not sent to the Script Window or the Command Window.


To open (and close) the Messages Log window:

  1. From the Origin menu, select View: Messages Log or press ALT+6.

Results Log

Origin automatically types many analysis and fitting results to the Results Log. Each entry in the Results Log includes a date/time stamp, a window name, a numeric stamp which is the Julian day (see Dates below), the type of analysis performed, and the results.

In most cases, when results are reported to the Results Log, it opens automatically. Manually open (or close) the Results Log by doing one of the following:

  1. Click the Results Log button Button Results Log.png on the Standard toolbar. Alternately, from the Origin menu, select View: Results Log or press ALT+2.


Right-click in the Results Log to open a shortcut menu with commands to Copy, Print, Clear..., and View Results.

Float, Dock and Auto-Hide Windows

There are several Origin windows, which can be floated, docked, auto-hidden, or hidden. These windows include Project Explorer, Results Log, Command Window, Messages Log, and Quick Help. This allows you to customize your Origin workspace so as to maximize utility and save screen space.

Numbers in Origin

  • Displayed vs. Actual Cell Value: When you import or type your data into a workbook or matrix book, Origin uses a combination of user-specified settings to determine how to display the data in each cell. What displays is a visual representation of the data value. The actual data values are stored with the full precision allowed by the dataset's Data Type (see table below). When you perform calculations, it is the actual data values that are used and not the displayed values.
  • Display of Numbers that Exceed Cell Width: If a workbook or matrix book contains data that exceed the cell (column) width, Origin displays values as series of pound signs (######). This avoids confusion caused by a truncated display of cell values. Pound signs ###### will revert to numbers when you enter cell editing mode.
  • Missing Values in the Worksheet: When spreadsheet programs first appeared it was recognized that there was a need for a special number that was "not a number" which would - when used in a calculation - generate itself. Origin has such a number and its internal value is -1.23456789E-300. Because Origin recognizes this value as a special value, it can be used to enter a missing value into a worksheet or matrix and it can be used in calculations or scripts (for instance, to return a missing value unless some condition is met). Origin displays missing values in a worksheet or matrix sheet as "--". However, you shouldn't confuse this display (output) with what you enter as a missing value (input).
  • Decimal, Scientific and Engineering Notation: You can display workbook or matrix book data in Decimal:1000, Scientific:1E3, Engineering:1k, and Decimal:1,000 notations. You can manually choose from these data display options but you can also pre-define thresholds for automatic display of scientific notation. By default, these thresholds are set to 6 (upper) and -3 (lower).
  • Dates and Times in Origin: Origin interprets dates based on the Gregorian Calendar. Origin's mathematical system for dates and time is based on Astronomical Julian Day Numbers. This defines January 1, -4712 (January 1, 4713 BCE), 12 hours Greenwich Mean Time as zero.
Note: For more information on numbers, see

Help: Origin: Origin Help > Origin Basics > Elements of the Origin Workspace > Numbers in Origin


Origin workbooks and matrix books support the following Data Types:

Workbook Matrix Book Bytes Range of Values

double

double

8

±1.7E±308 (15 digits)

real

float

4

±3.4E±38 (7 digits)

short

short

2

-32,768 to 32,767

long

int

4

-2,147,483,648 to 2,147,483,647

char

char

1

-128 to 127

byte

char, unsigned

1

0 to 255

ushort

short, unsigned

2

0 to 65,535

ulong

int, unsigned

4

0 to 4,294,967,295

complex

complex

16

±1.7E±308 (15 digits), each 8 bytes

Topics for Further Reading

 

© OriginLab Corporation. All rights reserved.