OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis                     
 
Skip Navigation Links
All BooksExpand All Books
User GuideExpand User Guide

5 What's New in 2018


Origin 2018 New Feature Highlights

  1. App Center: Popup window for browsing, adding, updating and requesting or submitting an App. Launched from the Add Apps button in the Apps Gallery.
  2. Windows Explorer Previews: Explorer Large or Extra Large icon views display image of graph active when file was saved. Windows Explorer Preview pane scrolling of all graphs in the project file. You can now view graph windows in your Origin project file in the Windows Explorer preview pane.
  3. Worksheet Cell Formula: Support for cell-level formulas in data rows and User-parameter rows. Formulas can include cell references to other sheets/books, operators, built-in functions, variables and constants. Responsive to data updates or filter conditions.
  4. New Graph Types: Bridge Charts (MS Excel's "Waterfall"), plus 4D XYZ Surface Plots with Custom Boundary, Double-Y Box Charts and Colormapped Line Series graphs.
  5. Graph Annotation and Axis Improvements: Statistics reference lines, Arrowhead option for axis begin/end in 2D graphs, easier legend symbol customization, more options for tick label wrapping, buttons for for evenly distribute layers/objects horizontally or vertically, total label on stacked column/bar plots, proportional scale control across axis breaks, skipping filtered worksheet rows for text-labelled axis, allow number of major ticks = 0, no extra space after "/" or "-" when using /(<U>) or -<U> as axis unit, gap control for double-Y column plots, leader lines for 3D pie charts labels, lighting effects for 3D wall charts.
  6. Export User-defined Area of Graph Page: Interactively manipulate a rectangular area to define the portion of the graph page that you want to export.
  7. Unicode Support: Unicode (UTF-8) and new file formats for project (*.OPJU) and child window and template files. Added benefit of reduced file size for Origin projects.
  8. Batch Processing Improvements: Embedded graphs can be pasted or paste-linked to a cell in a summary report, generate intermediate book for row in summary sheet, batch process for existing xyz data, etc.
  9. Automatic Transfer of User Files on Upgrade: If you are upgrading from Origin 2017, you can opt for automatic transfer of User Files from 2017 to 2018.
  10. Miscellaneous Improvements: Default digits control for different analysis, data analysis skip hidden columns and plots, auto bound setting for positive-only and negative-only peaks, grouping for stats on rows, set Origin as default program to open data files, skip cols on CSV import, new toolbar buttons for re-import and clone import, autosave unsaved files.

New Features by Category

Ease of Use

Origin Project

  • Support for Unicode (UTF-8) with a new, more efficient project file structure.
  • Support for Windows Explorer previews of graphs contained in new Unicode project files.
  • Increase the maximum number of worksheets, matrix sheets or graph layers from 255 to 1024. More than 255 sheets/layers requires saving project in new .OPJU format.

Origin Central

  • Search the Graph Sample tab of Origin Central, using keywords.
  • Load Autosaved project files from Origin Central, even if you have chosen not to save the project. The autosaved project will be kept for 7 days (controlled by system variable @USKT). Disable/Enable this option from Tools:Options > Open/Close tab.

Origin Menus

  • File: Export as PDF File menu item added for worksheets.
  • Export: Export Graphs menu item for exporting worksheet-embedded graphs.

Apps

  • A small collection of pre-installed Apps useful for general scientific work is included with your Origin 2018 software.
  • Click the Apps Gallery Add Apps button to open App Center where you can browse, search, download, install, or update Origin Apps.

Graphing

  • Improvement to data point labeling at specified indices only.
  • Color Lists and Palettes: Delete from list or restore via shortcut menu commands.
  • Toolbar buttons for distributing selected objects evenly in the X or Y dimensions.

Upgrade

  • Option to carry over 2017 workspace layout on first launch.
  • Option to transfer User Files Folder (UFF) contents to new UFF.

Graphing

New Graph Types

  • Bridge Charts (aka "Waterfall Charts" in Excel) are a type of floating column chart used to plot a running total.
  • 4D XYZ with Custom Boundary uses designated color and boundary datasets to modify 3D XYZ surface plots.
  • Double-Y Box Charts
  • Colormapped Line Series plots with colors mapped to a palette, color-scale legend.

Legend Improvements

  • GUI tools add independent symbols
  • Adjust the display properties of line, symbol, color block part of legend.

Axis

  • Place reference lines on your plot by statistic (mean, median, etc.) for 2D plots or by formula for function plots.
  • Arrowheads at axis Begin and End for 2D graph types.
  • More options for wrapping of tick labels.
  • Dataset labeling of axis ticks at specified indices.
  • Plot support for skipping rows of filtered axis label data.
  • Allow number of Major Ticks to be zero.
  • No extra space after "/" or "-" when using "/<U>" or "-<U>" as Unit Display for Axis Title.
  • Proportional scale control across axis breaks.

Plot Manipulation

Graph Customization

  • Leader lines for Pie Chart labels.
  • Gap control between grouped bars (same X) for Double Y column plots.
  • Show "total" label for Stacked Column/Bar Charts.
  • Increment symbol size for each plot in a plot group.
  • Page-level control of decimal separator; useful when publishing to journals with different standards.


3D Graphing

  • 3D XYZ surface support for colormapping by a fourth worksheet column.
  • 3D XYZ surface support for custom XY boundary, with or without smoothing.
  • 3D Walls Lighting support.

Analysis

  • Set default digits for different analysis.
  • Ignore hidden worksheet columns and hidden plots in the graph for Analysis dialogs that support choosing all columns or all plots. System variable @AIP has been added to restore old behavior.
  • Automatically set Area/Amplitude boundary based on Peak Finding Direction (if + only, then boundary is >= 0; if - only, then boundary is <= 0).
  • Improvement to graphic export to include embedded graphs and graph sheets (worksheets containing a graph; often used in analysis templates).
  • Grouping by column label row support for Statistics on Rows.

Import and Export

  • New Reimport and Clone Import toolbar buttons.
  • Set Origin as default program to open data files.
  • More renaming options when importing Excel files.
  • Import dialogs now have a check box for creating a file name User Parameters row on import.
  • Support skipping columns in CSV files on import.
  • Partial Import for Excel and CSV files. This feature includes a flexible syntax for including or excluding column and row ranges.

Programming

  • New X-Function wcellfmt added to get or set properties of selected cells.
  • LabTalk string and text functions now operate based on characters and character offsets rather than bytes and byte offset. Necessitated by variable length of characters in UTF-8 encoding.

Worksheet

  • Worksheet cell formulas with support for dragging to extend formula to other cells.
  • Renaming of sheet from the Navigate Worksheets dialog.
  • New system variable @WTT allows disabling of worksheet tab tooltip.
  • Increase UNDO operation from 10 to 100.

New Apps for 2018

Apps for Origin 2018 Release:

  • New Simple Fit
  • Paired Comparison Plot
  • OPJ Searcher
  • Kernel Density for Polar and Ternary
  • Equation Solver (Pro Only)
  • Global Peak Fit (Pro Only)
  • Composite Spectrum Regression (Pro Only)
  • FFT Examiner (Pro Only)
  • Gage Study (Pro Only)
 

© OriginLab Corporation. All rights reserved.