OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis                     
 
Skip Navigation Links

11 Graphing


Creating a Graph

Graphs can be created from both hard data and from mathematical functions. With Origin, you can create over 100 graph types using Origin's built-in graph templates. Each of these graphs has been specifically chosen for its applications in various technical fields.

All graph types are accessible from the Plot menu. Note that while most graph types also have a corresponding 2D Graphs or 3D and Contour Graphs toolbar button, some do not. Until you've had time to familiarize yourself with available toolbar buttons, the Plot menu should be your "go to" place for creating graphs.

Creating most graphs involves just two steps.

  1. Select your data.
  2. Select the plot type.

Some Origin graph types have very specific data requirements. Other graphs can be created from multiple data arrangements. See the Origin Graph Types section for specific requirements.

Creating Graphs from Worksheet Data

Origin's most generic graph types -- line, column/bar, pie -- plus a lot of the more specialized types, are created from worksheet data. The following quick tutorial demonstrates importing an ASCII data file and creating a simple graph.

Tutorial: One click to create graph with selected data

  1. Open a new workbook and select File: Import: Single ASCII... from the main menu.
  2. Choose the file Samples/Curve Fitting/Multiple Gaussians.dat and click Open.
  3. Now highlight columns B(Y), C(Y), D(Y) and E(Y) by clicking and dragging across the four column headings.
  4. Click Plot > 2D: Line & Symbol: Line & Symbol. A graph window is created with four line and symbol plots. Note that the plots differ by line color and by symbol type.
  5. Return to the worksheet, and again select columns B(Y), C(Y), D(Y) and E(Y).
  6. This time, select the Plot > 2D: Multi-Panel: 4 Panel menu item. Note that a very different plot is created using the same datasets.

We were able to quickly create two different graphs using the same data. The chapter Customizing Graphs discusses customizing graphs and saving templates in more depth.

We are also able to create 3D plot types from worksheet data. The following tutorial demonstrates creating a 3D surface plot, then overlaying it with a 3D scatter plot.

Tutorial: 3D Surface Plot from XYZ Data

  1. Create a new, empty workbook window and import the file \Samples\Matrix Conversion and Gridding\XYZ Random Gaussian.dat.
  2. Highlight column C and right click. Select Set As: Z from the fly-out menu.
  3. Select Plot > 3D: Surface: 3D Colormap Surface to create a 3D Colormap Surface plot.
  4. Select the Graph: Layer Contents... menu item or right click the layer icon on the left-top of the graph to open the Layer Contents dialog. In this dialog, click on drop-down next to the Plot type button.png button and select 3D Scatter/Trajectory/Vector from the fly-out menu.
  5. Select column C from the left panel and click on the Add Plot Add plot button.png button to add the 3D scatter plot to the graph. Click OK to close the dialog.
  6. Double-click on the plot to open the Plot Details dialog. In the left panel, expand the Layer1 node and then expand the 2nd node which represents the scatter plot. Click and select the branch named Original. Be sure to leave the node-level check box selected, otherwise this plot will be hidden.
  7. In the Symbol tab on the right side, set Shape to Ball, Size to 12 and Color to Color Mapping: Col(C).
  8. In the Drop Lines tab, clear the Parallel to Z Axis check box.
  9. Select Layer1 from the left panel of the Plot Details dialog. In the Lighting tab, under Mode, select Directional. Click OK to close the dialog.
  10. Click on the scatter plot in the graph to select this plot, then in the Style toolbar, click on the Button Palette.png button and select the Rainbow palette.

Your graph should look like this:
:Tutorial 3D Plotting08.png

You can hold down the R key on your keyboard and use the mouse to freely rotate the 3D surface. With the pointer tool active, click on the layer for additional controls to move, stretch and rotate the surface.

Worksheet Column Plot Designations

The labels (X), (Y), (Z), etc. in column headings are referred to as the Column Plot Designation. Columns can also be designated as Label, Disregard, Y Error or X Error. Each plot type has certain data requirements (e.g. a simple line plot requires one X and one Y dataset) and column plot designations work in concert with settings saved in the graph template, to allow you to quickly create a graph.

To set the Column Plot Designation, select a column or multiple columns, then from the menu choose Column: Set as:<option>; or right-click and choose an option from the Set As: context menu.

In the 1st tutorial above, we plotted 2D graphs, which require Y data from one or more worksheet columns. The Y data were automatically plotted against the X column data to their left. In 2nd tutorial, we plotted a 3D graph using Z data. The Z data were plotted against X and Y data columns to the left of the Z data column.

Note: For more information on Column Plot Designations and how they affect plotting behavior, see Plot Designation, in documentation for the Column Properties Dialog Box.

Selecting Worksheet Data

Various ways to select data for plotting:

  • Single column: Click on the column heading, e.g. B(Y)
  • Multiple columns: To select a small number of contiguous columns, click on the first column heading and drag the pointer to the last column heading. To select a large number of contiguous columns, click on the first column heading, use the scroll bar at the bottom of the worksheet to locate the last column, then press the SHIFT key and click on the last column heading. To select non-contiguous columns, press the CTRL key while clicking on the desired column heading.
  • A range in a column: Click on the first cell of the range and drag to the last cell of the range.
  • Multiple ranges within a column: Select one range. Press the CTRL key while selecting each range. When plotting, each range will be treated as a separate data plot in a plot group.
  • Ranges across multiple columns: If cells are contiguous, click on the first cell and drag to the last cell. If cells are not contiguous, press the CTRL key while selecting each range. Each range selection will be treated as a separate data plot in a plot group.
  • Range(s) across all columns: Click on the first row heading and drag to the last row heading, to select multiple rows. This will select data in all columns in the worksheet. Press the CTRL key while selecting row headings for non-contiguous rows. Each range selection will be treated as a separate data plot in a plot group.
  • Entire worksheet: Press CTRL+A to select the entire worksheet; or mouse over the bottom-right corner of the blank cell in the upper-left corner of the worksheet. When the pointer becomes a downward-pointing arrow, click to select the entire worksheet.
  • Specific columns: To select columns by data in column label rows (header rows); or to select columns using a pattern, choose Edit: Select.

Creating a Graph from Matrix Data

As discussed in the Matrix Book, Matrix Sheets and Matrix Objects chapter, a matrix is a dataset of Z values arranged as an array of columns and rows which are linearly mapped to X (column) and Y (row) values. Matrix data is used to create 3D, contour and heatmap graphs -- all of which require require "3D" data. In earlier versions of Origin you had to have your data in a matrix to create such plot types but this is no longer the case (see discussion of the Virtual Matrix below). A few graph types such as a color-filled surface with error bars still require matrix data.

There are still many situations in which you will be creating 3D plots from matrix data. If data are stored in a worksheet and for one reason or another, you need to convert it into a matrix form, see Converting Worksheets to Matrixes.

Once your data are in a matrix form, plotting matrix data is simple: activate the matrix window then select your plot type using a Plot menu command or corresponding 3D and Contour Graphs toolbar button. Since you cannot plot only a portion of the matrix, data selection isn't necessary. You can, however, choose a subset of the data plot to display once the graph is created. See Editing Plot Range in the Manipulating Data Plots section of this chapter.

The Virtual Matrix

The Virtual Matrix concept was covered in the Matrix Book, Matrix Sheet and Matrix Object chapter of this Guide. To recap, a virtual matrix is a block of worksheet cells which contain Z values, with X and Y coordinates in the first row or column label row, and first column. X and Y coordinates don't have to be evenly spaced and can even contain text or date/time data.

When selecting and plotting virtual matrix data to 3D, Contour and Heatmap graph types, the worksheet's Column Plot Designations are ignored. Instead, a dialog box is opened where you designate your X and Y coordinates. The intersecting data points are then treated as Z values.

Tutorial: Contour Plot from Virtual Matrix

  1. With a new workbook active, use the File: Import: Import Wizard... menu to open the Import Wizard dialog.
  2. Press the browse button in the dialog and select the file Waterfall.dat from the Samples\Graphing subfolder.
  3. This file has an import filter already associated with it. Press the Finish button to import the file.
  4. With the workbook active, press CTRL+A to select the entire sheet.
  5. Now select the Plot > 2D: Contour: Contour - Color Fill menu item. The plotvm dialog will open.
  6. In the dialog, set the Y Values in drop-down to Column Label, and then set the Column Label drop-down to Excitation Wavelength(nm).
  7. Set the X Values in drop-down to 1st column in selection, then press OK to close this dialog.
  8. The contour plot will be created.
  9. Use the Graph: Speed Mode... menu item, then in the dialog that opens, set the Speed Mode drop-down to Off and press OK. This will turn off speed mode so that all data points are plotted (see the discussion of Speed Mode, below).
  10. Click on the contour plot to select this data plot, then from the Style toolbar, click the Palette button Button Palette.png and then select the Pumpkin Patch palette. Your graph should look similar to the image below:
GSB Graphing Contour.png

Once you customize your contour levels and colors, you can save your settings as a Theme, or simply copy-paste your customizations from one graph to another. To save a Theme, right-click on the graph and choose Save Format as Theme; or use the Colormap Theme controls on the Colormap/Contours tab of the Plot Details dialog box.

2D and 3D Function Plots

To create function plots and parametric function plots, select File: New: Function Plot menu. There are four options to choose from:

Type Function Form
2D Function Plot y = f(x)
2D Parametric Function Plot x = f1(t)
y = f2(t)
3D Function Plot z = f(x, y)
3D Parametric Function Plot x = f1(u, v)
y = f2(u, v)
z = f3(u, v)


These plot types are also accessible from the function plot buttons on the Standard toolbar.

Function Plots Buttons.png


Tutorial: 3D Function and 3D Parametric Function in Same Layer

  1. From the menu, choose File: New: Function Plot: 3D Parametric Function Plot...
  2. In the dialog that opens, click on the arrow button at the top right side of the dialog, and from the fly-out menu select the built-in example Partial Torus (System) and press OK to close the dialog. The function plot will be created.
  3. With the function plot window active, invoke the menu File: New: Function Plot: 3D Function Plot....
  4. In the dialog that opens, enter -5 and 5 for the From and To edit boxes for x and y scale.
  5. In the Z(x,y) edit box, enter 0.
  6. Set the drop-down at the bottom left corner of the dialog to Add to Active Graph and press OK to close dialog.
  7. The Z=0 plane will be added to the graph, and the plane will properly intersect the parametric surface plot. You can hold down the R key and use the mouse to freely rotate the plot.

GSB Graphing FuncPlot.png

  • Some function plot dialogs provide sample formulas. Click the arrow button beside Theme at the top of the dialog box to access them. You can download more examples at http://originlab.com/3dfunctions.
  • For 2D parametric, 3D, and 3D parametric function plots, data is generated when the function plot is created. To create data for 2D function plots, right-click the plot and choose Make dataset copy of Function or if on the Function tab in Plot Details, click the Workbook button.
  • Besides function plots, you can also create graphs with all built-in and user-defined nonlinear curve-fitting or surface-fitting functions. From the menu, choose Analysis: Fitting: Simulate Curve... or Simulate Surface.... You can even add noise to the plot. Corresponding data is created as well.

Plotting without Using Column Plot Designations

While Column Plot Designations remain an important concept, they are no longer required by many Origin graphing and analysis operations. For instance, the Plot Setup dialog box allows you to freely specify which column is used as X, Y, etc. when plotting, thereby overriding the Column Plot Designations.

In order to make full use of the Plot Setup dialog box, you need to have some familiarity with the hierarchy of objects contained in the Origin graph window.

Pages, Layers, Plots and the Active Plot

Each Origin graph window is comprised of a single, editable graph page. The graph page is defined by the white area inside the graph window. Anything that lies outside the page is not printed or exported. By default, the dimensions of the graph page are defined by the printable area of your default printer driver; without adjusting settings, a printed graph should fill the printed page.

The Graph Page-3B.png
  • The graph page must contain at least one, and may contain as many as 1024, graph layers.
  • Each graph layer generally contains one or more data plots (graphical depictions of datasets). Note that the graph in the image above contains three graph layers, represented by the three non-printing layer icons in the upper-left corner of the graph page. Note that there is one layer icon which is highlighted, indicating the active layer.
  • Just as there is only one active layer, there is only one active plot in a graph. Usually, the active plot is the first plot in the active layer. To verify which plot is active, click on the Data menu while the graph is active. The active plot will have a check mark beside it.
Active dataset data menu.png


The hierarchical structure of the graph page can be seen in these places:

  • The Plot Details Dialog Box (Format: Page Properties ...)
  • The Object Manager (View: Object Manager)
  • The Plot Setup Dialog Box (Graph: Plot Setup...)


Page structure dialogs 2.png

The Plot Setup Dialog Box

The Plot Setup dialog box is a flexible all-in-one plotting tool for creating graphs and manipulating the data plots in an existing graph.

  • Creating graphs without regard to Column Plot Designations
  • Creating graphs from a combination of data sources: multiple worksheets, workbooks, matrix books, loose datasets, etc.
  • Creating graphs combining multiple plot types.
  • Adding, removing, replacing data plots.
  • Grouping or ungrouping data plots.
  • Reordering data plots in a layer or moving data plots to another layer.

Plot-setup entire2.png

To create a graph with the Plot Setup dialog, make sure no data is selected in the active worksheet and choose the plot type that you want to create (from the Plot menu or by clicking on a toolbar button).

To open the Plot Setup dialog for an existing graph window, right-click on any layer icon in the upper left corner of the graph window and select Plot Setup..., or choose menu Graph: Plot Setup....


Tutorial: Creating a Simple Line Plot with the Plot Setup Dialog Box

  1. Click the New Workbook button on the Standard toolbar.
  2. Click File: Import: Single ASCII, browse to the Origin installation folder and import the file \Samples\Curve Fitting\Step01.dat. Starting from column B, columns are actually paired - X data and Y data -- but by default all columns are assigned a "Y" Column Plot Designation on import.
  3. Without selecting any data, click Plot > 2D: Line: Line. This opens the Plot Setup dialog box.
  4. Click the two "double-arrow" buttons to show all three dialog box panels.
  5. In the middle panel, select the "X" box for Column B (Sensor Ax) and the "Y" box for Column C (Sensor Ay), then click the Add button to add the plot to Layer 1 in the bottom panel.
  6. Select the "X" box for column D (Sensor Bx) and the "Y" box for Column E (Sensor By), then click Add.
  7. Select the "X" box for column F (Sensor Cx) and the "Y" box for Column G (Sensor Cy), then click Add. Three plots are added to Layer 1.
  8. Press CTRL and click on each plot in the bottom panel to select all three, then right-click and choose Group.
  9. Click OK to create a grouped line plot.
Plot setup mini tutorial group.png

Tutorial: Creating a Graph with Data from Multiple Worksheets

  1. Click the New Workbook button on the Standard toolbar.
  2. Click File: Import: Multiple ASCII, browse to the Origin installation folder and select Sensor01.dat, Sensor02.dat and Sensor03.dat under \Samples\Curve Fitting\ to import. After Import, 3 workbooks are created.
  3. Without selecting any data, click Plot > 2D: Line+Symbol: Line+Symbol. This opens the Plot Setup dialog box.
  4. Expand the top panel if it is hidden. From the Available Data list, choose Worksheets in Folder.
  5. Select Sensor01, Sensor02 and Sensor03 sheets in the top panel.
  6. In the middle panel, select the "X" box for Column A (Displacement) and the "Y" box for Column B (Sensor Output), then click the Add button.
  7. Click OK to create a grouped Line+Symbol plot using Sensor Output columns from 3 worksheets.
Plot setup mini tutorial group 2.png
  • The Plot Setup middle panel only allows choosing one X column at a time.
  • If your worksheet is set up with the correct Column Plot Designations (e.g. XYXY) but you only want columns with same Long Name, click the toggle in the upper-right corner of middle panel so that only plottable columns show (e.g. for 2D plot types, X columns are not shown). Then you can sort the columns and select all columns with same Long Name and plot them together. The Y columns will be plotted against corresponding X columns.
  • To change a data plot's type, choose the corresponding plot in bottom panel. Corresponding X and Y columns will show in middle panel. Choose a new plot type in middle panel and click the Replace button.
  • All data plots in a group share the same plot type. If you want to change the plot type of a single plot in a group, right-click the Group node in bottom panel and Ungroup first.
  • Drag and drop data plots in the bottom panel to move them to different layers.
  • If the bottom panel is hidden and you have selected columns in the middle panel, you can directly click the OK button to create your graph.

Manipulating Data Plots

The following sections discuss higher level modifications to existing graphs such as changing plot type, adding or removing plots from the layer and controlling the density of plotted points (Speed Mode). For more detailed plot customizations, including those involving such things as changing plot symbols, colors, and legend customizations, see the Customizing Graphs chapter.

The following methods of manipulating data plots in the graph window are fairly easy to use. Thus, you may want to choose File: Open Template and pick your template to create a blank graph window. Then, using the methods below you can add and group data plots in the graph.

Changing Plot Type

Some Origin plot types (e.g. scatter, line, line+symbol) allow you to interchange the plot type of an existing plot with a few other select plot types. Some examples:

  • Scatter, line, line+symbol, column/bar are interchangeable.
  • 3D scatter/trajectory/vector, 3D bars, 3D surface are interchangeable.


To change the plot type of an existing plot:

  • Right-click on the data plot and choose Change Plot to: Graph Type from the shortcut menu.
  • Click on the data plot and choose Format: Plot Properties and in Plot Details choose from the Plot Type drop-down list.
  • Click on the data plot, then click one of the supported graph toolbar buttons.


Note that if you switch plot types and the selected plot is part of a plot group, all plots in the group are switched.

Exchanging Data Plots

You can quickly change the data source (X, Y, or worksheet) of a plot using these context menu commands. Right-click on a data plot, then select one of these options:

  • Change X. This menu item allows you to change the assignment of X data to another data column in the same worksheet.
  • Change Y. This menu item allows you to change the assignment of Y data to another data column in the same worksheet.
  • Change Worksheet. This menu item allows you to replace both X and Y with data from another worksheet. The selected worksheet should have the same Short Names, the same Column Plot Designations and the same row index range as the current worksheet.

If you have a grouped data plot, then clicking once on any of the plots in the group will select the entire group. Click a second time to select a particular member of the group. The context menu options to change worksheet, X, or Y are available only when a single data plot is selected.

Tutorial: Changing X and Y assignment of a data plot

  1. Start with a new workbook and import the file automobile.dat from the Samples\Statistics sub-folder of the Origin installation folder.
  2. Select the Gas Mileage column and select the Plot: Symbol: Scatter menu item. The Gas Mileage column is plotted against the default X column Year.
  3. Right-click on the data plot and select Change X: Engine Displacement. The Gas Mileage column is now plotted against Engine Displacement.
Note: If new data is significantly outside of the current range for X or Y axes, you will be asked if the graph should be rescaled. If data are not significantly different, you may want to manually rescale the graph (Hot key: CTRL+R).

If you perform analysis on the data plot (e.g. linear regression with Recalculate set to Auto), the fit results will automatically update when you change X/Y or the worksheet.

Adding, Removing and Hiding Data Plots

Use the following methods to add or remove data plots from a graph.

Adding Data with the Add Plot to Layer Menu Command

This is a simple method for adding a range of data to an existing Line, Scatter, Line + Symbol, Column or Area graph:

  1. Highlight your worksheet data.
  2. Go to the graph window where you want to add data. If there are multiple layers in the graph, press the layer icon to activate the desired layer.
  3. From the menu, choose Graph: Add Plot to Layer: Graph Type.
  • You can use the Graph: Add Error Bars... menu item to add error bars, calculated from statistics such as standard deviation.
  • Error data will be output beside the data column in the worksheet. This only works for the active plot. You can set the active plot from the Data menu. The active plot has a check mark beside it.

Adding Data by Drag and Drop

You can add data to a graph by drag and drop. When using this method, Origin relies on worksheet Column Plot Designations to create the plot.

  1. Select the worksheet data (one or more columns or a range of one or more columns).
  2. Move the mouse over the left or right edge of the selected range.
  3. When the pointer looks like this Drag and drop mouse.png, hold down the left mouse button and drag the data to the graph window. Release the mouse.
  4. If there are multiple layers in the graph, drag the data to the desired layer, then release the mouse.

Usually the current plot type is used when plotting by drag-and-drop. To change the global plot type to use when drag and drop, choose Tools: Options... from the main menu. Go to the Graph tab and change the global Drag and Drop plot type.

Adding and Removing Data with the Layer Contents Dialog Box

Open the Layer Contents dialog box by double-clicking or right-clicking on the layer icon(s) in the top left corner of the graph page. Controls in the left panel can be used to filter and list available datasets. The right panel lists datasets that are plotted in the active layer.

Layer contents dialog.png

Controls in the center of the dialog box allow you to add or remove plots from the active graph layer. When adding data to the graph, click the list button (downward-pointing arrow) to pre-select the plot type before adding data to the layer. Use controls in the right panel to group or ungroup plots, or re-order plots in the layer.


Adding, Removing, Replacing or Hiding Data Plots with the Plot Setup Dialog Box

Among other things, the Plot Setup dialog box can be used to add or remove data plots from the graph.

  1. To add plots to the graph, use the top panel of Plot Setup to identify your source data.
  2. Use the controls in the middle panel to specify the plot type and how the data selection should be treated (as X, Y, yError or Label).
  3. In the bottom panel, choose the Layer to which you want to add plots, then click the Add button.
  4. To remove a plot from the layer, select the plot in the bottom panel, then right-click and choose Remove.
  5. To hide a plot, uncheck the Show check box for the plot.
  6. To replace a plot, select the plot in bottom panel, then change the X and Y selection and plot type in middle panel and click the Replace button.
Plot Setup Removing.png

Adding Data by Direct ASCII Import

You can import ASCII files directly into the active graph window using the the Import ASCII toolbar button. Note that this method works only with files having a simple structure and it supports only the simplest of graph types - Line, Scatter, Line + Symbol, Column and Bar charts.

  1. Click the Import ASCII Button Import ASCII.png button. This opens the Import ASCII dialog box.
  2. Choose a file.
  3. Click Open.

The file is imported and plotted in the active graph window.

Adding Data by Copying and Pasting a Plot

You can copy a plot from an existing graph window and paste it into the same or another window.

  1. Click on the plot to select it and press CTRL+C.
  2. Click on the target graph and press CTRL+V.

Simultaneously, a ClipbN worksheet is created. You can open this worksheet by double-clicking on the plot, then clicking the Workbook button at the bottom of Plot Details; or right-click on the plot in the graph window or in the Object Manager and choose Create worksheet ClipbN.

You can also "paste" a copied plot to a worksheet cell. Select a cell and press CTRL+V to fill the column(s) with plot data.

Removing or Hiding Plots with the Object Manager

The Object Manager is a dockable panel that allows for easy manipulation of graph layers and data plots. See the section on The Object Manager in this Guide.

To hide or remove plots, right-click on a plot and choose from the shortcut menu:

OM remove hide menu.png
  • To show or hide plots of the same Long Name.
  • Show all plots.
  • Remove a plot from the graph window (not the same as hiding).
  • When you right-click on a plot, there is a Remove shortcut menu item. If the plot is part of a group, the entire group will be removed.
  • When you right-click on a plot, you can use the Hide Data Plot and Hide Others shortcut menu items to quickly hide selected plots (restore plots by enabling their display in the Object Manager or in Plot Details).

Removing or Hiding Data with Plot Details

In the left panel of the Plot Details dialog box (Format: Plot Properties), right-click on a plot and choose Remove or Hide from the context menu. Remove will delete the data plot from the graph so if you just want to temporarily hide a plot, choose Hide. Neither of them will delete data from worksheet or matrix.

PD Hide vs Remove.png

Deleting Plots using the Delete Key

Click on a data plot (either in the graph window or Object Manager) and press the Delete key. If the selected plot is part of a group, the entire group is deleted. This action does not delete worksheet or matrix data. To restore the deleted plots, choose Edit: Undo Remove Plot from the main menu.

Editing Plot Range

Once a graph is made, you can edit the plot display range, specifying only a portion of the plotted data:

  • Right-click on the plot and choose the Edit Range... shortcut menu command. Edit the From and To values.
  • In the right panel of the Layer Contents dialog box (Graph: Layer Contents), turn on the Range column by right-clicking on the column headings and choosing Range. Click on a plot's range values, then click the ... button that appears to the right side of that column.
  • In the bottom panel of Plot Setup (Graph: Plot Setup), click on the plot range in the Range column and click the ... button that appears to the right side of that column.

Choose Graph: Rescale to Show All to rescale the graph after editing the plot range.

Grouping Data Plots

When you make multiple range or column selections, then create a graph, Origin groups the resulting data plots in the graph layer. This applies to most 1D (statistical) and 2D graphs, plus 3D XYY (XYY 3D bar, 3D ribbon, 3D wall, and 3D waterfall plots) and 3D XYZ (3D scatter, 3D bar) graphs.

Grouping provides for quick creation of presentation-ready graphs because each plot in the group is assigned a differentiating set of plot attributes (line color = black, red, green...; symbol shape = square, circle, triangle...; etc.). Assignments are made by cycling through a pre-determined (user-modifiable) increment list of styles. For instance, the first plot of a grouped line plots might be denoted by a black line; the second plot might be denoted by a red line (the second color in the color list), the third plot by a green line (the third color in the color list), and so on.

Tutorial: Creating a simple grouped data plot

  1. Open a fresh worksheet and click the Import Single ASCII button Button Import Single ASCII.png on the Standard toolbar.
  2. Browse to the Samples\Graphing subfolder in the Origin software folder and Open GROUP.DAT.
  3. Select B(Y), C(Y), and D(Y) columns
  4. Click the Line & Symbol button Button Line And Symbol.png on the 2D Graphs toolbar. Note that line and symbol color and symbol type are automatically differentiated for each plot.

Tutorial: Grouping (or ungrouping) plots manually

  • Via the Layer Contents dialog box
  1. To open the Layer Contents dialog box, double-click on the layer n icon in upper-left corner of the graph window.
  2. To create a group, select the desired data sets from the Layer Contents list (use CTRL + select, SHIFT + select, or simply drag the mouse to select multiple data sets).
  3. Click Group. Note that each plot in Layer Contents is now preceded by a gn (for "group1", "group2", etc.).
  4. To ungroup, click on one of the grouped data plots in the Layer Contents list and click Ungroup.


  • Via the Plot Setup dialog box
  1. To open the Plot Setup dialog box, ALT + double-click on the layer n icon in upper-left corner of the graph window.
  2. To create a group, select the desired plots from the Plot List (use the CTRL or SHIFT keys to select multiple data sets).
  3. Right-click and select Group. Note that a Group icon now precedes the selected plots in the Plot List.
  4. To ungroup, right-click on the Group icon and choose Ungroup from the shortcut menu.

Speed Mode

With Speed Mode, you can control the number of data points displayed in a graph layer. This option is most useful when working with large data sets. Speed Mode can be turned on for any 2D or 3D graph. When Speed Mode is enabled, the layer icon displays in red and a Speed Mode is On watermark appears in the layer. The watermark is not included when printing, copying, or exporting the graph.

Increasing Screen Drawing Speeds 02.png

To adjust Speed Mode settings:

  1. With your graph active, select Format: Layer Properties from the Origin menu.
  2. Select the Size/Speed tab.
  3. For plots created from worksheet data, Select the Worksheet Data, Maximum Points Per Curve check box to enable Speed Mode for all the data plots in the layer that are created from worksheet data. Type the desired value (n) in the associated text box. If the number of data points in a data plot exceeds n, Origin displays a subset of the data plot containing n points, drawn by extracting values at regular intervals from the data set.
  4. For 3D data plots created from a matrix or for contour data in the layer, Select the Matrix Data, Maximum Points Per Dimension check box to enable Speed Mode. Type the desired value (n, m) in the X and Y text boxes. If the number of data points in a data plot exceeds n or m, Origin displays a subset of the data plot composed of -- at maximum -- n by m points. This subset is drawn by extracting values at regular intervals from the matrix columns (X) and rows (Y).

For broad control, you can select Speed Mode from the Graph menu. This opens the speedmode X-Functiondialog. The dialog lets you specify a number of options for where your changes should apply ( Target ) as well as a range of Speed Mode settings from Off to On - High.

Click the Enable/Disable Speed Mode Button Speedmode.png button on the Graph toolbar, to toggle Speed Mode on/off for all layers in the graph window.

To turn off the Speed Mode is On watermark:

  1. Select Tools: Options to open the Options dialog box.
  2. Select the Graph tab and clear the Speed Mode Show Watermark check box and refresh the graph, if needed.
Notes on Speed Mode:
  • The Speed Mode controls on the Size/Speed tab of the layer's Plot Details only apply to what you see on screen. They do not apply to graphs that are printed or exported, by default. If you wish to skip points in printouts, use controls in the Print dialog. See the discussion of the Skip Points feature as it applies to some graph windows in the Origin Help file. If you wish to apply Speed Mode settings to graphic export, please see this discussion of Performance Group controls on the Miscellaneous tab of the Plot Details dialog box or use controls under the Export Settings node in the Graph Export dialog.
  • All Speed Mode settings are saved with the graph template. If you make changes to Speed Mode settings for a particular graph type, you will have to resave the graph template to make those changes permanent.
  • Always exercise caution when using Speed Mode. Since Speed Mode systematically weeds out a portion of your data points, it should be kept in mind that any graph in which Speed Mode is turned on, may -- or may not -- accurately represent your data, to your satisfaction. Always familiarize yourself with your data and adjust and compare Speed Mode settings to ensure that trends in your data are accurately depicted.

Publishing Your Graph: Copy/Paste, Image Export, Slide Shows and Printing

There are a number of ways to present your finished graph.

  • Copy a graph page and paste it in other applications such as Word, Powerpoint, etc.
  • Export graph page as an image file (raster or vector).
  • Send Graphs to Powerpoint.
  • Printout.
  • Slideshow within Origin.
  • Create Movies.

Please read details in the Publishing and Export chapter of this User Guide and the "Topics for Further Reading" there.

Origin Graph Types

Origin supports over 100 plot types. Origin's 2D graphs are plotted from Worksheet data. Origin's 3D graph are plotted from Worksheet data (XYY, XYZ), a worksheet arrangement we refer to as a Virtual Matrix or from Matrix data.

Origin Graph Samples of most 2D and 3D graph types are included with your Origin software. To view graphs, supporting data and guidelines for making the graphs, choose Help: Origin Central; or click on the Origin workspace to activate Origin and press F11 on your keyboard.


The tables below list all Origin 2D and 3D graph types, grouped as they appear in the Plot menu:

Plot Menu.png
  • The Plot menu icon for each graph type precedes the graph name.
  • The Notes column provides basic information on data requirements. For more specific data requirements, click on the graph name beside the Plot menu icon.

2D Graphs

Beginning with Origin 2018b, you can modify the size of the Plot menu icons using the LabTalk system variable @PPS. To find out how to change the value of a system variable, see Customizing Origin Using System Variables.

Plot Menu Group Graph Types Notes
Line

Line PM 75.png Line
Button Horizontal Step PM 75.png Horizontal Step
Button Vertical Step PM 75.png Vertical Step
Button Spline PM 75.png Spline

  • Start with a Worksheet.
  • Select one or more Y columns or at least a portion of one Y column.
  • Multiple Y columns are grouped in layer.
  • If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For specific data requirements, follow links in the Graph Types column.
Scatter

Scatter PM 75.png Scatter
Button Scatter Center PM 75.png Scatter Central
Button Column Scatter PM 75.png Column Scatter
Button Y Error PM 75.png Y Error
Button X Y Error PM 75.png XY Error
Button Vertical Drop Line PM 75.png Vertical Drop Line
Button Bubble PM 75.png Bubble
Button Color Map PM 75.png Color Mapped
Button Bubble And Color Mapped PM 75.png Bubble + Color Mapped
Button Error Band PM 75.png Error Band

  • Start with a Worksheet.
  • If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For specific data requirements, follow links in the Graph Types column.
Line + Symbol

Button Line And Symbol PM 75.png Line + Symbol
Button Line Series PM 75.png Line Series
Button 2 Point Segment PM 75.png 2 Point Segment
Button 3 Point Segment PM 75.png 3 Point Segment
Button Spline Connected PM 75.png Spline Connected

  • Start with a Worksheet.
  • Select one or more Y columns or at least a portion of one Y column.
  • Multiple Y columns are grouped in the graph layer (except Line Series).
  • For Line Series graph, select 2 or 3 Y columns.
  • If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For specific data requirements, follow links in the Graph Types column.
Function

Button Function New 2D 75.png New 2D Plot
Button Function New 2D Parametric 75.png New 2D Parametric Plot

  • Function plots are not created from physical data.
  • Once a function plot is created, you can obtain the derived dataset.
  • For more information on function plots, follow links in the Graph Types column.
Bar

Button Column PM 75.png Column
Button Column Label PM 75.png Column + Label
Button Bar PM 75.png Bar
Button Stack Column PM 75.png Stacked Column
Button Stack Bar PM 75.png Stacked Bar
Button 100p Stacked Column PM 75.png 100% Stacked Column
Button 100p Stacked Bar PM 75.png 100% Stacked Bar
Button Floating Column PM 75.png Floating Column
Button Floating Bar PM 75.png Floating Bar

  • Start with a Worksheet.
  • For Bar, Column or Column + Label, select one or more Y columns (multiple Y columns are grouped in layer).
  • For Floating Bar/Column, select two Y columns.
  • For Stack graphs, select two or more Y columns.
  • If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For specific data requirements, follow links in the Graph Types column.
Pie

Button 3D Color Pie 75.png 3D Color Pie Chart
Button 2D BW Pie 75.png 2D B&W Pie Chart

  • Start with a Worksheet.
  • Select exactly one Y column or a range from one Y column.
  • If there is an associated X column, the X data are used in the graph legend; otherwise row number is used.
  • For specific data requirements, follow links in the Graph Types column.
Area

Button Area 75.png Area
Button Stacked Area 75.png Stacked Area
Button 100p Stacked Area 75.png 100% Stacked Area
Button Fill Area 75.png Fill Area
Button Fill Area 2Color 75.png Fill 2 Colors

  • Start with a Worksheet.
  • If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For specific data requirements, follow links in the Graph Types column.
Multi-Y

Button DoubleY 75.png Double-Y
Button 2Ys Col Line Symbol 75.png 2Ys, Column-Line&Symbol
Button DoubleY Column 75.png Double-Y Column Graph
Button 3Ys Y-Y-Y 75.png 3Ys Y-Y-Y
Button 3Ys Y-YY 75.png 3Ys Y-YY
Button 4Ys Y-YYY 75.png 4Ys Y-YYY
Button 4Ys YY-YY 75.png 4Ys YY-YY
Button MultipleY Axes 75.png Multiple Y Axes...
Button Stacked Lines byY 75.png Stacked Lines by Y Offsets
Button Color Map Line Series 75.png Colormapped Line Series

  • Start with a Worksheet.
  • Select two or more Y columns.
  • Multiple Y Axes opens interactive dialog. Choose plot type, number of axes, plots per layer, axis color to match plot, etc.
  • For specific data requirements, follow links in the Graph Types column.
Multi-Panel

Button Vertical 2 Panel 75.png Vertical 2 Panel
Button Horizontal 2 Panel 75.png Horizontal 2 Panel
Button 4 Panel 75.png 4 Panel
Button 9 Panel 75.png 9 Panel
Button Stack 75.png Stack...
Button Multiple Panels 75.png Multiple Panels by Label...

  • Start with a Worksheet.
  • Select one Y column (or range) per panel.
  • If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For specific data requirements, follow links in the Graph Types column.
Zoom

Button Zoom 75.png Zoom

  • Start with a Worksheet.
  • Select at least one Y column or a range from at least one Y column.
  • If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For specific data requirements, follow the link in the Graph Types column.
Box

Button Box Chart 75.png Box Chart
Button Interval Plot 75.png Interval Plot
Button Marginal Box Charts 75.png Marginal Box Charts
Button Bar Box Chart 75.png Bar Chart
Button Box Overlap 75.png Box Overlap
Button Box Normal 75.png Box Normal
Button Bar Overlap 75.png Bar Overlap
Button Bar Normal 75.png Bar Normal
Button Scatter Inteval 75.png Scatter Interval
Button DoubleY Box 75.png Double Y Box

  • Start with a Worksheet.
  • Select at least one Y column or a range from at least one Y column.
  • For specific data requirements, follow the link in the Graph Types column.
Histogram

Button Box Chart 75.png Histogram
Button Histogram Probabilities 75.png Histogram + Probabilities
Button Stacked Histograms 75.png Stacked Histograms
Button Marginal Histograms 75.png Marginal Histograms
Button Distribution 75.png Distribution
Button Histrogram with Label 75.png Histogram with Labels

  • Start with a Worksheet.
  • Select at least one Y column or a range from at least one Y column.
  • For specific data requirements, follow links in the Graph Types column.
2D Kernel Density

Button 2D Kernel Density 75.png 2D Kernel Density

  • Start with a Worksheet.
  • Select at least one Y column or a range from at least one Y column.
  • For specific data requirements, follow the link in the Graph Types column.
Scatter Matrix

Button Scatter Matrix 75.png Scatter Matrix

  • Start with a Worksheet.
  • Select two Y columns or a range from two Y columns.
  • For specific data requirements, follow the link in the Graph Types column.
Probability

Button Probability Plot 75.png Probability Plot]
Button QQ Plot 75.png Q-Q Plot

  • Start with a Worksheet.
  • Select one Y column or a range from one Y column.
  • For specific data requirements, follow the link in the Graph Types column.
Pareto

Button Pareto Binned 75.png Pareto Chart - Binned Data
Button Pareto Raw 75.png Pareto Chart - Raw Data

  • Start with a Worksheet.
  • Select one Y columns or a range from one Y column (Raw), or a Y column of Binned results.
  • For specific data requirements, follow the link in the Graph Types column.
QC (X-bar R) Chart

Button QC X-bar 75.png QC (X-bar R) Chart

  • Start with a Worksheet.
  • Select at least one Y column or a range from at least one Y column.
  • For specific data requirements, follow the link in the Graph Types column.
Contour

Button Contour Color 75.png Contour - Color Fill
Button Contour BWLines 75.png Contour B/W Lines + Labels
Button Contour Gray 75.png Gray Scale Map
Button Heat Map 75.png Heatmap

  • Contour Color Fill, B/W Lines + Labels, Gray Scale Map, Contour Profiles: XYZ, Virtual Matrix, Matrix.
  • Heatmap: Virtual Matrix, Matrix.
  • For specific data requirements, follow links in the Graph Types column.
Polar

Button Polar thetaX rY 75.png Polar theta(X) r(Y)
Button Polar rX thetaY 75.png Polar r(X) theta(Y)
Button Bar theta r 75.png Bar theta, r
Button Bar r theta 75.png Bar r, theta
Button Line Symbol theta r 75.png Line + Symbol theta, r
Button Line Symbol r theta 75.png Line + Symbol r, theta
Button Symbol theta r 75.png Symbol theta, r
Button Symbol r theta 75.png Symbol r, theta
Button Polar Contour thetaX rY 75.png Polar Contour theta(X), r(Y)
Button Polar Contour rX thetaY 75.png Polar Contour r(X), theta(Y)

  • Start with a Worksheet (Polar, Polar Contour) or Matrix (Polar Contour only).
  • For data requirements and other information on all polar graphs except polar contour graphs, see Polar Graph.
  • For data requirements and other information on polar contour graphs from XYZ data, see Polar Contour from XYZ Data.
  • For data requirements and other information on polar contour graphs from matrix data, see Polar Contour from Matrix Data.
Vector

Button Vector XYAM 75.png Vector XYAM
Button Vector XYXY 75.png Vector XYXY

  • Start with a Worksheet.
  • For XYAM Vector, select three Y columns (or a range of the three Y columns).
  • For XYXY Vector, select two X columns and 2 Y columns (or a range of two X and two Y columns).
  • For specific data requirements, follow links in the Graph Types column.
Ternary

Button Ternary 75.png Ternary
Button Ternary Line Symbol 75.png Ternary, Line+Symbol
Button Ternary Line 75.png Ternary, Line
Button Ternary Contour 75.png Ternary Contour
Button Piper Trilinear 75.png Piper

  • Start with a Worksheet.
  • For specific data requirements, follow links in the Graph Types column.
Stock

Button Hi Lo Close 75.png High-Low-Close
Button Japanese Candlestick 75.png Japanese Candlestick
Button OHLC Bar 75.png OHLC Bar Chart
Button OHLC Volume 75.png OHLC-Volume
Button Line Financial 25.png Line

  • Start with a Worksheet.
  • For specific data requirements, follow links in the Graph Types column.
Bridge Chart

Button Bridge Chart 75.png Bridge Chart
Button Stacked Bridge Chart 75.png Stacked Bridge Chart
Button Stacked Total Bridge Chart 75.png Stacked Total Bridge Chart
Button Horiz Bridge Chart 75.png Horiz-Bridge Chart

  • Start with a Worksheet.
  • Select one or more Y columns (or a range of one or more Y columns). If there is an X column to the left of the Y column(s), this X column is treated as categorical data; otherwise, the worksheet's row indices will be used.
  • Origin Bridge Charts are variants of one basic chart type. For more information, see Bridge Charts.
Profile

Button Contour Profile 75.png Contour Profiles
Button Image Profile 75.png Image Profiles

  • Start with a Worksheet, Virtual Matrix or Matrix (Image Profiles, Matrix only).
  • For specific data requirements, follow links in the Graph Types column.
Smith Chart

Button Smith Charts 75.png Smith Chart

  • Start with a Worksheet.
  • Select at least one Y column of values (or a range from at least one column). If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For more information, follow the link in the Graph Types column.
Wind Rose

Button Wind Rose Binned 75.png Wind Rose - Binned Data
Button Wind Rose Raw 75.png Wind Rose - Raw Data

  • Start with a Worksheet.
  • Select one or more Y columns or a range from one or more Y columns. If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For specific data requirements, follow links in the Graph Types column.
Radar

Button Radar 75.png Radar
Button Radar Line Fill 75.png Line Fill
Button Radar Line 75.png Line
Button Radar Symbol 75.png Symbol

  • Start with a Worksheet.
  • Select at least one Y column (or a range from at least one Y column). The X column displays as the title of the radial axis around the chart. If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • Radar Charts and Spider Charts are created from the same basic Origin plot type.
  • For more information, see Spider Charts.
Group Plot

Button Grouped Columns Indexed 75.png Grouped Columns - Indexed Data
Button Grouped Box Indexed 75.png Grouped Box Charts - Indexed Data
Button Grouped Box Raw 75.png Grouped Box Charts - Raw Data

  • Start with a Worksheet.
  • Select at least one Y column (or a range from at least one Y column), plus a second column with grouping information. If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For more information, follow the link in the Graph Types column.
Trellis Plot

Button Trellis 75.png Trellis Plot

  • Start with a Worksheet.
  • Select at least one Y column as input data. Optionally, you can have an additional associated Y error column for each Y column. Other column(s) generally contain grouping information.
  • For more information, see the link in the Graph Types column.

3D Graphs

Beginning with Origin 2018b, you can modify the size of the Plot menu icons using the LabTalk system variable @PPS. To find out how to change the value of a system variable, see Customizing Origin Using System Variables.

Plot Menu Group Graph Types Notes
Line + Symbol

Button 3D Scatter 75.png 3D Scatter
Button 3D Scatter Error Bar 75.png 3D Scatter + Error Bar
Button 3D Line 75.png 3D Line
Button 3D Trajectory 75.png 3D Trajectory

  • Data requirements vary by plot type. See links in the Graph Types column.
Function

Button New 3D Function 75.png New 3D Plot
Button New 3D Parametric 75.png New 3D Parametric Plot

  • Function plots are not created from physical data.
  • When a 3D Function is plotted, a matrix of Z values is simultaneously generated.
  • For more information on function plots, follow links in the Graph Types column.
Vector

Button 3D Vector XYZ XYZ 75.png 3D Vector XYZ XYZ
Button 3D Vector XYZ 75.png 3D Vector XYZ dXdYdZ

  • Start with a Worksheet.
  • Select 6 worksheet columns, designated as XYZ XYZ.
  • For more information, see links in the Graph Types column.
Bar

Button 3D Bars 75.png 3D Bar Graph
Button 3D Stacked Bars 75.png 3D Stacked Bars Graph
Button 3D 100pc Stacked Bars 75.png 3D 100% Stacked Bar Graph

  • Start with a Worksheet (XYZ) or a Virtual Matrix or Matrix of Z values.
  • For specific data requirements, follow links in the Graph Types column.
Surface

Button 3D Color Fill Surface 75.png Color Fill Surface
Button 3D X Constant 75.png X Constant with Base Surface
Button 3D Y Constant 75.png Y Constant with Base Surface
Button 3D Colormap 75.png Color Map Surface
Button 3D Colormap Projection 75.png Color Map Surface with Projection
Button 3D Wire Frame 75.png Wire Frame
Button 3D Wire Surface 75.png Wire Surface

  • Start with a Worksheet or Matrix.
  • For specific data requirements, follow links in the Graph Types column.
Ternary

Button 3D Ternary CMAP 75.png 3D Ternary Colormap Surface
Button 3D Ternary Symbol 75.png 3D Ternary Symbol

  • Start with a Worksheet.
  • Select two Z columns (XYZZ) or a range of data from two Z columns (Z columns may be multiples of 2).
  • For more information, follow links in the Graph Types column.
Waterfall

Button Waterfall 75.png nWaterfall
Button Waterfall Y Color 75.png Waterfall: Y Color Mapping
Button Waterfall Z Color 75.png Waterfall: Z Color Mapping
Button 3D Waterfall 75.png 3D Waterfall
Button 3D Waterfall Y CMAP 75.png 3D Waterfall: Y Color Mapping
Button 3D Waterfall Z CMAP 75.png 3D Waterfall: Z Color Mapping

  • Start with a Worksheet.
  • Select at least one Y column (or a range from at least one Y column). Ideally, select at least two Y columns (or a range of at least two Y columns). If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For more information, see the links in the Graph Types column.
Multi-Y

Button XYY 3D Bars 75.png XYY 3D Bars
Button XYY 3D Stacked Bars 75.png XYY 3D Stacked Bars
Button XYY 3D 100pc 75.png XYY 3D 100% Stacked Bars

  • Start with a Worksheet.
  • Select at least one Y column (or a range from at least one Y column). Ideally, select at least two Y columns (or a range of at least two Y columns). If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For more information, see the links in the Graph Types column.
3D Ribbons

Button 3D Ribbons 75.png 3D Ribbons

  • Start with a Worksheet.
  • Select at least one Y column (or a range from at least one Y column). Ideally, select at least two Y columns (or a range of at least two Y columns). If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For more information, see the link in the Graph Types column.
Walls

Button 3D Walls 75.png 3D Wall Graph
Button 3D Stacked Walls 75.png 3D Stacked Wall Graph
Button 3D Stacked Walls 100pc 75.png 3D 100% Stacked Wall Graph

  • Start with a Worksheet.
  • Select at least one Y column (or a range from at least one Y column). Ideally, select at least two Y columns (or a range of at least two Y columns). If there is an associated X column, X column supplies X values; otherwise, Y sampling interval or row number is used.
  • For more information, see the link in the Graph Types column.


For an overview of Origin's 3D graph types and their source data requirements, see these topics:

Topics for Further Reading

 

© OriginLab Corporation. All rights reserved.