15 Data Analysis

Introduction

Origin contains powerful tools for all of your data analysis needs, including curve fitting, statistics, peak analysis and signal processing. Most of Origin's analysis tools can make use of a stored collection of settings -- something known as a Dialog Theme -- that makes repeat analyses a snap. Furthermore, the output from one operation can become the input for another operation, thus allowing you to set up a chain of operations, with results that update whenever there are changes to source data, as would happen when importing a series of data files.

The following sections cover (1) selecting the data that you wish to analyze and (2) the Origin and OriginPro tools available for analyzing that data. Please refer to the How to Handle Repetitive Tasks chapter of this User Guide for more information on Analysis Templates, Dialog Themes and other time-saving features.

Apps are add-on tools that extend Origin's graphing and analysis capabilities. Many analysis-related tools are available free-of-charge from OriginLab's File Exchange. To find out more about Apps in Origin, see the Apps for Origin chapter of this User Guide.

Data Input

Origin's analysis tools will work with workbook and/or graph data, depending upon the tool. By default, analyses will be on done on selected data in the worksheet or graph window. You may want to restrict your analysis to a subset of the data -- say, a certain range of rows or columns in a worksheet or a certain X range in a graph -- and we cover that here.

Data selections can be made before or after opening an analysis dialog. Most of Origin's X-Function based analysis tools have a Input branch with a range selection control that you can use to interactively select your data (as explained below).

Selecting Data in the Worksheet

When you highlight a range of worksheet data, then open one of X-Function based dialog boxes -- that would include nearly all of those that open from the Analysis or Statistics menus -- you will see your range selection already entered into the dialog box Input branch. Most will find that selecting worksheet data prior to opening an Analysis or Statistics dialog box, is the easiest way to specify which data you wish to analyze.

Selecting Data in the Worksheet-1.png

If you open one of the X-Function dialog boxes without pre-selecting your data, the first thing you should do upon opening the dialog is to select data in Input branch:

XF range selection control.png
  1. Click the range selection control next to Input (or Input Data). The dialog box will roll up.
  2. Go to worksheet and highlight your worksheet data, then click the Xf open dialog.png button at the right end of the rolled up dialog box. The Input branch will now show the selected range.

Note that you do not have to select entire datasets (columns). You can select a portion of your worksheet data and analyses will be confined to that selected subset of your data. Also if the analysis supports multiple datasets, you could support multiple ranges such as multiple Y columns or Y ranges. If the analysis only supports one dataset, you may be able to select multiple ranges in the worksheet, but only the 1st range will be picked in the analysis.

Selecting Data in the Worksheet-2.png



Notes

  • The Input Data branch has a hierarchical structure. If the analysis supports multiple datasets, you can add multiple ranges under Input Data and they will show as Range 1, Range 2, etc., each with its corresponding X, Y, Error and Row controls.
  • Mousing over each level will show a tooltip indicating where the data on that level is from (i.e. book, sheet and column).
  • A Rows control under each range node lets you set range by row index or X value. If you want to apply the same row range to all ranges under Input Data, click the arrow button to the right of the range node and choose Apply Row Range to All.
  • Depending on where you are in the Input Data hierarchy, the range selection button may have some limitations ( e.g. if you click range selection control next to Y, though you could select multiple columns in a worksheet, only the 1st column is accepted).
  • Clicking the arrow button to the right of the range selection control will show more selection options, including individual worksheet columns that can be quickly added to your data selection.
  • Depending on which level you are in, the selection options when clicking the arrow button may vary. For instance, clicking the "arrow" button next to Input Data and clicking the Select Columns... menu item, will open the Column Browser allowing you to select multiple columns from different worksheets.

XF shortcut menu.png

  1. Use the List Datasets drop-down list to filter which sheets you want to pick from. The top panel list can be sorted by clicking any of the column headings, making it easy to select, for example, all columns that share the same LName or Comments.
  2. Then click the Add button to add the column to your selection list in bottom panel.
  3. To modify the data input range of any dataset, click the range button to the right of any dataset added to the bottom panel and edit the From and To values.

Selecting Data in the Graph

When a graph window is active and you select one of the Analysis menu tools, the default behavior is for the analysis dialog box to open showing the selected range of the active dataset as your Input Data (note that analysis dialogs include an Input Data node that allows adjustments -- adding more datasets with the interactive range selector button, changing a data range, etc.).

The Data List and the Active Data Plot

The active data plot is the one that shows in the data list (bottom of the Data menu) with a check mark next to it. If the active graph layer contains a plot group, the default behavior is to make the first plot in the group the active data plot (note the "g1" beside each range in the following image, indicating that all are members of plot group 1). You can activate a different plot by clicking on another of the data plots listed at the bottom of the Data menu. Subsequently, when you open an analysis dialog box, this newly-selected plot will be listed as your input data.

Select Data from Graphs-1.png

However, for most purposes, you can ignore the data list and select your plot data directly in the graph window or using the Object Manager:

  • If your data plots are part of a plot group, select the entire group by pressing SHIFT + clicking on a plot. Alternately, click on the group icon in the Object Manager. Either will set Input Range to all plots in the group.
  • To select just a single plot -- whether it be an independent plot or part of a group -- click once on the plot. Alternately, click on the plot icon in the Object Manager. Either will set Input Range to only the selected plot.
UG OM Group Plot Selection.png


You can also indicate the active dataset by placing a red box around the plot's legend entry. In the case of grouped plots, the red box shows on the first plot in the group.

To turn this feature on or off:

  • Click on your graph window, select Format: Page..., click on the Legends/Titles tab and enable or clear the Indicate Active Dataset box.
  • Select the graph legend, then right-click on it and choose Legend, then select/deselect the Indicate Active Dataset menu entry.
  • Select the graph legend, then right-click on it and choose Legend: Update Legend and enable or clear the Indicate Active Dataset box.

Customizing X scale range using Analysis Dialog "Rows" controls

You can adjust data range using the Rows controls under the Input Data branch of most analysis dialogs. If you have an analysis dialog box open:

  1. Click on Input Data branch to expand.
  2. Change the Rows drop-down list to By Row or By X and enter your From and To values. Note that each Range N will have its own Rows controls.
UG Rows Range Controls.png

Customizing X scale range using Axis Scale Mini Dialog

Before opening an analysis dialog...

  1. Click on an axis then click the Mini Toolbar Axis Scale button to open the Axis Scale dialog box.
  2. UG Analysis Axis Scale MTB.png
  3. Adjust the X axis scale to your desired range.
  4. Now open your analysis dialog (e.g. Linear Fit) and click the arrow button beside the Input Data box and select Use X Scale Range from the context menu:
Select X Scale as Input.png

As you can see, the customized scale range of X axis on the graph has been used to specify the input data range for your analysis (Rows = By X).

Selecting data graphically using The Regional Data Selector

You can graphically select a range of data using the Regional Data Selector tool:

  1. With a graph window active, click and hold on the Regional Data Selector button Quick Help Reg Data Sel button.png on the Tools toolbar, and then choose either the Selection on Active Plot or Selection on All Plots button.
  2. Drag out a rectangle or freehand object to select an area of the plot(s). Note that you can press Space to toggle between rectangle Select Data from Graphs-3.png and freehand modes Select Data from Graphs-4.png.
Select Data from Graphs-2.png

When you make your selection, Data Markers are placed on the graph to mark the selected range(s). You can now use Origin's analysis tools (e.g., Linear Fit) to perform an analysis on the selection, but note that some analysis dialog boxes do not work on multiple data ranges. The smoothing dialog box, for example, (Analysis: Signal Processing: Smooth...) will only smooth data in the active dataset or a single, selected plot.

There is a new Mini Toolbar for controlling X scale range when using Data Markers. Click on a Data Marker and use the buttons to Set Display Range or Reset to Full Range.

UG MT Data Markers.png

Tutorial: Linear Regression on Partial X Range

  1. Import the file \Samples\Curve Fitting\Exponential Decay.dat into a new workbook.
  2. Select all Y columns and create a line plot.
  3. Click and hold the Regional Data Selector button on the Tools toolbar, and then choose the Selection on All Plots button Quick Help Reg Data Sel All button1.png.
  4. Drag out a rectangle to select the tail-end of the three curves between values of approximately 0.6 and 1.0 along the X axis.
  5. Use the Analysis:Fitting:Linear Fit menu to open the Linear Fit dialog.
  6. Input Data branch is filled with three ranges. Mouse over Input Data branch will show tooltip which shows 1X,1Y, ...3X and 3Y.
  7. If you want to change the data selection, click the arrow button in Input Data and choose Reselect All Data from Graph. The dialog will roll up. Drag out a rectangle in graph again to make your selection and then click the Xf open dialog.png button at the right end of the rolled up dialog box. The new data selection will show in Input Data branch.
  8. Accept default Linear Fit settings and press OK to close the dialog. Linear fitting will be performed on all three curves over the selected range.


Data Selection and Fitting.png

In addition to the data selection and data masking methods discussed in this section, Origin offers data filtering and data reduction tools. Please visit the linked pages for details.

Editing a Data Marker

To edit a Data Marker:

  • To modify a data range, right-click a data marker and choose Edit; or double-click on the data marker. The red marker changes to a dark color with arrows on both ends and the cursor changes into a cross-hair. Drag the beginning or ending marker to a new position or use one of the keyboard shortcuts listed below and modify the data range. To escape edit mode, double-click on the marker or press the Enter key.
  • There are other options when right-clicking the data marker such as Delete Marker, Delete Data, etc..
Select Data from Graphs-7.png

Note: If you have used the Regional Data Selector tool to place markers on multiple plots (Selection on All Plots), be aware that moving markers will affect the data range of the active plot only; the ranges of other selected plots will not follow that of the active plot. This is a limitation of the Regional Data Selector.


Alternately, you can use these keyboard shortcuts to select and edit data markers:

  1. Select data markers using these keys ...
    Hot Key Action
    s Select the first pair of data markers on the graph (those marked with "1").
    Tab Select the next pair of data markers (not in edit mode) or the other data marker of the pair (in marker edit mode).
    Home Return to the first data marker.
    End Go to the last data marker.
  2. ... then activate and edit the data marker using these key combinations:
    Hot Key Action
    Enter Activate the selected data marker for editing. (Press Enter again to exit data selection mode.)
    Arrow Move the active data marker exactly one data point.
    Ctrl/Shift + Arrow Move the active data marker multiple data points.
    Delete Delete the the active data marker.

Difference between Data Markers and Analysis Markers

  • Data Markers define a sub-range that you select using the Data Selector tool.
    If you want to remove the data markers from a graph, you can select Data: Clear Data Markers from the main menu, or click the Clear Data Markers Clear data markers.png button on the Markers and Locks toolbar.
Select Data from Graphs-5.png
  • When the analysis routine is completed, Data Markers are replaced with Analysis Markers. By default, Analysis Markers will not show if the analysis is done on the entire dataset. If performed on a subrange, Analysis Markers will show at the beginning and end of that subrange. To modify the data range and rerun your analysis, you must right-click an analysis marker and choose Change Parameters.... Change the Input Data range and rerun the analysis.
Select Data from Graphs-6.png

Note:
  1. If you set Recalculate to None in the analysis dialog box, then no analysis markers are generated.
  2. Data markers and analysis markers are not exported when you choose File: Export Graphs.
  3. To select the exact same range again for another analysis, click the green lock and choose Plot Input Data with Data Markers to create a new graph and do analysis on it.
  4. There is a Markers and Locks toolbar to control analysis markers and locks, such as Marker Hide Show Marker hide show.png to toggle analysis markers on or off, etc. There is also an Analysis Markers submenu, available from the Data menu; or when you right-click on an analysis marker or green lock and choose Analysis Markers.

The Pick Points Tool

You can also pick the data points in the graph using the Pick Data Points tool. This works best for scatter or line + symbol plots of smaller datasets.

  1. Select Data: Pick Data Points. The Pick Points dialog will pop up.
  2. With the square cross-hair, you can read the coordinate of current data points in the Pick Points dialog (also the Data Source). Double-click on the point you want to pick until the cross-hair cursor became round, the actual X&Y values will be recorded and the total number of picked points will be counted up.
    Pick Points DLG.png
  3. Once you finished the picking, click the Done button to output the results to a new workbook.

The Data Highlighter

In some cases, the Data Highlighter on the Tools toolbar, can be useful for selecting some portion of your data for further analysis. For instance, you have a 2D scatter plot and you are interested in data points in a particular region of the graph.

  1. Click the the Data Highlighter button Button Data Highlighter.png on the Tools toolbar.
  2. Highlight the desired group of data points. Note that you can toggle between rectangular and freehand selection modes by pressing the spacebar while the Highlighter is active. Selection points in the graph simultaneously highlights selected rows in the source worksheet.
  3. Go the source worksheet, right-click on it and choose Create Subset Sheet.

You now have a secondary worksheet named as wcopyN, that contains only the data points that you selected in the graph.

For more information, see The Data Highlighter Tool.

Data Output

Origin's analysis tools typically have an Output branch (the exact name varies by tool), in which you can specify the output that you wish to generate and where you would like that output to go. This happens to be the output branch of the Integration tool.

UG output range strings.png

Output can be directed to various places -- a range of worksheet cells or columns, or possibly to a worksheet, a workbook, a matrixsheet, or a graph layer. Output options depend upon the target object as well as the type of window that was active when the tool was opened. You can determine your output target by:

  • Typing directly in the associated text box, using a standard range notation
  • Selecting data with the interactive range control.
  • Type or select your target using a set of predefined range strings.


This being an introductory manual, we will stick with the simplest to use -- using predefined range strings. For information on other options, follow the links above.

Specifying Output Using Range Strings

Referring to the image above, note that range strings are enclosed by < > characters. Valid strings will differ from dialog to dialog (e.g. <source> is available from the Book list under the Output Fitted Values To branch of the Fit Linear dialog, but it is not used to specify Output in the Smooth dialog).

The most common strings:

  • <none>: Generate no output.
  • <new>: Create a new Origin object -- a column, a worksheet, a graph, etc.
  • <input>: Use the input object for output.

You can type these strings directly into the edit box but the easiest thing to do is to just select them from the flyout menu (options will vary by tool). Alternately, you can click the Custom button and open the Range String Builder. Despite the intimidating name, it is just a way to step through the process of specifying your output target. For more information on range strings and Range String Builder, see Output Results in the Origin Help file.

For Origin 2021, changes were made to clarify labeling and presentation of the Range String Builder dialog, plus better context labeling of controls (e.g. Range String Builder is now Custom for custom range string, in the Output flyout menu).

Data Masking

Masking is another technique that you can use when you want to analyze only a subset of your data, or when you have spurious data points that you do not want included in your analysis. Masking or unmasking data will trigger recalculation of linked operations.

  • You can mask data points in both worksheets and graphs.
  • When data exist in both the worksheet and the graph, masking data in one will mask (and mark) the corresponding data in the other.
  • Mask toolbar buttons work on both graphs and worksheets.
  • Tools toolbar buttons work on graphs.
  • When data are selected in the worksheet, a Mini Toolbar Mask Data button becomes available.
  • Additionally, you can mask worksheet data by mathematical condition.

Origin 2021 supports data masking in XYZ 3D plots. You can mask data using buttons on the Mask toolbar (worksheet active) or the Tools toolbar (graph active).

Masking with the Mask Toolbar (worksheet, graph)

These toolbar buttons are used to mask and manipulate masking of selected data. Note that this includes graphs, once data have been selected (see the next section on Tools toolbar buttons for graph selection).

Action Toolbar Button Shortcut Command Notes
Mask data Button Mask Range.png Mask: Range Mask the selected data range. Masked data will display in the mask color.
Unmask data Button Unmask Range.png Mask: Clear Range Unmask the selected data range. Unmasked points are included in analysis operations and plot "normally".
Swap mask Button Swap Mask.png Mask: Swap Swap masked and unmasked points in the active dataset.
Change mask color Button Change Mask Color.png Mask: Change Color Change the mask color of the masked data range.
Hide/Show masked points Button Hide Show Mask.png Mask: Hide Toggle display of masked points ON and OFF on-screen, and in printed and exported graphs.
Disable masking Button Disable Or Enables Masking.png Mask: Disable Masking Toggle the mask ON or OFF for all masked data in the worksheet. When toggled OFF, all data points are analyzed and included in printed and exported graphs.

Masking with the Tools Toolbar (graph)

For Origin 2021, there is a change to the default masking mode:

  • Default is changed from mask by row index number to mask by rectangular region.
  • Otherwise, behavior remains as before: toggle between masking modes (see next) by pressing Spacebar.
  • You can use system variable @MTI=1 (persistent) to revert mask by row index as default.

To mask points, click on the graph window to activate it:

  1. Choose Data: Mask Data Points from the main menu or click the Mask Points on Active Plot button or Mask Points on All Plots button on the Tools toolbar, then hover on the graph.
  2. To mask a single point, double click on the point. To mask a region of points, press the Space bar to toggle among masking by row index number, by rectangular region or by freehand region (differences explained below), then drag out a region.
  3. Once data are masked in the graph, you can use the Mask toolbar buttons, described above.
Mask Points on Active Plot Mask Points on All Plots of Active Layer Purpose
Masking Data in Graphs-3.png Masking Data in Graphs-8.png Mask data points by rectangular region. Only the data points inside the rectangle that you drag out, will be masked.
Masking Data in Graphs-4.png Masking Data in Graphs-9.png Mask data points by freehand region. Only the data points inside the region that you drag out, will be masked.
Masking Data in Graphs-6.png Masking Data in Graphs-7.png Mask data points by row index number. All data points between the lowest and highest selected index numbers are masked regardless of whether they lie inside your rectangle.


To remove the mask from data points in the graph window:

  1. Choose either the Unmask Points on the Active Plot Button Unmask On Active Plot.png tool or the Unmask Points on All Plots of Active Layer Button Unmask On All Plots.png tool on the Tools toolbar.
  2. Use the space bar, as needed, to choose points by index, rectangular region or by freehand region, then drag to unmask your data points. The tool will be active until press ESC or click the Pointer Button Pointer.png tool.

Mask Mini Toolbar Button (worksheet)

When worksheet data are selected -- cells or entire columns -- A Mini Toolbar Mask Data button Button MT Mask.png becomes available. The button works as a toggle to mask or unmask data within the selection.

Mask Cells by Condition (worksheet)

There is a tool for masking worksheet data values by condition (e.g. <= 0).

  1. With the data selected (cells or one or more columns), choose Column: Mask Cells by Condition. This opens the colmask dialog.
  2. Choose your Condition and Value, plus other options as needed and click OK.

For Origin 2021, a new cell mask Condition = Outliers by IQR (interquartile range) has been added

Drawing or Moving, or Deleting Data Points in the Graph

This collection of tools and menu-driven operations is helpful in exploring certain "what if" scenarios, or to quickly generate some data for purposes such as testing a fitting function. These procedures work only with 2D scatter plots.

  1. Activate the graph window.
  2. Click on the Draw Data Tool Button Draw Data.png.
  3. Make sure that the correct graph layer is active and place the cursor on the graph.
  4. Double-click to create data points. The Data Display tool opens (if not already open) and displays the X and Y values for each created data point.
  5. When you have finished adding data points, click on another tool (on the Tools toolbar) to exit drawing mode.

When you use the Draw Data tool, you simultaneously create a hidden worksheet named Drawn (worksheets are automatically enumerated, with n = 1, 2, 3, 4, etc.).

Opening the hidden Drawn Worksheet

Right-click on the data plot and select Go to Drawn from the shortcut menu or in Plot Details dialog, with data plot selected on left panel, click the Workbook button.

A Drawn workbook will appear with A(X) and B(Y) columns with coordinate values of your drawn data plot.

Deleting a Data Point

You can delete individual data points from your graph:

  1. Select Data: Remove Bad Data Points.
  2. Double-click on the data point, or click to select the data point and press ENTER key.
  3. Click Arrow button on Tools toolbar or press ESC key to exit the Remove Bad Data Points mode.

The data point is deleted from both the data plot and the worksheet cell. In the worksheet, only the data cell for the Y value will be cleared and shown as missing value.

Moving a Data Point

You can move individual data points in the graph. Understand that when you do this, you are changing the plot and the underlying data:

  1. Select Data: Move Data Points (you'll be warned that you are about to change your data).
  2. Click on the point you want to move (change X and Y coordinates). Place crosshairs on the point and drag; or use the arrow keys.
  3. Click the Pointer button Button Pointer.png on the Tools toolbar or press ESC to exit the Move Data Points mode.

The data point is moved in the plot and the X and Y coordinates are changed in the worksheet cell.

Mathematics

Origin provides a number of mathematics tools to perform basic calculations, interpolation, and area or volume calculations.

Basic Math

When averaging multiple curves with a different X range, a No Extrapolation checkbox is added when Averaged X = Full X Range, Custom or Follow Curve Trace.

Tool Name Description Menu Entry
  • Simple Column Math/Simple Curve Math
  • Normalize Columns/Curves
  • Average Multiple Curves
  • Differentiate
  • Perform basic calculations on worksheet columns or XY data plots
Analysis:Mathematics (workbook, graph)
  • Subtract Reference Data
  • Subtract one dataset from another
Analysis:Data Manipulation (workbook, graph)
  • Subtract Straight Line
  • Subtract a straight line defined graphically by clicking in the graph.
Analysis:Data Manipulation (graph)
  • Vertical Translate
  • Horizontal Translate
  • Use a Gadget to graphically translate curve(s) in vertical or horizontal.
Analysis:Data Manipulation (graph)
  • Differentiate Gadget
  • Perform differentiation over a region of interest in a graph
Gadgets:Differentiate... (graph)
  • Intersect Gadget
  • Calculate the intersection points of two or more data plots.
Gadgets:Intersect... (graph)
  • Vertical Cursor
  • Read and tag X, Y coordinate values for data plots across multiple graphs that share the same X axis.
Gadgets:Vertical Cursor... (graph)
  • Set Column Values
  • Use formulae to set/transform worksheet column values
Analysis:Mathematics (workbook)
  • Inverse
  • Generate pseudo inverse of a matrix
Analysis:Mathematics (matrix)
  • Median Filter
  • Special Filter
  • Custom Filter
  • Apply median/special/custom filter to a matrix
Analysis:Mathematics (matrix)

Interpolation

Tool Name Description Menu Entry
  • Interpolate Gadget
  • Perform interpolation over a region of interest
Gadgets:Interpolate... (graph)
  • Interpolate/Extrapolate
  • XYZ Trace Interpolation(3D Graph)
  • Trace Interpolation(2D Graph)
  • Perform interpolation/extrapolation on a group of XY data.
  • Perform periodic interpolation on XYZ worksheet data
  • Perform interpolation on cycle or periodic curves
Analysis:Mathematics (workbook, graph)
  • Interpolate/Extrapolate Y from X
  • 3D Interpolation
  • Perform interpolation/extrapolation on a group of XY data to find Y at given X values.
  • Perform 2D interpolation on a group of XYZ data to find Z at given XY values w/ choice of 8 methods.
  • Perform interpolation with a 3D function on XYZ dataset.
Analysis:Mathematics (workbook)
  • 2D Interpolate/Extrapolate
  • Perform 2D interpolation/extrapolation for a matrix
Analysis:Mathematics (matrix, graph from matrix)

Area/Volume Calculation

Tool Name Description Menu Entry
  • Integrate Gadget
  • Perform integration over a region of interest in a 2D Graph
Gadgets:Integrate... (graph)
  • 2D Integrate Gadget OriginPro Symbol.png
  • Calculate max height, volume, FWHM (X,Y) for a contour or image graph created from matrix or XYZ worksheet data (OriginPro Only).
Gadgets:2D Integrate... (graph)
  • Integrate(2D Graph)
  • Polygon Area(2D Graph)
  • XYZ Surface Area (3D Graph) OriginPro Symbol.png
  • Perform integration on input data
  • Calculate the area of enclosed plot regions
  • Calculate the area of the XYZ surface
Analysis:Mathematics (workbook, graph)
  • 2D Volume Integrate OriginPro Symbol.png
  • Matrix Surface Area OriginPro Symbol.png
  • Calculate the volume beneath the matrix surface from zero plane
  • Calculate the area of the matrix surface
Analysis:Mathematics: 2D Volume Integrate (matrix, 3D graph from matrix)
or
Analysis:Mathematics: Matrix Surface Area (matrix, 3D graph from matrix)

Curve Fitting

A number of free Apps designed for various curve-fitting operations are available from the OriginLab File Exchange. To find and install these Apps click Analysis: Fitting: Find Apps. The App Center will open, displaying only fitting-related Apps. Browse available Apps and click the Download and Install button AC Download Icon.png to install an App.

Linear and Polynomial Fit

Linear and polynomial fitting can be performed on worksheet data or data plots in a graph. The menu entries of these tools are listed in the table below. All are available for both workbook or plotted data.

Tool Name Menu Entry
  • Linear Fit
Analysis:Fitting:Linear Fit
or
Gadgets:Quick Fit (graph)
  • Fit Linear with X Error OriginPro Symbol.png
Analysis:Fitting:Fit Linear with X Error
  • Multiple Linear Regression
Analysis:Fitting:Multiple Linear Regression
  • Polynomial Regression
Analysis:Fitting:Polynomial Fit
or
Gadgets:Quick Fit (graph)

Nonlinear Curve Fit

You can perform nonlinear curve fitting using one of many built-in fitting functions, or you can create a user-defined fitting function. OriginPro supports implicit function fitting, surface fitting, and fit comparison. Some tools are available only in OriginPro.

The table below summarizes available nonlinear curve fitting tools:

Tool Name Features Menu Entry
  • Quick Fit Gadget
  • Fit a region of interest in a graph interactively
  • Fit with built-in or user-defined fitting functions
  • Fit one or multiple datasets
  • Choose from a number of pre-defined analyses (incl. Linear, Cubic, Peak and Sigmoidal).
Gadgets:Quick Fit (graph)
or
Gadgets:Quick Sigmoidal Fit (graph)
  • Nonlinear Curve Fitting
  • Fit with built-in or user-defined fitting functions
  • Fit one or multiple datasets
  • Compare fit, multiple parameter sets
  • Global fit with parameter sharing
  • Global fit, parameter sharing with multiple functions OriginPro Symbol.png
  • Fit with replicas
  • Advanced options including bounds, constraints, fit control
Analysis:Fitting:Nonlinear Curve Fit (workbook, graph)
  • Implicit Curve Fitting OriginPro Symbol.png
  • Fit with implicit functions
  • Orthogonal Distance Regression (ODR) algorithm
Analysis:Fitting:Nonlinear Implicit Curve Fit (workbook, graph)
  • Surface Fit OriginPro Symbol.png
  • Fit data from a matrix or worksheet XYZ columns
Analysis:Fitting:Nonlinear Surface Fit (workbook, graph)
or
Analysis:Nonlinear Matrix Fit (matrix)
  • Fitting Function Builder
  • Create or edit user-defined fitting functions
Tools:Fitting Function Builder
  • Fitting Function Organizer
  • Manage fitting functions by categories
  • Move or share functions between categories
Tools:Fitting Function Organizer
  • Fitting Function Library App

New for Origin 2021

  • Download fitting functions from originlab.com
  • Request or Share a Function with OriginLab
Click the Fitting Function Library icon in the Apps Gallery
  • Simulate
  • Simulate a curve from a given function
  • Simulate a surface from a given function OriginPro Symbol.png
Analysis:Fitting:Simulate Curve
or
Analysis:Fitting:Simulate Surface
  • Fit Comparison OriginPro Symbol.png
  • Compare fit results from two datasets using one function function
  • Compare fitting results for one dataset using two fitting functions
Analysis:Fitting:Compare Datasets
or
Analysis:Fitting:Compare Models (workbook, graph)
  • Fit and Rank Functions OriginPro Symbol.png
  • Compare fit results of two or more functions for a single dataset
Analysis:Fitting:Rank Models (workbook, graph)

Peak Analysis

For Origin 2021, a change to the Peak Analyzer Theme: Enable Linear Constraints Status and Constraints are now enabled by default.

Origin provides several tools for peak analysis. With these tools, you can define and subtract baselines, find peaks, integrate peaks, and fit peaks. Some tools are available only in OriginPro.

The table below summarizes various built-in tools available for peak analysis:

Tool Name Features Menu Entry
  • Quick Peaks Gadget
  • Perform peak analysis over a region of interest
  • Create baseline
  • Subtract baseline
  • Find peaks
  • Integrate peaks
  • Fit peaks
Gadget:Quick Peaks (graph)
  • Multiple Peak Fit
  • Pick multiple peaks
  • Fit peaks
Analysis:Peaks and Baseline:Multiple Peak Fit
(graph, workbook)
  • Peak Analyzer
  • Create baseline
  • Subtract baseline
  • Find peaks
  • Integrate peaks
  • Fit multi-peak datasets OriginPro Symbol.png
  • Fit baseline OriginPro Symbol.png
  • Find hidden peaks
  • Compute many peak characteristics OriginPro Symbol.png
Analysis:Peaks and Baseline:Peak Analyzer
(graph, workbook)
  • Batch Peak Analysis
  • Use a theme file created using Peak Analyzer tool
  • Perform batch peak analysis on multiple datasets
Analysis:Peaks and Baseline:Batch Peak Analysis Using Theme
(graph, workbook)

A number of free Apps designed for peak analysis are available from the OriginLab File Exchange. To find and install these Apps click Analysis: Peaks and Baseline: Find Apps. The App Center will open, displaying only peak-fitting related Apps. Browse available Apps and click the Download and Install button AC Download Icon.png to install an App.

Signal Processing

Origin provides signal processing tools for many tasks, including producing signal transforms, smoothing/filtering, and correlation on 1D and 2D signals. Advanced tools are available in OriginPro.

You may refer to the tables below for the signal processing tools and their menu entry.

Signal Transforms

Tools Menu Entry
  • FFT Gadget
Gadgets:FFT... (graph)
  • Fast Fourier Transform (FFT)
  • Inverse Fast Fourier Transform (IFFT)
Analysis:Signal Processing:FFT (workbook, graph)
  • 2D FFT OriginPro Symbol.png
  • 2D IFFT OriginPro Symbol.png
Analysis:Signal Processing:FFT (matrix)
  • Short-time Fourier Transform (STFT) OriginPro Symbol.png
Analysis:Signal Processing:STFT (workbook)
  • Hilbert Transform OriginPro Symbol.png
Analysis:Signal Processing:Hilbert Transform (workbook, graph)
  • Image Profiling
Plot>2D:Profile:Image Profile(matrix, worksheet, XYZ data)

Filtering

Tools Menu Entry
  • FFT Filter
Analysis:Signal Processing:FFT Filters (workbook, graph)
  • 2D FFT Filter OriginPro Symbol.png
Analysis:Signal Processing:2D FFT Filters (matrix)
  • IIR Filter Design OriginPro Symbol.png
Analysis:Signal Processing:IIR Filter (workbook, graph)

Smoothing

Tools Menu Entry
  • Smooth
Analysis:Signal Processing:Smooth (workbook, graph, matrix)

Correlation

Tools Menu Entry
  • Correlation
Analysis:Signal Processing:Correlation (workbook, graph)
  • 2D Correlation OriginPro Symbol.png
Analysis:Signal Processing:2D Correlation (matrix)

Convolution

Tools Menu Entry
  • Convolution
Analysis:Signal Processing:Convolution (workbook, graph)

Wavelet Analysis (Pro Only)

Tools Menu Entry
  • Continuous Wavelet Transform
  • Discrete Wavelet Transform (Decomposition)
  • Inverse Discrete Wavelet Transform (Reconstruction)
  • Multi-Scale Wavelet Decomposition
  • Smoothing
  • Noise Removal
Analysis:Signal Processing:Wavelet Analysis (workbook, graph)
  • 2D Wavelet Decomposition
  • 2D Wavelet Reconstruction
Analysis:Signal Processing:Wavelet Analysis (matrix)

Other Advanced Tools (Pro Only)

Tools Menu Entry
  • Rise Time Gadget
Gadget:Rise Time (graph)
  • Decimation
Analysis:Signal Processing:Decimation (workbook, graph)
  • Coherence
Analysis:Signal Processing:Coherence (workbook, graph)
  • Envelope Curves
Analysis:Signal Processing:Envelope (workbook, graph)

Image Processing

Origin provides a collection of tools for basic image processing. These tools are accessible from the Image menu when a matrixbook is active. Some tools are OriginPro Symbol.png only.

The tools are organized in the following sub-menus:

  • Image:Adjustments
  • Image:Arithmetic Transforms
  • Image:Conversion
  • Image:Geometric Transforms
  • Image:Spatial Filters

Topics for Further Reading