12 Customizing Graphs


Grand image customizing graphs3.png

Introduction

This chapter introduces you to various aspects of graph customization. All Origin graphs start from a graph template. If the graph you are making is fairly standard for its type, the options that were stored in the graph template may be entirely adequate to produce a polished-looking graph. The business of basic graph creation was covered in the last chapter, Graphing.

Sooner or later, however, you are going to want to add annotations, modify axis scales, or change plot colors. Hence, the purpose of this chapter is to introduce you to some key Origin graph customization tools and techniques, as well as to point you toward resources that will help you manage more complex graph customization tasks.

We begin with a discussion of the graph customization-related toolbars, as these toolbars have tools that are commonly used for quick modifications of graph elements.

Toolbars

Toolbar buttons useful for graph-customization tasks:

Description Toolbar
(default configuration)
Format toolbar buttons:
  • Creating and customizing text objects.
Format bar.png
Style toolbar buttons:
  • Editing colors, line thickness, fill patterns.
Style bar.png
Tools toolbar buttons:
  • Add text objects, lines, arrows, rectangles/circles/polygons.
Tools bar.png
Graph toolbar buttons:
  • Add graph layers incl. inset graphs, merging or extracting graphs; exchanging axes; anti-aliasing and Speed Mode.
Graph toolbar 92.png
Add Object to Graph toolbar buttons:
  • Add legends/color scales/bubble scales; date & time and project path stamps; XY scale; table objects.
Add Object to Graph Toolbar.png
Object Edit toolbar buttons:
  • Arranging and aligning objects and layers on the page.
Object Edit bar.png

Menus, Dialogs and Buttons Used in Graph Customization

Many graph customizations are initiated via commands on the Format or Graph menus. The following table lists key menu commands and dialog boxes plus a few toolbar buttons, used in customizing graphs.

Task Dialog Name Method
Customize the graph Page, Layer, or Data Plot

Plot Details dialog

  • Double-click on Page, Layer or Data Plot
  • Format: Page... menu
  • Format: Layer... menu
  • Format: Plot... menu

See, Customizing Page, Layer and Data Plots

Customize Axes

Axis Dialog

  • Double-click on axes or tick labels
  • Format: Axes... menu
  • Format: Axis Tick Labels... menu
  • Format: Axis Titles... menu

See, Customizing Graph Axes

Add a Default Legend (most 2D graphs)

N/A

  • Click the Reconstruct Legend (CTRL+L)New Legend.png button on the Add Object to Graph toolbar
  • Right-click on the legend object and choose Legend: Reconstruct Legend
  • Choose Graph: Reconstruct Legend from the main menu

See, Graph Legends

Customize the Legend

(Text Object -) Legend dialog

  • Ctrl + double-click on the legend object text

See, The (Text Object Properties) Text tab

Update Legend dialog

  • Right-click legend and choose Legend: Update Legend or choose Graph: Legend: Update Legend...

See, The legendupdate Dialog Box

Legends/Titles tab at Page level of Plot Details dialog

  • Double-click in the white area just inside graph window frame (but outside of the data plot), then click on the Legends/Titles tab
  • Choose Format: Page and click on the Legends/Titles tab

See, The (Plot Details) Legends/Titles tab

Add a Color Scale (color-mapped plots)

N/A

  • Click the Add Color ScaleAdd color scale button.png button on the Add Object to Graph toolbar

See, Color Scales

Add a Bubble Scale (symbol-size mapped plots)

N/A

  • Click the Add Bubble ScaleButton Add Bubble Scale.png button on the Add Object to Graph toolbar

See Bubble Scale

Merge multiple graph windows into one graph window

Merge Graphs dialog

  • Graph: Merge Graph Windows... menu

See, Merge and Arrange Graphs (tutorial) and The Merge Graph Dialog Box.

Layer level customizations: resize, move, swap, align, or add layers

Layer Management dialog

  • Graph: Layer Management... menu

See, Layer Management-Quick Start

Save settings as graph template

Save Template As dialog

  • File: Save Template As... menu
  • Right-click graph window title and choose Save Template As...

See, Graph Template Basics

Manage graph templates, add plots to a template

Template Library
(custom graph templates)

  • Plot > Templates: User menu (worksheet is active)

See, The Graph Template Library

System Templates
(built-in graph templates)

  • Plot > Templates: System Template menu (worksheet is active)

See, System Templates

Save settings as graph Theme

Save Format as Theme dialog

  • Right-click and choose Save Format as Theme... context menu (graph is active)

See, Saving Formats to a Theme

Manage Graph Themes: edit, combine, apply Theme, set as System Theme

Theme Organizer dialog

  • Preferences: Theme Organizer.. > Graph tab.
  • F7 hotkey.

See, Theme Organizer

Customizing Page, Layer and Data Plots

A graph window is a collection of objects, organized in a hierarchical structure. As we shall see, there are editable properties at the page, layer and data plot levels.

Quick formatting of some graph properties can be done using toolbar buttons, as mentioned above. However, the vast majority of properties are customized via Origin's Plot Details dialog box. To open Plot Details, (1) double-click on your plot or (2) click the Format menu, then choose Page..., Layer... or Plot....

The figure below shows an example of the Plot Details dialog box:

  • The left panel depicts the Page > Layer > Plot hierarchy as an expandable/collapsible tree.
  • The right panel contains controls, organized by tabs, that pertain to the object that is currently selected in the left panel.
  • To customize an object, select it in left panel and modify the corresponding properties that appear on the various tabs in the right panel.
    PD customizing graphs 2.png

Selected Left Panel Object Right Panel, Controls for...
Page Settings that pertain to the whole page -- Print/Dimensions, layer drawing orders, page display color, legends/titles, etc.
Layer Settings that are specific to the graph layer -- Layer background colors, layer size and speed mode settings, layer display settings, stack settings for applicable plot types. Some plot types will include extra tabs/controls specific to the plot type.
Plot Plot specific properties. The tabs and controls vary by plot type (e.g. Scatter plots have a Symbol tab with controls pertaining to scatter symbols, Line plots a Line tab with controls pertaining to line plots).
Data Point Properties that apply to user-specified "special points". Available for some plot types. The tabs and controls are generally similar to those available at the Plot level.


You can UNDO customizations made in the Plot Details dialog box. Click OK to close Plot Details and choose Edit: Undo Modify Page or press CTRL + Z.


:PD customizing graphs 1a.png

Prevent text and label objects from scaling when resizing layer, by going to the Size tab of Plot Details (at the Layer level) and setting Fixed Factor to 1.

Origin 2018b added a Layers tab at the Page Level in Plot Details. Use these controls to apply customizations made to a graph layer and contained plots, to other layers and plots in the graph page. This feature is particularly useful for modifying stack or panel graphs. Previously, for instance, if you wanted to customize a 9-panel graph you had to customize each panel individually. Now, you can apply multiple customizations to all plots, simultaneously. For more information, see The (Plot Details) Layer Tab.

Plot Details common diisplay.png

Customizing Grouped Plots

When you select and plot multiple data ranges to a single graph layer, the plots are grouped in the layer. Generally speaking, plots within a group are automatically differentiated by assigning styles built from one or more customizable "increment lists", one for each plot property (symbol shape, symbol color, line style, etc.).

Usually, some properties are configured to increment "by one" for each plot (e.g. line color) and some will be configured not to increment (e.g. line style), though this is ultimately controlled by the user. In any case, these increment lists for each property, are saved with the graph template (.oggu) or Theme file (.oth) so that you can easily use them later to create graphs with the same look.


:PD Group tab 2015.png

The above image shows the Plot Details Group tab settings for a line + symbol plot in the upper-left. On this Group tab, the first column lists Line Color, Symbol Type, Line Style Symbol Edge Color and Symbol Interior. Properties of Line Color, Symbol Type and Symbol Edge Color are set to increment By One and Between Subgroups (subgrouping occurs using the column Comments), while Line Style and Symbol Interior are set to increment by None (they do not vary).

As previously mentioned, this arrangement is completely customizable and you can save customizations with the graph template:

Using Object Manager with Grouped Plots

  • To highlight a single plot and dim others (grouped or ungrouped) in the layer, click once on the plot in Object Manager; or in the graph window, click twice on the plot if grouped, once on the plot if ungrouped.
OM plot highlight.png
  • To reorder plots in the layer, drag a plot icon within the group; or right-click on the plot (in Object Manager) and choose Move Up or Move Down.
OM reorder plots.png
  • To group or ungroup data plots in the layer, right-click on the group icon ("gN") and choose Ungroup. To group plots in the layer, right-click on a plot and choose Set as Group Begin.
OM group ungroup.png
  • To move a plot from one group to another, drag the plot to the other group.
  • To move a series of plots out of the group, right-click the last plot that you want to keep in the group and choose Set as Group End.
  • To remove a plot from the layer (and the graph), right-click on the plot and choose Remove.
  • To move a plot to a second Y axis, or move the plot to another layer, right-click on the plot in Object Manager and choose Move Plot to Second Y Axis or Move Plot(s) to Other Layer ....

Customizing Multi-layer Graphs

The graph layer is a fundamental concept in Origin and it is a primary building-block of most complex Origin graphs (e.g. a graph with both left and right Y axes is constructed by overlaying one layer on another, and sharing a common X axis between the two layers). While the graph layer is, fundamentally, a self-contained unit it is, at times, desirable to create dependencies between layers:

  • One type of dependency is what we call "linking" of layers, which involves establishing spatial relationships or relationships between axis scale values. You can read more about linking graph layers, below.
  • Another type of dependency is based on what we call "common display" and this is most useful in a situation where we have multiple similar panels in a graph and we want to do something like change the background color of each graph, or perhaps the change plot colors used in each layer.


At the graph page level in Plot Details, you will find a Layers tab that has controls that affect all layers within a given graph page. The Common Display controls can be used to enable simultaneous editing of layer, plot and axis properties of multi-layer graphs. For instance, in the following example, we have a two-layer trellis plot -- the two layers being necessitated by there being a left-Y axis and a right-Y axis with two completely different scales -- and as a simple illustration, we have used the Common Display controls to simultaneously add a background color to both layers. We could have accomplished the same thing without using the Common Display controls but this would have required twice the work -- set the background color of layer 1, then set the background color of layer 2.

User guide common display controls.png

This was a simple illustration but we can use the Common Display controls for application of more complex mix of layer, plot and axis properties. Some of Origin's built-in multi-layer graph templates have Common Display elements turned on by default. When working with multi-panel graphs, you may want to choose Format: Page, click the Layers tab in Plot Details, and check the Common Display settings. See Common Display for more information.

The Common Display Apply to control now supports including or excluding certain layers from common display customizations. For instance, you might have a 4 panel graph, each with an inset layer and using this control, you could apply a common background color to the inset layers without applying the same background color to the 4 primary layers (panels). See Common Display for more information.

Customizing Individual Data Points

For some plot types such as scatter and column, you can modify the display properties of a single data point.

To edit a single point:

  1. Press the CTRL key and double-click on the data point in the graph. This opens the Plot Details dialog box with the focus set to edit this data point. The data point will be identified in the left-panel of Plot Details by its row index number.
  2. Use the controls on the tabs in the right panel to modify the appearance of the data point. Changes you make to the appearance of this point will not affect the appearance of other points in the same plot.
PD point-edit mode.jpg

Alternately, when the Custom Construction box is checked, you can use these controls to customize the symbol.

PD point-edit mode ALT.jpg

You can customize some properties of a single data point simply by selecting the point (click (slowly) twice on the point if not part of a group, or three times if part of a group), then clicking the appropriate button on the Style toolbar -- no need to open Plot Details.


To remove customizations made to a single data point:

  • Right-click the single point in the left panel of the Plot Details dialog and choose Delete.
  • In the graph window, click on the single point to select it, then press DELETE on the keyboard.

The point itself is not deleted; only the custom styling is removed and the point reverts to the style of the containing data plot.

Customizing Graph Axes

Most graph axis customizations are made via the Axis Dialog box. Double-click on the graph axis or tick labels to open the Axis Dialog - Layer N dialog box.

For Origin 2019b a new Rug tab has been added to the Axis dialog. Use controls on the tab for adding "Rug Plots" to your graph axes. While they can be added to many graphs, Rug Plots are perhaps best suited for illustrating distribution differences among groups of scatter points, where the axis variable is measured on a continuous scale. Several customizable graph templates with "Rug Marks" turned on, are included with Origin. See the list of Graph Types for details.

Customizing graphs rug marks.png



This image shows the tab-based axis dialog used by most 2D and 3D graphs.

Axis dialog box.png

In the left panel, you can select one or more icons (hold the CTRL key to select multiple icons) to specify the axis or axes to be customized, then select the desired tab and choose your options.

Tab Controls for
Scale Scale range of values, scale type, rescale mode and margin, reverse scale, major and minor ticks.
Tick Labels Display and Format options for major and minor tick labels, including custom labeling using LabTalk substitution or mathematical expression. For information on custom formatting of numeric data including display of percentages, fractions, pi, and geographic (Lat/Lon) formats, see Origin Custom Formats.
Title Axis title (often set using variable notation) and font options. Note that you can directly edit by double-clicking the text object in the graph.
Grids Control display and properties of grid lines at major and minor ticks.
Line and Ticks Global axis line and tick display options for all axes.
Special Ticks Placement of special tick labels.
Reference Lines Display of reference lines (key statistics) and "recession bars" (shaded areas with transparency), that can be overlaid on the data plot(s).
Breaks Enable line breaks and configure each break.

Click the Apply To... button to apply the axis format settings of the currently selected axis to another axis.

Note: For more information on axis customization and for axis controls for specialized graph types (e.g. polar, ternary, radar chart.etc), refer to:

Help: Origin: Origin Help > Graphing > Graph Axes

Graph Legends

How the Default Legend is Created

A graph legend is automatically created when you plot data. For most 2D and some 3D graph templates, the default legend combines (A) plot style information stored with the graph template, with (B) dataset information stored in the worksheet column label rows, and places the resulting legend object on the graph page.

Customizing Graphs Default Legend.png


Note that the default legend object is not created with literal text and plot symbols but instead is created from LabTalk script.

  • This allows the legend object to be dynamically linked to plotted data and worksheet metadata, so that the legend can be updated when data or plot metadata change.
  • Because construction of the legend object relies on scripting rather than literal information, you can save customizations to a graph template and recreate the graph with its accompanying legend object using new data, as often as is needed.


The legend script relies on "substitution notation" to convert variable values to readable symbols and text. You can see this notation when you double-click inside of the legend object (as if to edit it).

Auto Creation of Legend.png

You control which dataset metadata are used in constructing the default legend text by setting the the Translation mode of %(1), %(2) list in the Legends/Titles tab of the Plot Details dialog box (Format: Page...). Custom strings can be constructed using LabTalk substitution. Customizations can be saved to the graph template for repeat use.

Origin 2019 added support for wrapping of legend text. To make use of this, open the Plot Details Legends/Titles tab, set Translation mode of %(1), %(2) to Custom, then enter your custom legend notation with the characters %(CRLF) at the point where you want text to wrap.

Tips for Quick Legend Edits

  • Select the legend object, then right-click and choose Legend to open a shortcut menu with some useful commands including Text Color Follows Plot, Reverse Order, and Show Legend for Visible Plots Only (the same menu commands are available from Graph: Legend).
  • The same shortcut menu also has an Arrange in Vertical/Horizontal command for changing the legend aspect; or you can modify it interactively by selecting the legend object, then pressing CTRL while dragging a selection handle (e.g. drag horizontally to create a legend that is all on one line).
  • Double-click on the legend text to enter in-place edit mode (where you can manually overwrite the legend text).
  • CTRL + double-click the legend text to open the Legend dialog box. Here you can modify all aspects of the legend.
  • Double-click a legend symbol to open the Plot Details dialog box.
  • If you do not want a legend object added to your graph each time you create the graph, delete the legend object and re-save the graph template.

Adding and Updating the Default Legend

The table below lists tasks associated with adding or updating the graph legend, and where to find editing controls for each legend type. Before proceeding, we should point out that there are two legend refresh modes:

  • Updating a legend will preserve any customizations that you might have made to the existing legend, including size and position adjustments and legend symbol and text customizations.
  • Reconstructing a legend will overwrite any customizations. When you add or reconstruct the legend, you are creating a copy of the legend that is stored in the graph template.


In addition, the graph template stores a Legend Update Mode setting that determines how the legend is refreshed when adding or removing data plots from the graph. See Controlling Legend Update, below.


Task Method (graph is active)
Add or reconstruct legend
  • Graph: Legend: Reconstruct Legend menu.
  • Reconstruct Legend button Button New Legend.png (Add Object to Graph toolbar).
  • CTRL+L.

Legend customizations not saved with the template, will be lost when you reconstruct.

Update legend Open the legendupdate dialog box:
  • Graph: Legend: Update Legend menu.
  • Right-click on legend and select Legend: Update Legend.


Note: "Updating" a legend does not overwrite legend customizations.

Customizing special legends Right-clicking on these special legends opens a dialog box with customization options specific to each legend type:
Add color scale Only available for color-mapped plots (e.g Contour Plots).
  • Click the Add Color Scale button Add color scale button.png (Add Object to Graph toolbar).
  • Right-click in the layer and select New Color Scale.
  • Insert: Color Scale menu.
  • When you have multiple color-mapped plots in a single graph window, you can click on each plot to select it, then add a corresponding color scale.
Control color scale Available when a color scale object has been added to a graph. To open the Color Scale Control dialog:
  • Double-click on the color scale object.
  • Right-click on the color scale object and choose Properties.
Add bubble scale Available for bubble plot, or when symbol size is controlled by a dataset.
  • Select Insert: Bubble Scale.
  • Right-click in the layer and select New Bubble Scale.
  • Click the Add Bubble Scale button Button Add Bubble Scale.png in the Add Object to Graph toolbar.
  • Right-click the legend to select Add Bubble Scale from the context menu.
Control bubble scale

Available when bubble scale object has been added to a graph. To open the Bubble Scale Control dialog:

  • Double click on the bubble scale object.
  • Right-click on the bubble scale object and choose Properties.

The legendupdate dialog box and the Legend/Titles tab at page level of Plot Details both have an Auto Legend Translation Mode drop-down that determines which worksheet metadata (e.g. column Long Name, Comments, etc.) is used to generate the legend text. For a list of Custom options, see Legend Substitution Notation.

Origin 2018 added an interface tool to manually Add Legend Symbols to the graph legend. Right-click on the legend object and choose Properties. Click the Add Legend Symbol button in the lower-right corner of the dialog box.

Add Legend Symbol.png
Note: For more information on creating and customizing graph legends, see:

Help: Origin: Origin Help > Graphing > Graph Legends and Color Scales

Controlling Legend Update

When a data plot is added or removed from a graph layer, the default behavior is to update the legend. The Legend/Titles tab at the graph page level in the Plot Details provides a Legend Update Mode drop-down to control this behavior.

The default setting Update when Adding only affects the legend display of data plots that are added or removed. Previous legend customizations to existing plots, such as literal text entered manually, will be maintained.

Tutorial: Customize legend and add data plots

  1. Start with a new project in Origin.
  2. Open Windows Explorer and navigate to the subfolder <Origin EXE folder>\Samples\Import and Export\
  3. Shift-select the files S15-125-03.dat, S21-235-07.dat, S32-014-04.dat and then drag-and-drop the files onto an empty Origin workbook. The three files will be imported into three separate workbooks.
  4. Click on one of the workbooks, select the column B, and create a line plot.
  5. Right-click on the legend and select Legend: Update Legend... to open the legendupdate dialog.
  6. Change the Auto Legend Translation Mode drop-down to Custom, and in the edit box that appears below, enter the string:
    @WS, @LD3
    and then press OK to close the dialog box. The legend updates, displaying the sheet name and the third user parameter.
  7. Click on the second workbook, select column B, move the mouse over the right-edge of the column until it changes to Drag and drop mouse.png, and then drag-and-drop this data onto the graph to create a 2nd data plot.
  8. Repeat the procedure with column B from the third workbook. The graph will now display three data plots, and the legend will automatically update to display the identifier for all three plots.
  9. Click on each individual curve and use the Style toolbar to set a different line color for each. The legend will automatically update and display the new line color.

GSB Legend Tutorial.png

Special Legend Types

As mentioned, Origin supports these specialized legends for use with specific graph types. These legends can be customized and updated similarly to the Data Plot legend used by most 2D graph types.

Legend Type Menu to Create Used in situations where ...
Legend for Categorical Values Graph:Legend:Categorical Values At least one plot attribute (e.g. color, symbol shape.etc) is controlled by data indexing.

See the Legend for Categorical Values help page.
Point by Point Legend Graph:Legend:Point by Point The plot symbol style is controlled by data indexing, an increment list, or color mapping.

See the Point by Point Legend help page.
Legend for Box Chart Components Graph:Legend:Box Chart Components The graph is a box chart, or a grouped box chart.

See the Legend for Box Chart Components help page.

Annotating Your Graph

When we speak of "annotating" a graph, we are talking about adding text or drawing objects to the graph. Generally, these "annotations" help to enhance the graph in some way -- add a page title, add an arrow to draw attention to some graph feature, label data points, add a date-time stamp to note the time of graph creation, etc.

Annotating a graph can be as simple as adding a static text object and formatting it with Format toolbar buttons. Or you might add a more complex object that is dynamically linked to a variable value or to some LabTalk script that is executed whenever some user-specified event occurs.

The following table lists some common graph annotation tasks and available tools for accomplishing those tasks.

Origin 2018 added Unicode (UTF-8) support.

Task Method
Label Data Points and Plots
  • Choose Format: Plot ..., then click the Label tab and select Enable (not available for all plot types).
  • To label individual data points using a customizable label, see "Annotate a Data Point", below in this table.
Add Text Objects
  • Click the Text Tool Button Text Tool.png button, then click on the graph to place the object.
  • Right-click on the graph and choose Add Text from the shortcut menu.
  • Double-click on text to do rich text editing.
Add Layer Title
  • Right-click on graph and choose Add/Modify Layer Title from the shortcut menu to add/modify layer title in active layer.
Add Vertical/Horizontal Line
  • With a 2D graph active, use the Insert: Straight Line... menu item.
Annotate a Data Point
Add Drawing Objects Use the corresponding toolbar buttons on Tools toolbar. Origin supports:
  • Arrow, Curved Arrow.
  • Line, Polyline, Freehand Draw.
  • Rectangle, Circle, Polygon, Region.
Insert Equation, Word Object, Excel Object, Other OLE Object
  • Insert Equation group on the Tools toolbar.

You can download a free App from the OriginLab File Exchange, for adding LaTeX objects to worksheets and graphs.

Insert Image
  • Right click on the graph and choose Insert Images From Files.
Add Table
  • Click the New Link Table Button New Link Table.png button on the Add Object to Graph toolbar and then click on the graph.
  • From the main menu, choose Insert: Table.
  • To edit the table, double-click the table object.
Insert Date & Time Stamp
  • Date & Time Button Date Time.png button on the Add Object to Graph toolbar.
Insert Project Path
  • Project Path Button Project Path.png button on the Add Object to Graph toolbar.
Add Bracket with Asterisk
  • To indicate statistical groupings, click the Add Asterisk Bracket Button Add asterisk bracket.png button on the Add Object to Graph toolbar. Manually adjust the size and placement of brackets by dragging handles on the object.
Add XY Scale This is useful when using a nonlinear xy scale.
  • New XY Scale button Button Add XY Scale.png and click on a graph layer.
  • Select Insert: XY Scaler.

Tips for Editing Your Graph Annotations

  • Pressing CTRL when drawing with the Rectangle Button Rectangle Tool.png or Circle Button Circle Tool.png tools, will draw a square or circle (as opposed to a rectangle or ellipse).
  • Right-click an object and choose Properties... to edit the properties of the text or drawing object and set the default.
  • Use the Format and Style toolbar buttons to quickly modify some plot elements including plot colors and axis title font face or size.
  • For text objects, including the axis titles, you can edit text objects directly in "In-place Edit" mode. Double-click on a text object to edit. Use the Format toolbar buttons to add superscript, subscript, and Greek characters.
  • Do NOT set font size while in "In-place Edit Mode" unless you need to mix font sizes. The correct way to change font size is to click the text object once so that the green selection handles appear, then select font size from the Format toolbar. If you set while in In-place Edit mode, Origin will not indicate the proper font size when you hover on the text object.
  • When you are in In-place Edit mode, you can right-click and choose Symbol Map to insert special characters into your text object.
  • You can insert the contents of a worksheet cell into a text object by copying and pasting the cell contents. While in In-place Edit mode in the text object, right-click and choose Paste or Paste Link from the shortcut menu. Pasted data is static; Paste Linked data is dynamic and will change if data in the linked cell changes.
  • Also, when in In-place Edit mode, you can right click and choose Insert Info. Variable... to insert information related to plotted data, into the text object. Since the pasted information is linked to a LabTalk variable value, the inserted data updates if the variable value changes.
  • You can insert variable values into a text object using the LabTalk %, and $ substitution notation by setting the Link to (%,$), Substitution Level to 1 in the text object's Properties dialog box, Programming tab. Right-click on the text object and choose Properties from the shortcut menu.
  • You can use controls on the Programming tab to associate LabTalk script with a text or drawing object (for instance, see Linking Text Labels to Data and Variables). Enter your script in the text box and specify a Script, Run After condition for running the script. Use the Apply to drop-down to set the scope for the script.
  • You can copy a range (of cells) from a workbook and paste it into a graph as a table object. The table object is editable.

Grouping, Aligning and Arranging with the Object Edit Toolbar

Object Edit bar.png


You can group text labels and drawn objects so that they move or resize as a unit:

  1. To select objects, press SHIFT + click; or drag out a box around objects using the Pointer Button Pointer.png tool.
  2. To group the selected objects, click the Group button Group button.png on the Object Edit toolbar.
  3. To ungroup objects, click the Ungroup button Button Ungroup.png on the Object Edit toolbar.


You can align text labels and drawn objects using the tools on the Object Edit toolbar:

  1. Select objects to be aligned by holding the SHIFT key while selecting (or drag out a selection box using the Pointer Button Pointer.png tool), then click one of the align objects buttons on the toolbar. Note that objects will be aligned with respect to the first-selected object.


You can bring overlapping objects to the front or send them to the back:

  1. Select the objects that you want to move to the front or the back.
  2. Click the Front button Button Front.png or the Back button Button Back.png on the Object Edit toolbar.
Note: For more information on graph annotations, see your Origin User Guide:

Help: Origin: Origin Help > Graphing > Adding Text and Drawing Objects

You can also use the Object Edit Toolbar to manipulate graph layers. Use buttons to align and set a uniform size for multiple graph layers or to swap layer order.

Object Attachment and Scaling in Graphs

There are two settings that you should know something about, particularly if you subsequently modify axis scales or resize the graph layer after adding annotations: One is the object's Attach to method, the other is the layer's Scale Elements behavior.

Object Attachment

When you add a text or drawing object to an Origin graph window, the object becomes part of the active graph layer. Thus, if you resize or delete that graph layer, you will resize or delete the added object.

In addition to being part of the graph layer that was active at the time of object creation, note also that objects are attached to the graph in one of three ways, depending upon the type of object and where it is created on the page.


To view the "Attach to" setting for any object:

  1. Right-click on a text or drawing object and choose Properties....
  2. Click on the Programming tab and note the object's Attach to setting.
    Object Properties Attachment.png

Though objects remain a part of the layer that was active at the time of their creation, you can manage some object behaviors by changing the object attachment method. An object is attached in one of three ways:

  • Page. When attached to the page, objects are not affected by moving or resizing the graph layer, nor are they affected by a change in axis scales. These objects are still associated with a particular graph layer and they will be hidden or deleted if the layer is hidden or deleted.
  • Layer Frame. Objects that are attached to the layer frame, are resized and moved with respect to the layer frame. However, they are not tied to axis scales and are not affected by changes in the layer's axis scale values. Objects are hidden or deleted if the associated layer is hidden or deleted.
  • Layer and Scales. Objects are linked to a particular range of axis scale values. If you resize the layer, the object is resized accordingly. If you rescale the axes, the object moves in relation to the visible scale and will disappear from view if the linked axis scale range is not displayed. These objects are hidden or deleted if the associated layer is hidden or deleted.

To briefly illustrate why object attachment is important, let's look at the following graph. After the graph was created, arrows and text objects that point to their respective data plots, were added to the graph. Both arrows and text objects are attached to the graph Layer Frame.

Custom graph object attachment 1.png

Now, consider what happens to these objects when we modify the graph's X axis scale (recall that objects attached to the Layer Frame "are unaffected by changes in the layer's axis scale values"). Note that by changing the axis scale display range, we have shifted the data plots but the text objects and arrows did not move with them.

Custom graph object attachment 2.png

The remedy for this is to change the text and drawing objects' Attach to method to be Layer and Scales because "if you rescale the axes, the object moves in relation to the visible scale." Sometimes we may want an object to move with scale changes; at other times we may not. You can force either behavior if you keep in mind the Attach to setting.

Object Scaling

Object scaling often comes up when manually resizing the graph layer or when merging separate graphs into a single multi-panel graph (Graph: Merge Graph Windows). By default, added objects are set to Scale with Layer Frame -- that is, when the graph layer is resized, associated objects such as text objects, axis lines and ticks, and axis titles -- will be scaled proportionally. In the case where you merge four single layer graphs into a single, four layer multi-panel graph, these objects will be scaled down with the reduction in size of the layer frame.

Custom graph scale elements.png

However, this is another default behavior that you may want to change (e.g. you have set your font size to 10 pt. and you want to preserve that size), and you can do this using the Scale Elements control on the Size tab (Layer level) of Plot Details. If our goal is to keep objects at their current size when merging graphs, for instance, we can open the Plot Details dialog box and at the layer level (Format: Layer...), click on the Size tab, choose the Fixed Factor radio button and set the scaling factor to 1.

If you have resized the graph layer, either by merging multiple graphs into a single graph or by manually resizing the layer, you will find that the font sizes do not display at their "correct" size (i.e. if you select a text object, the Font Size list on the Format toolbar shows the original font size). Further, if select a text object, the Status bar will report two font size numbers -- "size" and "actual". You can reset font size so that they are shown as actual size, not scaled size, by choosing Graph: Fix Scale Factors. For more information, see FAQ-441 How do I export graphs with exact size and resolution as specified by publishers?

Arranging Graphs and Layers

Task Method
Merge multiple graph windows into a single graph window.
  • Graph: Merge Graph Windows... menu command

or

  • Merge Graph Windows button Button Merge.png on the Graph toolbar.

Origin has two dialog boxes -- Fitting Layers to Page and Fit Page to Layers -- that are useful for arranging multiple graph panels on the page and for adjusting graph margins.

Extract data plots in one layer to multiple layers.
  • Extract to Layers button Button Extract To Layers.png on the Graph toolbar.


Hint: to preserve your original graph, click the Duplicate button Button Duplicate.png before extracting to layers.

Extract multiple layers in a single graph to multiple graph windows
  • Graph: Extract to Graphs

or

  • Click the Extract to Graphs button Button Extract To Graphs.png on the Graph toolbar.

All layers are extracted to individual graph windows, even if a layer is linked to another layer.

By default, the layextract dialog box has Extracted Layers set to 1:0, which specifies that all layers be extracted. To extract only certain layers, clear Auto and use the layextract X-Function's comma/colon notation to control which layers are extracted. The notation 1:0 means starting with layer 1, extract all layers to graphs (0 denotes all). Specifying 1,3:4, for example, tells Origin to extract only the first, third and the fourth layer. Note that you can enable Keep Source Graph to preserve the original graph.

Add, arrange, resize, position, swap, align, or link layers
  • Graph: Layer Management... menu.
  • Position selected layers using Object Edit toolbar buttons. Hold SHIFT + click to select multiple layers and Align Left, Right, Top, Bottom, etc.

You can use the Layer Management tool's Swap control (Graph: Layer Management,Size/Position tab) to physically swap layer positions without reassigning layer numbers. Before doing so, set each linked layer's Units to % of Page (Size/Speed tab of Plot Details).

Link graph layers
  • Linked Axes Scales tab, layer level of Plot Details dialog box.
  • Link tab of the Layer Management dialog box.

When linking layers, the child layer must have a higher layer number than the parent layer.

Linked layers can be moved and resized together.

You can link layers' axis scale values to be Straight (1:1) or you can specify a Custom mathematical relationship.

Reorder layers

There are several ways to reorder graph layers (reassign Layer number for each Layer). Learn more about reassigning layer numbers in the mini tutorial below this table.

  • Method 1: Open the Layer Management dialog and click the row header (shown in image below) and drag it up or down to change the Layer order.

Swap area.png

For more information, see the Layer Management tool.

  • Method 2: Enter the following LabTalk script in the Command Window (Window:Command Window), then press Enter to execute.

page.reorder(n,m)

The command changes the nth Layer to the mth Layer.

  • Method 3: Use the Front and Back buttons on the Object Edit toolbar (these buttons work on the active layer as indicated by the graph layer icon Layer icon active.png). Alternately, right-click on the graph layer icon and change layer order using shortcut menu commands (e.g. Bring to Front).


Note: Reordering layers may break layer linking relationships.

A Note on Inset Graphs: In certain situations (see Tutorial, below), the order in which the layers are drawn on the screen becomes an issue. In this image, we have added an inset graph using the Add Inset Graph with Data button (Graph toolbar). The problem is that the data plot of the parent layer (red symbols) shows through the inset layer (small, black symbols). To fix this, we do two things:

  • Set the inset layer background Color = White -- by default, it is None (Format: Layer, then Background tab).
  • Set the layer Drawing order to Draw layer by layer (Format: Page then Layers tab).
Inset draw layer by layer.png

By default, an inset layer is added "on top of" the parent layer but if needed, you can click on the inset layer to select it, right-click and choose Bring to Front.

Exchange X-Y Axes
  • Graph: Exchange X-Y Axes menu command
  • Exchange Axes Button ExchangeXYAxes.png button on the Graph toolbar.
Move a plot(s) to another layer
  • Method 1: Open Plot Setup dialog(by selecting Graph:Plot Setup), expand the bottom panel, select a plot and drag it from a layer to another layer.
  • Method 2: Run laymplot -d; (e.g. open the Script Window, type the command and press <Enter>) to open the Move Plot dialog to specify plot(s) to move and a target layer.

You can move a plot by Copying(CTRL+C or Copy Range context menu) and Pasting(CTRL+V or Paste context menu) operations, between different layers or different graphs. Please note, the pasted plot won't be associated with the source data of copied plot, but exists as a loose dataset.

In a multi-layer graph, layer order determines drawing order. The 1st layer is plotted and then 2nd layer is plotted on top of it, and so on. The layer with higher number is drawn on top of the layer with lower number. This is important when plots in one layer overlay plots in another layer. When necessary, you can change layer order to change plot drawing order.

This mini tutorial shows you how layer reassignment works. Use the preview window to see how layer number reassignment affects your graph.

  1. Click Help: Origin Central or press F11.
  2. Click on the Graph Sample tab, set the Samples in drop-down list to Area Plots and double-click on this graph:
    Custom graph layermanage tutorial.png
  3. Activate the graph Area Plot With Horizontal Color Gradient, then click the Extract to Layers button Button Extract To Layers.png on the Graph toolbar. Set both number of rows and columns to 1, click OK, then, click OK again for the page spacing. The green layer is on the top of the yellow layer in the figure. The purpose of this last step was simply to create a two layer graph in which the data in one layer partially hides the data in the other layer. What we will do now is to reorder the layers and set the yellow layer on the top, giving you a better view of the two plots.
    Reorder1.png
  4. Choose Graph: Layer Management... menu, then drag the row header "1" of the Layer1 in the Layer Selection downward under the Layer2 (indicated by a blue line), and click OK.
  5. You can see the yellow layer is on the top now.
    Reorder2.png


Alternate Method: Beginning with Origin 2017, you can use the Front Button Front.png or Back Button Back.png toolbar buttons (located in the Object Edit toolbar, or at the top of Layer Selection box in the Layer Management dialog) to bring a layer forward or push it backwards. Just as with the previous method by dragging row header in Layer Management, this method swaps layer numbers.

You can easily add an inset layer with data by clicking the Add Inset Graph With Data button Button Add Inset Graph With Data.png on the Graph toolbar or Insert: New Layer(Axes): Inset With Data (Linked Dimension) .

You can copy a layer from one graph window to another graph window. Click to select the layer first (a frame shows around the layer). Then press Ctrl+C or right-click and choose Copy. Click on the target graph window, then right-click to Paste.

Note: For more information on merging graphs, see your Origin User Guide:

Help: Origin: Tutorials > Graphing > Layers > Adding and Arranging Layers

Help: Origin : Origin Help > Graphing > Reference > The Merge Graph Dialog Box

Templates and Themes

Origin's flexible Page > Layer > Plot hierarchy, plus an extensive list of editable object properties makes it easy to customize and save your graph settings for repeat use. You can preserve your custom settings in a couple of ways -- either with templates or with Themes. These concepts are introduced below.

Note: For detailed information please refer to Origin Help file, see:

Help: Origin: Origin Help > Graphing > Creating Graphs from Graph Templates

Help: Origin: Origin Help > Customizing Your Graph > Graph Formats and Themes

Templates

Customizations to your graph can be saved to template files for repeat use. For example, you can customize a graph page to add multiple layers, set relationships between layers, modify data plot properties, and then save all of these attributes as a graph template (.otpu) file. You can further specify that the graph template be "cloneable" allowing you to link these graph customizations to dataset Long Name, Short Name or worksheet column index number and quickly re-create fairly complex graphs using new data.


A few things to note:

  • In a fresh Origin installation, each one of Origin's 100+ built-in graph types uses a specific "system" template when creating a particular graph type. When you click on a Plot menu graph or graphing toolbar button (e.g. Area Button Area.png), one of these templates is used to plot the selected data.
  • System templates are installed to the Origin Program Folder. They are completely customizable but you cannot overwrite the template files in your Program Folder (see next).
  • When you customize and save a system template, it is saved by default to your User Files Folder (UFF). If you save the customized template to the same system template name, the customized template replaces the system template as the template associated with the Plot menu command or toolbar button used to create that plot type. Additionally, the customized template is added to the user's Template Library.
  • To view customized or system graph templates, click Plot (workbook or matrix should be active) and under Templates, choose User: Template Library or System Templates.
  • You can save a graph template anywhere (and with any name) that you like -- it does not need to be saved to your UFF. However, by saving customized templates to your UFF, they will be collected in one, easily-remembered place and they will be readily available when you upgrade your Origin software.
Template Library 2016 GSB.png

Themes and Copy/Paste Format

An Origin Theme is a file containing a set of object properties. There are four kinds of Theme files in Origin: graph Themes, worksheet Themes, dialog Themes and function plot Themes.

Graph Themes are a collection of properties of different elements in a graph window. A graph Theme can be very simple (e.g. graph axis major and minor tick direction settings) or it could be something more complex (e.g. a combination of page dimensions, layer background, axis scales, and color palettes). Whether simple or complex, the purpose of graph Themes is to allow you to quickly change one or more object properties in an existing graph, or to apply a consistent set of properties to a selection of graph windows, without having to recreate a suite of settings, or to apply those settings one-by-one to individual graph windows.

All graph objects have a customizable set of properties that are specific to the object type. Therefore, it follows that the properties that can be saved as a Theme differ depending upon the selected object. You can (1) copy a Theme from one object and "paste" it to another object of the same type or (2) you can save a Theme from one object as a named Theme and apply that named Theme to other like objects at a later time.

  1. Right-click on an object in a graph window (e.g. a plot) and choose Copy Format. Depending on what you click on, there may be sub-menu items under the Copy Format shortcut menu, which give you the option as to what exact format to copy.
    • To apply the copied formats to a single object, right-click on your target graph and choose Paste Format To. Again, this shortcut menu might has some sub-items that limit what to paste. In this way, the formatting option(s) from your source object should be applied to your target object.
    • To apply the copied formats to multiple windows in the project, keep the source graph window active and select Edit:Paste Format(Advanced)... from the Origin menu. This opens the Apply Formats dialog box. Here you have the option of editing or selectively applying formats to one or more graph windows in the Origin Project.
  2. If you would prefer to save formats to a named Theme file that you can re-apply at a later time, choose the Save Format As a Theme... shortcut menu item, then use Preferences: Theme Organizer to apply the Theme when needed.

Theme Organizer

Use the Theme Organizer (Preferences: Theme Organizer) to organize and apply Themes to graphs. With this dialog box you can apply a graph Theme simultaneously to multiple graphs in the Origin project file.

To combine multiple Themes in the Theme Organizer dialog box:

  1. Press the CTRL key while selecting multiple Themes, then right-click and choose Combine from the shortcut menu. The shortcut menu in the tool provides an option for editing a Theme, allowing the user to add/delete properties from an existing Theme.


Graph theme organizer.png


  • The Theme Organizer has separate tabs for managing graph, increment list, worksheet, dialog boxes and plotted mathematical function Themes.
  • If you right-click on a graph Theme and save it as your System Theme, then each time you plot a new graph, this System Theme will be applied regardless of the settings that were saved with the graph template†.
  • Use the System Increment Lists tab to manage increment lists and selectively apply them to project graphs.
  • You can load a graph Theme in the Export Graph dialog and the Theme will be applied to the exported image file.

† If you don't want a System Theme to be applied automatically to the graph, save the graph as a template (File: Save Template As) and clear the Apply System Theme to Override check box.

Topics for Further Reading