4.3.11 Rise Time

Summary

In a step-like signal, rise time refers to the time required to change from a specified low value to a specified high value (or from a specified high value to a specified low value in the case of fall time). Origin's rise time tool allows you to graphically select a rectangular area tracing a rising or falling step in the signal, and from it calculate the rise time or fall time for this selected step.

What You Will Learn

With this tutorial, you will learn how to:

  1. Use the Rise Time gadget tool to calculate the fall time.
  2. Change the settings for fall time calculation.
  3. Set the display elements on the graph.
  4. Select the desired output options and output the result to worksheet.

Steps

  1. Start a new workbook.
  2. Select menu Data: Import from File: Single ASCII... to import the data file <Origin Installation Directory>\Samples\Signal Processing\Step Signal with Random Noise.dat.
    SP Tutorial Rise Time 1.png
  3. Highlight column B and make a line plot of it by selecting Plot: Line: Line from the menu.
    SP Tutorial Rise Time 2.png
  4. Click the Scale In (SP Tutorial Rise Time 3.png) button on the Tools toolbar, then select a range along the X axis from about 500 to 700, so that we can focus on this portion of the plot.
    SP Tutorial Rise Time 4.png
  5. With the graph active, choose Gadgets: Rise Time... from the menu to launch the tool.
  6. In the dialog box, click the ROI Box tab and set X Scale From to 510 and To to 650. Set Tool to Fall Time and Method to Histogram.
    SP Tutorial Rise Time 5.png
  7. Click the Fall Range tab and change From (%) of Step Height to 20 and To (%) of Step Height to 80.
    SP Tutorial Rise Time 6.png
  8. Click the Quantities tab, check only three check boxes: Dataset Name(name), Fall Range(dVref) and Fall Time(dT).
    SP Tutorial Rise Time 7.png
  9. Click the Output To tab, clear Script Window and check Append to Worksheet.
    SP Tutorial Rise Time 8.png
  10. Click the Display on Graph tab, expand the Indicator branch, and change Edge Color to Blue. Check Fall Range.
    SP Tutorial Rise Time 9.png
  11. Click OK to add the rectangular region-of-interest (ROI) to the graph.
    SP Tutorial Rise Time 10.png
  12. As the above image shows, the two red horizontal lines delineate the upper level and lower level. The vertical distance between the two blue lines is the fall range, shown by the two indicator points on the line plot. At the top of the rectangle, the fall time and fall range are reported.
  13. Click on the triangle button in the upper-right corner of the ROI to open a menu and select Fix ROI Position, so that the yellow ROI rectangle is locked in place.
    SP Tutorial Rise Time 11.png
  14. Open the menu again and click New Output to output the results. Open the menu again and choose Go to Report Worksheet.
    SP Tutorial Rise Time 12.png
  15. The report worksheet is activated and we can see that the three parameters that we chose on the Quantities tab are reported.
    SP Tutorial Rise Time 13.png