Origin 2019 Features

Analysis

Batch Processing

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-12759

Better Batch Processing with Multiple files in Analysis Template

Better Batch Processing with Multiple files in Analysis Template

If user has multiple data files imported into multiple sheets but also have other reference sheet, etc., Origin 2019 can better detect import data worksheet and only import to them when doing batch processing. 

E.g. user import 3 files into 1st 3 sheets. 4th sheet is a reference sheet, some analysis is done and analysis template is saved.

When using such workbook as analysis template for batch processing 6 files, first 3 will be processed together; second 3 files will be processed together. 

0

ORG-18539

Block Recalculation

Block Recalculation


Fitting

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18656

LabTalk command nlbegin supports to pick up error bar when fitting from graph

LabTalk command nlbegin supports to pick up error bar when fitting from graph

Example:
Active a plot with error bar then run the following labtalk script:
nlbegin func:=gauss; nlfit;
nlend 1;

0

ORG-16862

Output Adj. R-square and Pearson's r of a scatter matrix plot to a result sheet

Output Adj. R-square and Pearson's r of a scatter matrix plot to a result sheet

When Pearson's r or Adj. R-square is checked in Plot Scatter Matrix dialog, a new result sheet named ScatterMatrixStats will be created, with all Adj. R-square values and Pearson's r values in it.

0

ORG-16862

Output Adj. R-square and Pearson's r of a scatter matrix plot to a result sheet.

Output Adj. R-square and Pearson's r of a scatter matrix plot to a result sheet

Origin 2019 added "ScatterMatrixStats" worksheet to arrange Adj. R-square values and Pearson's r values of scatter matrix plot.

0

ORG-18756

Support to define both 32bit and 64bit External DLLs in a fdf file

Support to define both 32bit and 64bit External DLLs in a FDF file

Different dll files will be loaded by the same function if it's name follows the below rules:
32bit: DLLname.dll
64bit: DLLname_64.dll

0

APPS-275

Peak Deconvolution

Offer an intuitive and interactive interface to perform peak analysis.

Download Peak Deconvolution app from the page and install the app.

This app is capable of performing peak analysis intuitively and interactively. It is able to define baseline, then detect the peaks, and fit peaks.

0

APPS-450

Global Fit with Multiple Functions

Perform global fit and share parameters for different functions.

Download Global Fit with Multiple Functions app from the page and install the app.

This app is capable of performing global fit with multiple functions, and parameters can be shared across different functions.

0

APPS-180

Image Object Counter

Object identification and measurement on image.

Download Image Object Counter app from the page and install the app.

This app is capable of identifying the objects on image, together of measuring their characterics.

Click the app icon to start this app by opening a dialog. Then load an image as source image (If the active window is image window, this active image is used as the source image for analysis.), and then insert operations by using the menu. You can also save or load the operations to or from a file. And after getting the target objects on image, you can output the measurement results of these objects.

0

APPS-268

Design of Experiments

Design an experiment, fit a model to experimental data, and find best factor settings that optimize responses.

Download Design of Experiments app from the page and install the app.

This DOE app helps you determine the relationship between factors affecting a process and the output of that process.

You can use it to design an experiment, analyze experimental data and optimize output.

Features

  • Various types of designed experiments to help you create a design.

  • Customization of design table by replication, randomization, blocking, etc.

  • Fit of mathematical model to data from test runs.

  • Diagnostic statistics and graphs to help you interpret the results.

  • Optimization of response after defining factor constraints.

0

APPS-453

Fitting Function Libray

Search, find and add fitting functions to Origin.

Download Fitting Function Libray app from the page and install the app.

The purpose of this app is to allow Origin user search, find and add new fitting functions to Origin. Simply select the function and click a button to download the FDF file and add the function to Origin, then find and use it when perform fitting.

This app will update the function list automatically if Origin provides some new functions even after installation.

General

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-8760

Dialog Theme context menu Improvements for Import tools

Dialog Theme context menu Improvements for Import tools

0

ORG-18710

Hide Recalculation Locks on the graph

Hide Recalculation Locks on the graph

For analysis done on each plot, a lock is created under layer icon. If there are many locks, it's hard for user to view the graph.

Choose View: Show: Lock menu to uncheck it to hide locks in graph window.

Labtalk page property page.lock=0 to hide it.

0

ORG-18864

Set default node's shrink/expanding status on hierarchical result sheet for each analysis

Set default node's shrink/expanding status on hierarchical result sheet for each analysis

User can right click any node on result sheet and choose Save Node Configuration to save default node status of the analysis. Next time when you do such analysis, it will used the saved configuration. 

  • Useful feature for you if you want to print/export consistent reports from analysis

  • Each analysis tool can have its own default node configuration.

0

ORG-18118

Use new Window View for preview on more analysis tools

Use new Window View for preview on more analysis tools

Below analysis tool support:

  1.  XYZ (Log) Gridding

  2.  IIR Filter

 Matrix/Surface Fit

Mathematics

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18857

Add Excel Bicubic interpolation

Add Excel Bicubic interpolation

  1. Rename the current Bicubic method in 2D Interpolate/Extrapolate tool to be "Bicubic Convolution".

  2. Add option "Bicubic Lagrange" (enum as "lagrange") as the last one in Method combo.

Peak Analysis

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18333

Support threshold as a certain value in peak finding

Support threshold as a certain value in peak finding

Support Peak Filtering method in PA

 

Signal Processing

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

APPS-179

Align Peaks

Shift, scale and trim data to align various peaks.

Download Align Peaks app from the page and install the app.

This app can be used to align peaks of spectra by shifting, scaling, clipping and inserting data.

0

APPS-499

Independent Component Analysis

Separate mixed signals into sub-components.

Download Independent Component Analysis app from the page and install the app.

This app can be used to decompose observed mixed signals into sub-components which are assumed to be independent from each other. Input data can be either columns or matrices.

Three methods are supported:

  • FastICA

  • Information-Maximization (Infomax)

  • Joint Approximate Diagonalization of Eigenmatrices (JADE)

Statistics

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-15972

Set column as categorical for analysis tools related to grouping

Set column as categorical for analysis tools related to grouping

If a column is mostly text and the column is used as grouping column for analysis tools, Origin will automatically set it as categorical so you can easily adjust result sheet orders.

0

APPS-211

Stats Advisor

Help you pick the most appropriate statistical tool that is best suited for your data, including the tests, the graphs, and the Apps.

Download Stats Advisor app from the page and install the app.

If you are all new to Origin or are unfamiliar with the statistical procedures, this app could help you get started.

Open the Stats Advisor App, you could see three column, including What do you want to do, Your options and Suggested feature(s).

Data Handling

Database Import

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18853

Data Connector for SQL

Added a system variable @sqli= to determine whether the menu and the tooltip on the DB icon in the top left of a worksheet are enabled. By default it is 0.

Added a system variable @sqli= to determine whether the menu and the tooltip on the DB icon in the top left of a worksheet are enabled. By default it is 0.

Import Data

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18790

Add system variable so that import with "Replace Existing Data" will really replace existing data

Add system variable so that import with "Replace Existing Data" will really replace existing data

Added a system variable @IRE for import Excel file with "Replace Existing Data" Import Mode.

@IRE = 1(default): Replace the existing sheets in the active Workbook from the active sheet on.

@IRE = 0: Only replace the active sheet, and create new sheets to import following Excel sheets.

0

ORG-15666

Check new LibXL update

Updated the new LibXL version 3.7.1 to Origin, so that Origin 2019 will support importing more higher version Excel files.

Updated the new LibXL version 3.7.1 to Origin, so that Origin 2019 will support importing more higher version Excel files.

0

ORG-18352

Import Wizard Support relative OC File Path for user defined type

Import Wizard Support relative OC File Path "<App Folder>" for user defined type.

Import Wizard Support relative OC File Path "<App Folder>" for user defined type.

0

ORG-2266

Support Date Time Data with higher precision

Support Date Time Data with higher precision

Add three system variables:

1. @DSP: a project property, the date system in current project

  • 0: the current date system, +12 hours off from julian day system

  • 1: julian day

  • 2018: 2018 date system, 0 at 00:00 on Jan 1 2018

2. @DSO: the actual offset for the current date system, in day

And also, when the date system is 2018, Import Wizard support more higher precise date data, for example: When import time data like "2/5/2040 15:59:59.994983" using Import Wizard, can set Custom Date Format as "MM'/'dd'/'yyyy HH':'mm':'ss'.'######" to import.

Importing Third Party Formats

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18949

FAMOS import gets error about header not readable

Support importing newer FAMOS files that have the keys "NL" and "NV".

Support importing newer FAMOS files that have the keys "NL" and "NV".

0

ORG-18722

Improve TDMS Import to make it work with Batch Processing

Improve Batch Processing to support TDMS files.

Improve Batch Processing to support TDMS files.

0

ORG-18157

Support import HEKA newest instrument model version 1000

Support importing newer HEKA file, up to version 2x90.3.

Support importing newer HEKA file, up to version 2x90.3.

Workbook and Worksheet

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-19012

Add "1 000.0" as numeric separators in Tools: Options dialog.

In Tools: Options dialog, a newly entry "1 000.0" is added for Numeric Separators.

In Tools: Options dialog, a newly entry "1 000.0" is added for Numeric Separators.

0

ORG-18773

Auto fill column label row contents to the right

Auto fill column label row contents to the right

Double clicking the bottom-right corner of the cell with formula in Column label rows. The formula will be autofilled to all cells to the right.

0

ORG-18099

Column List View

Choose View: Column List View menu to view a list of columns with associated metadata and sparklines. Data cells are not displayed. You can select column(s) in this list view and perform the usual graphing and analysis operations.

Choose View: Column List View menu to view a list of columns with associated metadata and sparklines. Data cells are not displayed. You can select column(s) in this list view and perform the usual graphing and analysis operations.


0

ORG-18382

Copy and Paste Filter condition support

User can select the Copy Filter from filter's context menu or select a filter condition in Filter cell and Ctrl+C to copy a filter, and then paste it to other column(s).

User can select the Copy Filter from filter's context menu or select a filter condition in Filter cell and Ctrl+C to copy a filter, and then paste it to other column(s).

0

ORG-18166

Copy non-continuous rows

Support to copy non-continuous rows

Before Origin 2019, when selecting non-continuous rows and copying and pasting, the unselected rows in between were copied/pasted as well.

0

ORG-18990

Create Subset Sheet context menu to extract selected rows to a new sheet.

Create Subset Sheet context menu to extract selected rows to a new sheet.

After manually select multiple rows or select multiple rows based on data highlighting feature, right click the selected rows and choose Create Subset Sheet context menu

Corresponding X-Function: wcopy.

0

ORG-18759

Custom numeric format more works

Custom numeric format more works

  1. Improvement for Latitude Longitude display format.
    General syntax is now like this:

    D[Space][M[S]][F/D][n] [EW/NS[B]]


    New:
    F/D: F to indicate not to include symbols and space is always inserted. D to indicate only exclude last symbol.
    EW/NS: EW for longitude, NS for latitude
    B: before the numbers. if not specified, will be after.

    Example: For decimal degree of latitude -3.03423

    DMD3 NS -> 3° 02.053 S
    DMS1 NSB -> S 3°02'03.2"

  2. Support direct editing in custom numeric format using Hex.

0

ORG-19184

Improve Mask cells by condition to support noncontinuous columns and row ranges

Improve Mask cells by condition to support noncontinuous columns and row ranges

Highlight noncontinuous columns or row ranges, select menu Column: Mask Cells by Condition to open colmask dialog, masks cells by your condition.

0

ORG-18938

Masked status kept when copying and pasting data.

Masked status kept when copying and pasting data.

After pasting data into new sheet, masked data will be still masked. In the past, masked status was not kept.

A new system variable @CPM has been added to control the behavior, default value is 1.
Note:

1. Paste Transpose, Paste Link, Paste Link Transpose will not paste mask status.

2. Copy (full precision) will not copy the mask status.

0

ORG-14386

New XFunctions to join columns by plot designation

A new X-Function coljoinbydesig is added to concatenates columns by plot designation. Right now, it's only available by script access.

A new X-Function coljoinbydesig is added to concatenates columns by plot designation. Right now, it's only available by script access.

0

ORG-18380

Numeric allow percent (%) and engineering notation

Numeric allow percent (%) and engineering notation

  • Type 12% will convert it into 0.12 automatically. You can disable it by system variable: @cap=0

  • Convert Percent (%) to Number when Copying or Importing ASCII or Excel Data with %

  • Type "1k" in a cell, then convert column to Numeric format will change it to 1000 automatically.

0

ORG-18525

Press and scroll mouse wheel to view data

Press and scroll mouse wheel to view data


0

ORG-18351

Support Hex numbers

Support Hex numbers

  • Custom numeric display such that hex numbers can be used in worksheet cells/columns natively, without using Hex2Dec kind of conversion like in Excel. In Column Properties, set Display as Custom and then set Custom Display as %X or %0<#hexdigits>I64X e.g., %012I64X means 12 hexdigits. X can be in lower case.

HexDisplay.opju  demonstrates the power of using Custom Display Format of Numeric, as well as the various improvements


0

ORG-14837

Treat missing as blank Improvements

Treat missing as blank Improvements

  • Missing values will show as blank in worksheet.

  • When importing excel file with empty cells, or copy and paste data with empty cells from Excel, 

  • Before Origin 2019, when copying some data with blank rows above it and pasting it to new column, blank rows were removed. In Origin 2019, they are kept.

  • If there are empty cells above the data, below data or within data range, click on it, status bar shows <i1:, >i2:, or nothing correspondingly. These empty cells will not be included in calcuation, statistics. 

  • When selecting a cell outside the data bound, status bar will show "<i1: "(begin) or ">i2: "(end).

  • Worksheet cell background color show differently if outside i1 i2 by default. There is a checkbox Indicate unused cells with a shaded background in Workbook Properties dialog. System variable @COR determines the darkening intensity.

  • i1 starts from 1st row unless set otherwise.

  • Delete data on last row will shrink data size (i2 updates)

  • Ctrl+delete to add missing value to a cell, in cases that user wants to make sure each column has same length. 


0

ORG-18478

User Parameter Row Formula

User Parameter Row Formula

Worksheet Data Manipulation

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18358

Conditional Format Manager

Choose Worksheet: Conditional Formatting to manage and edit ranges with conditional format.

Choose Worksheet: Conditional Formatting to manage and edit ranges with conditional format.

0

ORG-16420

Split worksheet improvements

In Split Worksheet tool, add a new option "Retain 1st N Columns" for "By Number of Columns"/"By Column Label" split mode to keep the 1st N columns in the splitting worksheet result.

In Split Worksheet tool, add a new option "Retain 1st N Columns" for "By Number of Columns"/"By Column Label" split mode to keep the 1st N columns in the splitting worksheet result.

0

ORG-18290

Worksheet Conditional Formatting: Duplicates

Select a range of cells or column(s) and color cells with duplicate values.

Select a range of cells or column(s) and color cells with duplicate values.


0

ORG-18211

Worksheet Conditional Formatting: Heatmap

Worksheet Conditional Formatting: Heatmap

0

ORG-18289

Worksheet Conditional Formatting: Highlight

Select a range of cells or column(s) and color cells that match rules.

Select a range of cells or column(s) and color cells that match rules.


Graphing

Axes

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-18350

Axis dialog to support Custom Numeric format

Axis dialog to support Custom Numeric format

Easier way to enter From and To, special ticks, reference lines and break, etc. in axis dialog. Allow user to type 0 and 2 which will refer to 0 and 2 pi. The same issue exists when set Major Tick type as By Custom Positions; Special Ticks, Break, and Reference Lines tab.

0

ORG-18663

Object Manager: Move Plot to Other Y Axis

Object Manager: Move Plot to Other Y Axis

0

ORG-18772

Show Major tick at min and max of axis

Show Major tick at min and max of axis

Box Chart

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-16102

Customize outliers in box chart

Customize outliers in box chart

In Plot Details dialog, if Outlier is checked on Box tab, then Outlier tab appears for outlier customization.

0

ORG-13417

Display the median value in box chart

Display the median value in box chart

Add a Median check box to show Median value Label

0

ORG-17983

Enable vertical auto position for box chart label

Enable vertical auto position for box chart label

Add Auto Reposition to Avoid Overlap checkbox in Label tab.

Contour

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-18676

Contour label consider custom boundary

Contour label will consider the custom boundary

When custom boundary is on, Contour label will consider boundary now. Use @TCBL=0 to disable the feature

0

ORG-18314

Image Plot should have missing value support similar to contour

Image Plot should have missing value support similar to contour

Add Missing value control for Image plot.

0

ORG-18823

Support Custom Display Formats for Contour Labels

Support Custom Display Formats for Contour Labels

Customizing Color

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-18939

Add independent color scale on layout window

Add independent color scale on layout window

When adding 3d or contour graph with color scale into layout window, the color scale is very small in each graph. In Origin 2019, you can add an independent color scale object in layout and customize it to match the color scale in graph.

0

ORG-18753

Support 3-Color Limited Mixing for Color Mapping

Support 3-Color Limited Mixing for Color Mapping

Drawing Objects

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-18939

Support adding color scale on layout window

Support adding color scale on layout window

Support adding independent color scale to layout window by Add Color Scale button in add object to graph toolbar.

General

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-18919

Better Default Numeric Display Format For X Y Z in Tooltip

Better Default Numeric Display Format For X Y Z in Tooltip

Data Tooltip display custom format, following case covered:

  1. User unit

  2. Engineering

  3. DMS

  4. PI

  5. Percent

0

ORG-17760

Data Highlighter

Data Highlighter

0

ORG-4006

Data Point Tooltip

Data Point Tooltip

0

ORG-17997

Edit Range supports specifying X values and an Apply button

Edit Range supports specifying X values and an Apply button

User can right click a plot and choose Edit Range context menu to edit the display range.

In the past, user had to specify by row index. In Origin 2019, user can specify x range. 

Apply button is also added.

0

ORG-19113

Graph: Fix Scale Factors dialog improvements

Graph: Fix Scale Factors dialog improvements

Set fixed scale factor for all layers so that font, axis, plots and objects will not be resized when layer is resized.

When clicking OK, current size and thickness of all elements are adjusted to maintain current look.

Show smart hint for PD resize as well.

0

ORG-19043

LabTalk set command for custom increment list more support

LabTalk set command for custom increment list more support

Newly switches are added for set command to set custom increment list for color.

 

0

ORG-18505

Longer minus sign in Graph

Longer minus sign in Graph

0

ORG-18530

Object Manager: Data manipulation related to grouped plots

Object Manager: Data manipulation related to grouped plots

Usually when multiple data is selected and plotted, they are grouped so different colors are assigned to each pot.

Right click a plot in the group in Object Manager and choose Remove, the plot will be removed from the group. In the past, the whole group is removed.

This also works if you single click twice to select a plot in a group on the graph and then choose Remove

There is also Set as Group End context menu. When it's selected, all plots below it will be isolated from the group. 


0

ORG-17536

Pick point tool

Pick point tool

When mousing over a data point, data point tooltip shows. Right click in the tooltip and choose Pick Point to enter picking point mode.

Double click or single click +Enter key to keep on picking points. Press ESC to finish picking points. A output sheet will be created with pointed points for further analysis. 

0

ORG-19111

Pick Points Improvements

Pick Points Improvements

Improve Pick Points to display and output column-based range string. If range is too long for the dialog to display, show it with a tooltip when mouse over range.

Make data source column range strings in output into links.

0

ORG-14451

Rename plot group's long name in Object Manger

Rename plot group's long name in Object Manger

Right click group node, e.g. g1, g2 and choose Rename to give a meaningful group name.

Such group long name shows in

  • Data menu

  • Layer Contents dialog when mousing over group name

  • Labtalk commands are added to set and get group name:

    set %C -g1 Name; // %C must be Group Head get %C -g1 Name;


0

ORG-11302

Show Categorical values in Color List, Shape List, Interior List tab

Show Categorical values in Color List, Shape List, Interior List tab

Add a 2nd column "Categories" in the following tabs and increment editor dialog:

  1. shape list tab

  2. interior list tab

  3. color increment editor dialog

  4. pattern increment editor dialog

  5. shape list tab of 3D bar

0

ORG-17567

Show Master Items on Screen should be default and convert existing

Show Master Items on Screen should be default and convert existing

  1.  Allow any object to be skipped as master items

  2. Apply page size to all

  3. Allow rotate from Landscape to Portrait

  4. LT template saving needs to dump message

0

ORG-16241

Support more than one custom incremental lists for one property of one plot

Support more than one custom incremental lists for one property of one plot

Support more than one incremental lists for one property(currently is color or pattern) of one plot. User could ctrl-click to edit the increment list in fly-out to arrange elements. 

Graph Types

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-16220

Cluster Plot

Cluster Plot

Known Issue: Slow when there are many panels.

0

ORG-2188

Contour with Categorical Z Values

Contour with Categorical Z Values

If Z column is categorical, when choosing Plot: Contour: Contour with Categorical to plot it.

The graph will be plotted with color scale for each category.

0

ORG-19031

Grouped Scatter Plot

Grouped Scatter Plot


0

ORG-12982

Heatmap with Labels

Heatmap with Labels

Choose Plot: Heatmap: Heatmap with Label to directly plot a heatmap with Z values showing on each cell.

Customize the label on each cell on Labels tab of Plot Details dialog. E.g. Set decimal digits to display, etc.

Choose Y or Y, etc. from Label Form dropdown list on Labels tab to show  X or Y value as label.

0

ORG-16798

Parallel Plot

Parallel Plot


0

ORG-17640

Row-wise Line Series with Error Bars

Row-wise Line Series with Error Bars

When data is organized row wise, choose Plot: Line+Symbol: Row-wise to plot it.

  • YError column is supported.

  • X info. can be put to column label rows.

0

ORG-15225

Smith Chart handles negative real for z

Smith Chart handles negative real for z

@NRSC = 1 to disable this change

0

ORG-15225

Smith Chart improvements requested by Michael Lehnert Additive

Smith Chart more improvements

  1. Support zoom

  2. Data reader supports more results

  3. Handle negative real for z

0

ORG-18557

Stacked Histogram

Stacked Histogram

0

ORG-17834

Tetrahedral Scatters/Lines/Line+Symbols

Tetrahedral Scatters/Lines/Line+Symbols

For XYZZ data, Origin can normalize each row and plot in tetrahedral (Pyramid) coordinate system.

0

ORG-18606

Trellis Plot with Double-Y Axes

Trellis Plot with Double-Y Axes

0

ORG-17822

Violin Plot

Violin Plot

0

APPS-522

Graph Publisher

Help to export graphs and prepare a graph for publication.

Download Graph Publisher app from the page and install the app.

Features

  1. Simplified interface that eschews complex settings for exporting graph.

  2. Wizard interface to help you check and set the graph format step by step.

  3. Save the journal requirements as checking rule for graphs. Note that there are several built-in checking rules of various journals, you could use it directly.

  4. Multiple methods for saving the modified graphs: copy page to the clipboard, only keep the modified graph and keep both the original graph and the modified graph.

  5. Ability to export the modified graph.

Layer and Plot Management

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-18585

Need 4 directions margin controls for fit layers to page

Need 4 directions margin controls for fit layers to page

 Support left right top bottom margin for fit layers to page. Note we do not need to modify the gui of fit layers to page, just let the margin setting apply to 4 directions.

0

ORG-18913

Object Manager: Move a plot from one layer to another by dragging in Object Manager

Object Manager: Move a plot from one layer to another by dragging

Drag a plot in Object Manager to another layer in Object Manager and release the mouse.

Line and Symbol

ID

JIRA

SUMMARY

DETAILS

0

ORG-14809

Auto Fill/Distribution Curve/Line Color

Auto Fill/Distribution Curve/Line Color

Add Auto option for Box, Column and Bar graph's pattern fill color. When Auto is on, Fill color is slightly lighter than Border color. A new system variable @PFACF is introduced with default value as 65. Auto Fill color will be lighter when number increases. 


Auto option for distribution curve in Box chart and Histogram also changed to follow the same logic. And a new system variable @PDACF is introduced with default value as 30. Auto distribution cuve color will be darker when number increases. 

0

ORG-17400

Line Cap Control for Plots like Line and Column

Line Cap Control for Plots like Line and Column

Add a new system variable to @LCP to control the end of lines for Line+Symbol plot. 

  • 0: round (default value)

  • 1: square

  • 2: flat

0

ORG-17992

More Line Plot Styles

Support more Line Plot styles

0

ORG-19029

Support subset for Scatter Plot

Support subset for Scatter Plot

Subset is available for scatter plot in Origin 2019. When X is <autoX>, Spacing tab will show in Plot Detail dialog with Enable Subset Option, with option By Size and By Column. The new plot type Grouped Scatter-Indexed Data is base on this feature.

Multi-Axes/Multi-Panel

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-17939

Speed issue when there are too many panels

Speed issue when there are too many panels

Limit the number of panels. System variable is @nop. The value of nop is 50 by default.

Publishing

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-18170

Add Zooming to expGraph Image Pane

Add Zooming to expGraph Image Pane

Add zooming to image panel of expGraph that allows for zooming when raster is exported file type.

Specialized

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-8143

2d Vector graph should also support Scale Length with Magnitude like 3D vector

2D Vector graph should also support Scale Length with Magnitude

 Support Scale Length with Magnitude for both 2D Vector XYXY and 2D Vector XYAM. Note 2D Vector XYAM have Magnitude control to modify magnitude, the Scale Length with Magnitude should base on the modified magnitude. 

Text Labels & Legends

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-18721

Display 24:00 as 00:00 in time data

Display 24:00 as 00:00 in time data

Added a system variable @DSRS to specify if display 24:00 as 00:00 on Axes tick label. By default @DSRS = 1, means display 24:00 as 00:00, can also turn it off by setting @DSRS = 0.

0

ORG-17094

Legend Symbol context menu is added

Legend Symbol context menu is added

Right click legend in graph and choose Legend → A quick way to go to Symbol tab of Legend Properties dialog to customize symbol part.

0

ORG-18489

Legend Symbol Width scale factor on Symbol tab of Text Object - Legend dialog

Legend Symbol Width scale factor on Symbol tab of Text Object - Legend dialog

Easy way to set line or line+symbol kind of legend longer or shorter.  There was Legend Symbol Width control in Plot Details dialog for this in the past but hard to find. 

0

ORG-17988

legend.align=1 by default for Legend

Align legend to left properly even after modifying the text by default

It's set to 1 by default so legend will be aligned to left properly even after modifying the text.

0

ORG-10287

New Legend for Fill Area Plot

New Legend for Fill Area Plot

Both above and below colors are supported in legend.

In the past, only above color was supported.

0

ORG-9443

Row Title for Tick Label Table

Row Title for Tick Label Table

0

ORG-17949

Size index column should automatically indicate in bubble scale

Size index column should automatically indicate in bubble scale

A new system variable is added: @BNLP .It controls the auto-nested layout percent of bubble size. The default value is 20, which means when the bubble scale is larger than 20% of the whole layer in size, its layout will be switched to Nested from Linear if you renew/add a bubble scale for a size-indexed scatter/line+symbol plot.

0

ORG-18328

Support %(CRLF) in Legend to wrap text

Support %(CRLF) in Legend to wrap text

This works on Legends/Titles tab of Plot Details dialog and Update Legend dialog.

First set Translation mode to be Custom. Then specify the syntax with %(CRLF) in between.

0

ORG-18649

Support Categorical legend for 3D xyz bar plot

Support Categorical legend for 3D xyz bar plot

Before Origin 2019, categorical legend isn't supported in 3D xyz bar.

0

ORG-19063

Support number of table rows =10

Support number of table rows up to 10

Now the maximum of table row rises from 5 to 10. And Grouped Box/Column plots also support number of table rows to 10.

Installation and Licensing

Compatibility/Upgrade

ID

JIRA

SUMMARY

DETAILS

0

ORG-18461

New mechanism to show information to user such as free upgrade to new version

New mechanism to show information to user such as free upgrade to new version

In the 1st few instances of Origin, you will see the following notification on upper-right corner of your Origin. It will fade away after 10 seconds. It's for testing our new way to notify user of future release. The link goes to wrong location. U can ignore that.

Installation

ID

JIRA

SUMMARY

Description

DETAILS

0

ORG-18207

Customize Installation and File Path

Config.ini under setup.exe folder to
prefill settings in installation (Serial number, Installation Path, etc.) so subsequent users can to do a silent installation, and preset license information and folders (User Files folder, Apps folder, etc.) so no dialog opens on first launch of Origin.

Config.ini under setup.exe folder to

  1. prefill settings in installation. This is useful for group users. Manager can set Serial number, Installation Path, install 32 bit or 64 bit, etc. in config.ini file. Subsequent users just run setup.exe to do a silent installation. Together with PK.txt under setup folder, IT can auto install and license Origin.

  2. preset license information, e.g. flexnet server name and port number.

  3. preset User Files folder, Apps folder, AutoSave, backup, etc. folders so no dialog opens on first launch of Origin. 

Start-up

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18276

Backup, Autosave, Unsaved from User Files Dialog

Backup, Autosave, Unsaved from User Files Dialog

  1. If user has already customized their paths (customization can be via registry per Tools Options, or can be via config.ini), then DO NOT show any choices. Just use the customized locations

  2. Otherwise show the following radio choices:

  • Same level as UFF

  • Under User Files Folder (UFF)

  • Under "%s" // (show actual default root path)

Miscellaneous

Origin Workspace

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-17794

The New Workbook dialog allows you to:

Now functionalities of New Workbook dialog


0

ORG-18858

“About Origin” dialog improvements

“About Origin” dialog improvements

  1. Added the "Check Available Licenses" button to get license information for Individual License.

  2. Added the "Citation Text" button to dump a string for citation to messages log.

0

ORG-13937

A Start Menu button has been added to the bottom left corner of the Origin interface.

Start Menu button added

0

ORG-18449

Add Sparklines button on Columns toolbar

Add Sparklines button on Columns toolbar

Click it will add sparklines on selected columns.

0

ORG-18471

Adds some new graph types to 2D and 3D Graphs toolbars.

Adds some new graph types to 2D and 3D Graphs toolbars


0

ORG-19093

Ctrl+G hotkey to open Export Graph with previous settings

Ctrl+G hotkey to open Export Graph with previous settings

Hotkey CTRL+G opens Graph Export dialog with <last used> theme. It used to open with system default theme. 

0

ORG-17785

Define Preview of Book and Graph Templates

Define Preview of Book and Graph Templates

When saving book or graph templates, user can specify his/her own preview image. 

This also works when saving Workbook Window as OGWU or saving Workbook as Analysis Template OGWU 

0

ORG-18678

Easy way to pick a color and get its HEX value.

Easy way to pick a color and get its HEX value.

X-Function Colors is added.

Run "colors" in Script window. Colors dialog will open for user to pick a color.

Click OK. Hex value will be dumped.

0

ORG-18569

GUI changes in miscellaneous tab of tools options dialog

GUI changes in miscellaneous tab of tools options dialog

  1. Add Proxy Setting control.

  2. Move Bisection Search Points to Graph tab.

  3. Move Footnote Size Ratio to Text Fonts tab, and rename it to Footnote Size Ratio in Analysis Reports

0

ORG-18491

Help: Origin Central is renamed as Help: Learning Center.

Help: Origin Central has been renamed as Help: Learning Center.

Under Help: menu, Origin Central... is renamed as Learning Cener...

There are only 3 tabs

  • Graph Samples

  • Analysis Samples

  • Learning Center

0

ORG-18968

Improvements on By Points tab of Color control in toolbar and dialogs with applicable color controls.

Improvements on By Points tab of Color control in toolbar and dialogs

0

ORG-14132

Menu toolbar locking

Menu toolbar locking

0

ORG-17410

Project Explorer Improvements

Project Explorer Improvements

0

ORG-18507

Reorganize and reduce Help menu entries

Reorganize and reduce Help menu entries

Reorganizing and also regrouping the Help Menu

0

ORG-18507

Reorganized Help: Open Folder to open useful folders:

Reorganized Help: Open Folder to open useful folders:

0

ORG-18565

SCN icon improvements

SCN icon improvements

0

ORG-18980

Select multiple layers by clicking+Shift on the layer icon on the graph

Select multiple layers by clicking+Shift on the layer icon on the graph

Press Shift+click on layer icon to select multiple layers on the graph.

0

ORG-18729

Shortcut window improvements

Shortcut window improvements

  1. Shortcut window keep own state (position, size) if adjust the source window

0

ORG-17794

The New Workbook dialog allows you to:

New Workbook dialog


Origin Workspace

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-13031

HTML Mode for Notes Window

HTML Mode for Notes Window

Support HTML mode for Note window:

1 . Labtalk is added to provide access to the active note page:

  • note.text$: get/set the text of active note

  • note.readonly = 0/1: switch readonly mode, default=0

  • note.syntax = 0/1: default=0, plain text, 1 means HTML syntax colored.

  • note.view = 0/1: default = 0, text editor, 1 means render with HTML browser

2 . Embed Various Origin objects into Note page's HTMLIntroduce a new mechanism for user to insert Origin Graph, Cell, Table(from report sheet) and Matrix image inside note window's HTML mode. the syntax will be like this: 

<ANY_HTML_TAG data-OLink="OriginLink">

 For example, to insert a graph preview to a note window, you should use graph type. e.g.

<div data-OLink="graph://graph1"></div>

See following table for the type of responding Origin objects:

3 . HTML Export As Web Page: Added a new menu on Note window's title bar, label as Save as Webpage..., this menu will only be enabled when the Note is currently in HTML mode.


Settings

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18031

Support Numeric Units, pi, km etc in worksheet and graph

Support Numeric Units, pi, km etc in worksheet and graph

Programming

Labtalk

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-17035

Provides LabTalk functions for Linear Fit

Provides LabTalk functions for Linear Fit

0

ORG-18254

command to create OPX file

command to create OPX file

InitFromIni method is added to OPXFile class to support using OriginC function to create app, so that user can easily creating opx without opening package manager dialog. this will be useful if user execute origin from command line or a windows BAT files.

note: this method require a source ini file which including all settings in package manager dialog.

Example:

#include <Origin.h>
#include <../OriginLab/OPXFile.h>
int test_ini_to_opx()
{
	OPXFile opx;
	int err = opx.InitFromIni("opx_IEVer.ini");
	if( err == 0 )
	{
		if( !opx.Save() )
			printf("Failed saving.\n");
	}
	else
		printf("InitFromIni error %d\n", err);
	return 0;
}

0

ORG-18795

Improve Cell() function to get actual cell display string

Improve Cell() function to get actual cell display string

Example: Enter 0.5 in the first cell of col(A), format as Time format. Now it shows "12:00". Execute "cell(1,1)$ =;" will return "12:00", while it returns "0.5" in previous versions.

0

ORG-8422

More LabTalk/SCV Functions Support

More LabTalk/SCV Functions Support

More LabTalk/SCV functions are supported (or improved) e.g.,

  • Integer-handling functions: Ceil(x), Floor(x), GCD(x1, x2,...),

  • Convert(xa,xb)

  • Engineering functions: Base(), Decimal(), BitLShift(), BitRShift()

  • Math functions: Combina(number, number_chosen), Permut(number, number_chosen), Permutationa(number, number-chosen)

  • Complex functions: Imcosh(c), Imcot(c), Imcsc(c), Imcsch(c), Imsec(c), Imsech(c), Imsinh(c), Imtan(c)

  • Financial functions: pDuration(rate, pv, fv), RRI(nper, pv, fv), Effect(nominal_rate, npery), Nominal(effect_rate, npery)

  • Statistical functions: Maxifs(max_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...), Minifs(min_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...)

  • Miscellaneous condition and switch functions:

    • IfNA(value, value_if_na), xor(logical1, [logical2],…)

    • if(con,val_true[,val_false]), if(con,val_true$[,val_false$])$

    • ifs(con1, d1[,con2, d2,]...[,con40,d40]), ifs(con1, str1$[,con2, str2$,]...[,con40, str40$])$

    • switch(expression, val1, res1[,val2,res2]...[,val39,res39][,default]), switch(expression, val1$, res1$[,val2$,res2$]...[,val39$,res39$][,default$])$

  • TextJoin(StringArray|String delimiter$, bool empty, StringArray text|String text1$,...)$

  • IsFormula(string ref$)

0

ORG-13080

New worksheet switch to select column label row in worksheet

New worksheet switch to select column label row in worksheet

Syntax:

worksheet -sl c1 r1 c2 r2

Miscellaneous

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18391

Support inserting a link to a matrix book or sheet

Support inserting a link to a matrix book or sheet

Syntax:

  • matrix://MBookName: Insert a link to a matrix book, given by MBookName, so the matrix book will be displayed in the current worksheet cell. 

  • matrix://[MBookName]MSheetName: Insert a link to a matrix sheet, given by MSheetName, so the matrix sheet will be displayed in the current worksheet cell. 

(Note: Insert a link to a matrix object syntax is matrix://[MBookName]MSheetName!MatrixObjectName, which is already supported before Origin 2019.)

Origin C

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-16176

Add GraphLayer::InsertPlot(int nIndex) method

Add GraphLayer::InsertPlot(int nIndex) method

Added an OC function to reorder the plots in Graphlayer.

int GraphLayer::ReorderPlots(const vector<uint>& vnIndices, int c1 = 0, BOOL bUndo = FALSE);

  • vnIndices: Specify the new order of the plots.

  • c1: The indice of the starting plot.

  • bUndo: Specify if support undo.

0

ORG-17751

Big Integer and the Bit Operations Support

Big Integer and the Bit Operations Support

LabTalk now supports big integers which are higher than 32bit values (up to 52 bits), and their bitwise operations:
Conversion to an integer: int(), nint(), ceil(), floor()
Bitwise operators: (&(AND) and |(OR))
Bitwise functions: BitAnd(), BitOr(), BitXor(), BitLShift(), BitRShift()
  for example:
    i=hex(F1101010101);
    j=hex(F2010101011);
    Dec2hex(bitAnd(i,j),12)$=;     //==>0F0000000001
    Dec2hex(bitOr(i,j),12)$=;       //==>0F3111111111
    Dec2hex(bitXor(i,j),12)$=;      //==>003111111110
    Dec2hex(bitLShift(i,3),12)$=; //==>788808080808
    Dec2hex(bitRShift(i,3),12)$=; //==>01E220202020

0

ORG-18085

Code Builder should be able to inspect the values declared inside the loop

Code Builder can inspect the values declared inside the loop

Support to detect the variables inside the loop and list them in the variables list when debug in Code Builder.

For example: debug the following LT script in Code Builder.

doc -e LB 
{
  double x = 1.5;
  Col(2) = Col(1) * x;
} 

It will show x variable in Variables window.

0

ORG-15885

COM interface to allow full search ability for Origin Project Files

COM interface to allow full search ability for Origin Project Files

In Find in Project dialog:

  1. The keyword to search is highlighted in the found item.

  2. Show Comments on the pop up preview dialog.

  3. Show Graph preview for the graph item.

COM Interface:

  1. Added new Origin.Application COM class OriginFinder, more information see http://wikis/ocwiki/index.php?title=Category%3AOriginFinder_(OriginCOM).

0

ORG-18271

GetN GETN_OPTION_NUM_FORMAT to support Custom Numeric Format

GetN GETN_OPTION_NUM_FORMAT to support Custom Numeric Format

Added GETN_OPTION_NUM_FORMAT function to custom Numeric format, for example:

#include <GetNbox.h>
void test()
{
    GETN_TREE( treeTest )
    GETN_STR(test1, "Str Value", "junk")
    double xx = 0.5*PI;
    GETN_NUM(testVal, "PI Test", xx)
    GETN_OPTION_NUM_FORMAT( "* \"pi\"" )
   
    if( GetNBox( treeTest ))
        out_tree( treeTest );
}

0

ORG-19105

HTML Table support internal and from OC

HTML Table support internal and from Origin C

Support getting HTML table by OC way, for example:

void	html_test()
{
	OHTML doc;
	BOOL bRet = doc.ReadFile("c:\\temp\\html\\test.html");
	if( bRet )
	{
		StringArray headers, data;
		int nTables = doc.GetTableCount();
		for(int table=0; table<nTables; table++)
		{
			string strCaption;
			bRet = doc.GetTableCaption(table, strCaption);
			int nRows = doc.GetRowCount(table);
			int nCols = doc.GetColCount(table);
			for(int col=0; col<nCols; col++)
			{
				bRet = doc.GetColHeader(table, col, headers);
				bRet = doc.GetColData(table, col, data);
			}
		}
	}
}

0

ORG-18788

http_get_str Fails to Return Response Body as String w/ Certain URL

http_get_str Fails to Return Response Body as String w/ Certain URL

Added following OC functions:

int okutil_http_download(LPCSTR lpcszURL, LPCSTR lpcszFileName, int nConnectTimeout = 0, int nResponseTimeout = 0, BOOL bIgnoreCertError = FALSE);

int okutil_http_get(LPCSTR lpcszURL, string *pstrResult, int nConnectTimeout = 0, int nResponseTimeout = 30);

int okutil_http_post(LPCSTR lpcszURL, LPCSTR lpcszRequestData, string *pstrResult, int nConnectTimeout = 0, int nResponseTimeout = 30);

DWORD okutil_http_error();

DWORD okutil_http_status();

More information see http://wikis/ocwiki/index.php?title=Category%3ANetwork_(global_function)

0

ORG-18440

Improve JSON::FromString() & JSON::ToString()

Improve JSON::FromString() & JSON::ToString()

For JSON::FromString(): support converting Javascript array to arbitrary Origin C vector types, for example:

string strvs = "[\"hello1\",\"hello2\",\"hello3\"]";

vector<string> vs;

JSON.FromString(vs, strvs);

For JSON::ToString(): support convert Origin C vector to Javascript array, lfor example:

vector<string> vs = {"Chris", "Zheng", "Aviel", "Hideo", "Yiming"};

string str;

JSON.ToString(vs, str);

0

ORG-18404

More work on @MRU

More work on @MRU

System variable MRU support enable user template (MRU=8) and recent file (MRU=16)

0

ORG-18559

Need export a function to convert the date value from/to system time

Need export a function to convert the date value from/to system time

Added two functions to convert the date value from/to system time for inner python: Date2datetime() and Datetime2Date()

For example:

import PyOrigin
dateT = PyOrigin.Date2datetime(2458310.5811)
date = PyOrigin.datetime2Date(dateT)

0

ORG-18839

New OC funtion to get list of installed fonts

New Origin C function to get list of installed fonts

Added following  OC function to get the name list of installed fonts:

int GetFontNames(vector<string>* pstrNames, BOOL bIncludeDefFont = TRUE);
Parameters:
  pstrNames[output]:font name list.
  bIncludeDefFont[input]:whether include origin default font.
Returns:
  Count of font names

0

ORG-18984

New Origin C method to scale the font size and line thickness when page size changes

New Origin C method to scale the font size and line thickness when page size changes

Improve LT command "page -AFU -newWidth/oldWidth;" to support scale the font size and line thickness when change page size by oc way.

For example:

void SetPageSize()
{
	GraphPage gp = Project.ActiveLayer().GetPage();
	Tree tr;
	tr = gp.GetFormat(FPB_ALL, FOB_ALL, true, true);
	double dOldWidth = tr.Root.Dimension.Width.dVal;
	tr.Root.Dimension.Width.dVal = 5;
	tr.Root.Dimension.Height.dVal = 5;
	if(0 == gp.UpdateThemeIDs(tr.Root))
	{
		gp.ApplyFormat(tr, true, true);
	}
	
	string strScript;
	strScript = "page -AFU -" + 5 + "/" + dOldWidth;
	LT_execute(strScript);
	strScript = "menu -e 33027;";
	LT_execute(strScript);
}

0

ORG-18123

OC and LT access to Dataset Storage

OriginC and LabTalk access to Dataset Storage

Support LT and OC ways to the size of Dataset Storage, for example: Add a Dataset Storage and then run following code to get size:

LTlist -st;

OC: GetBinaryStorage(NULL, NULL, &nSize);

0

ORG-18556

OC font file path

OriginC font file path

Added a new OC function to get font file path:

int okutil_get_font_file_names(StringArray *psaResults, LPCSTR lpcszFontName);

psaResults: Return all the font file name.

lpcszFontName: Specify the font name,

0

ORG-17066

OC functions wanted for Batch Plotting

OriginC functions wanted for Batch Plotting

Added two new OC functions for batch plotting:

int GraphPage::GetDuplicateWithData(StringArray &saItems, const DuplicateWithDataInfo& info);
int GraphPage::AddDuplicateWithData(StringArray &saItems, const DuplicateWithDataInfo& info);

0

ORG-18846

OC issues related to getting data from the internet

OriginC issues related to getting data from the internet

1. New following OC function to read text file:

BOOL ocu_read_text_file(LPCSTR lpcszFilename, string* pstr);

Parameters:
    lpcszFilename = [input] full path file name
    pstr = [output] resulting file content as a string
Returns:
    FALSE if file not found

2. Improved OC function Column::SetFormat to support setting column custom format, for example:

void setcolumnformat_ex()
{
    Worksheet wks = Project.ActiveLayer();
    Column col1(wks, 0);
    col1.SetFormat(OKCOLTYPE_DATE, "yyyy'-'MM'-'dd");
    
    Column col2(wks, 1);
    col2.SetFormat(OKCOLTYPE_TEXT_NUMERIC, "DMS2");
    
    Column col3(wks, 2);
    col3.SetFormat(OKCOLTYPE_TIME, "hh mm ss'.'##");
}

0

ORG-18707

OriginC OC JSON add Tree support

OriginC OC JSON add Tree support

Improved OC function JSON::FromString to support converting JSON string to oc tree, and added a following OC function to get tree vector:

BOOL TreeToVector(TreeNode& tree, vectorbase& vv, LPCSTR lpcszTagName = NULL)

0

ORG-18312

Tree-like datatip in Code Builder to show variable structure for debugging

Tree-like datatip in Code Builder to show variable structure for debugging

When debugging OC code in Code Builder,and move the mouse over a variable name, a simple tooltip pops up to show the value of it.

Python/R

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18480

Build OriginExt for more Python Versions

Build a new OriginExt for Python 3.6 version

Build a new OriginExt for Python 3.6 version.

0

ORG-18480

Build OriginExt for more Python Versions

Improve OriginExt packager to support calling Origin COM for python 3.6

Improve OriginExt packager to support calling Origin COM for python 3.6.

0

ORG-18480

Build OriginExt for more Python Versions

Build a new OriginExt for Python 3.6 version

Build a new OriginExt for Python 3.6 version.

0

ORG-18480

Build OriginExt for more Python Versions

Improve OriginExt packager to support calling Origin COM for python 3.6

Improve OriginExt packager to support calling Origin COM for python 3.6.

0

ORG-18219

Support latest R 3.5.0

Support latest R 3.5.0


X-Functions

ID

JIRA

SUMMARY

DESCRIPTION

DETAILS

0

ORG-18678

Color Picker XF needed

Color Picker XF needed

 Add new XF, name = colors

OC added as

bool ColorsBox(COLORREF* pcr);

LT command as

ed -c [color]

LabTalk function needed to convert ocolor to RGB,

int ocolor2rgb(int ocolor);