21.1 Pasting or Embedding Graphs in Other Applications

There are two ways you can include Origin graphs in other application's files -- as a picture or using OLE (Object Linking and Embedding):

  • When you include your Origin graph as a picture, it cannot be edited using Origin tools.
  • When you include your graph using OLE, the graph can be edited using Origin tools (you can generally edit a picture in a destination application using that application's image editing tools, but this is not the same). When you embed your Origin graph, the destination file contains a copy of the graph object. A variation of this procedure allows a graph image in the destination file to be linked to the source graph, in which case the image in the destination file is dynamically updated if the source graph is edited.

When you include your graph in a destination file as an OLE object, Origin acts as an OLE server.

Embedding vs. Linking

There are two methods of sharing Origin graphs with OLE-compliant applications: embedding your graph or creating a link to your graph. The two are distinguished primarily by the storage location of the graph's supporting data. Both allow editing of the graph using Origin's tools.

  • When you embed your graph into another application's files, the data are stored in the destination file -- not in the Origin file. Subsequent editing of the graph can be initiated by double-clicking on the graph in the destination file. Chief advantage: This creates a single, self-contained file.
  • When you create a link to your graph in a destination file, the data are stored in an Origin file -- not in the destination file. The destination file saves a link to the Origin file, and displays an image of the linked graph. Editing of the graph is performed by directly opening the source graph in Origin. When the destination file is reopened or refreshed, the displayed image is updated. Chief advantage: You can display a graph in multiple destination files and only have to concern yourself with keeping a single graph up to date. Also, destination file size is reduced because data are not stored with the destination file.

Embedding your graph in another application

Origin provides three methods to embed your graph in an OLE-compliant file.


To embed your graph by pasting into another file using the Clipboard:

The graph does not have to be saved to a graph window (*.OGG(U)) or a project (*.OPJ(U)) file (the contents of the current Origin session do not have to be saved).

  1. In Origin, select Edit:Copy Page.
  2. In the destination application (such as Microsoft® Word), select Edit:Paste Special. In Word, this menu command opens the Paste Special dialog box.
  3. Select Origin Graph Object from the As list box.
  4. Select the Paste radio button.
  5. Click OK.

Your graph displays as an object in the destination file.

Note: Exactly the same result is produced by either of the following:
  • CTRL + C (Origin) => CTRL + V (MS Word).
  • Edit:Copy Page (Origin) => Edit:Paste (MS Word).

See the Copy/Export Page Settings Group documentation for important information on copying and pasting a graph to another application.

OLE embedding is not supported by Origin's Master Page feature. When exporting graphs containing master items to MS Office or other documents, you should insert the graph as an image. For more information, see Adding common elements to an MS Word or PowerPoint file.

Origin 2018 introduced new Unicode-compliant file types, including those for the Origin Project (OPJU) and the Origin Graph (OGGU). If you use Origin 2018 or later to embed an Origin graph in a Word document, then hand that document to a colleague who uses Origin 2017 or earlier, he or she will not be able to edit the Origin graph. See this FAQ for details.


To embed your graph window file (*.OGG(U) into another file:

The graph must already be saved to a graph (*.OGG(U)) window file.

  1. In the destination application (such as Word), select Insert:Object. In Word, this menu command opens the Object dialog box.
  2. Select the Create from File tab.
  3. Click Browse. This action opens the Browse dialog box.
  4. Select your *.OGG(U) file.
  5. Click OK.
  6. In the Object dialog box, make sure the Link to File check box is cleared.
  7. Click OK.

Your graph displays as an object in the destination file.


To create (and embed) a new Origin graph in another application:

  1. In the destination application (such as Word), select Insert:Object. In Word, this menu command opens the Object dialog box.
  2. Select the Create New tab.
  3. Select Origin Graph from the Object Type list box.
  4. Click OK. This action creates a new instance of Origin displaying a graph in a Documentn window.
  5. Make this new instance of Origin the active application.
  6. Create your graph (in the new program instance).
  7. With your graph window active, select File:Update Documentn.
  8. Select File:Exit and Return to Documentn. This menu command closes the new instance of Origin and returns activity to the destination application (in this example, Word).

Editing an embedded graph

When an Origin object is embedded in a OLE-compliant file, it is editable using Origin's tools.

  • To edit the embedded object in Origin:
  1. Double-click the inserted graph.
  2. This opens an instance of Origin; the graph window displays in the workspace and is ready for editing.
  3. Make changes to the graph.
  • To update the embedded object:
  1. Select File:Update DestinationApplication.
  • To close the instance of Origin and return to the destination application:
  1. Select File:Exit and Return to DestinationApplication.
  • To edit the embedded graph using in-place activation:

As an alternative, Origin objects inserted into a destination file can be edited without leaving the destination application. This editing method works by in-place activation of a subset of Origin's graph editing tools.

To enable in-place activation:

  1. From the Origin menu, select Preferences: Options, and choose the Graph tab.
  2. Select the Enable OLE In-place Activation check box.
  3. Click OK to close the dialog box (You are prompted to Save as Origin's startup options?).
  4. You may close Origin.
  • To edit the graph using in-place activation:
  1. Double-click on the embedded (not linked) Origin graph in the destination application. The Origin graph is now editable by right-clicking on the selected object and choosing from various Origin shortcut menu commands.
Note: In general, in-place activation is not the recommended method for editing embedded Origin graphs; you do not have access to many useful Origin features - for instance, the workbook windows that contain the data plotted in the graph.

Creating a link to your graph

Two methods exist for creating a link to your graph in an OLE-compliant file:

  • To create a link to a graph that is part of a saved Origin project (*.OPJ(U)) file.

To create a link to a graph in a saved Origin project file:

  1. Open the project that includes your graph window.
  2. With the graph window active, select Edit:Copy Page.
  3. In the destination application (such as Word), select Edit:Paste Special. In Word, this menu command opens the Paste Special dialog box.
  4. Select Origin Graph Object (or Picture) from the As list box.
  5. Select the Paste Link radio button.
  6. Click OK.

Your graph displays as an object in the destination file.

  • To create a link to a graph that is saved as a graph window (*.OGG(U)) file.

To create a link to a graph in a saved Origin graph window file:

  1. In the destination application (such as Word), select Insert:Object. In Word, this menu command opens the Object dialog box.
  2. Select the Create from File tab.
  3. Click Browse. This action opens the Browse dialog box.
  4. Select the desired *.OGG(U) file.
  5. Click OK.
  6. In the Object dialog box, select the Link to File check box.
  7. Click OK.

Your graph displays as an object in the destination file.

Editing a linked graph

  • To edit a linked graph:
  1. Opening the Origin project or graph window file that contains the source for the linked object.
  2. Edit the graph using Origin's tools.

Alternatively, you can:

  1. Double-click on the linked object in the destination file. This action opens an instance of Origin displaying the linked #graph in a graph window.

Make changes to the graph in this instance of Origin.

  • After making changes to the graph in Origin:
  1. Select Edit:Update Client from the Origin menu bar.

or

  1. Redirect window activity to the destination application.
  2. Update the link within the destination application. For instructions on updating the link, consult the destination application's documentation.