9.1.3 The (Plot Details) Layers Tab


Controls on the Layers tab apply to all layers on the Graph Page:

  • Common Display: Controls for enabling simultaneous editing of layer, plot and axis properties.
  • Drawing Order: Drawing behavior for overlapping layers with background color.
  • Set Active Layer by Layer Icon Only: Limit setting of active layer to clicking on icon.

To access Plot Details Layer tab controls:

  1. Activate the graph window and double-click on an empty portion of the graph, then click the graph (page) icon in the left panel of Plot Details; or from the menu, click Format: Page.
  2. Click on the Layers tab.
PD Layers tab.png


PD Layers tab ScatterMatrix.png

Common Display

The Common Display controls are used to apply customizations made to one graph layer to other graph layers in the same multi-layer graph page. In a simple example, you have a multi-layer graph and you want to make each layer's plots the same color. You could do this by selecting each plot individually, then applying the same color to each using the Fill and Line/Border Color buttons on the Style toolbar. Or, you could check the Plot Properties box on the Layers tab and change all layer's plots at once.

The Plot Details "Common Display" Group:

PD Common Display Group Controls.png
  • To use the Common Display controls, check the desired boxes before you begin making customizing plots.
  • You can continue to customize selected graph properties after closing Plot Details, by using available Mini Toolbars or with Format and Style toolbar buttons.
  • Note that there is graph page-level Mini Toolbar access to Common Display elements. Hover near the top of the graph page (but outside the layer) and click to show the toolbar; then click the Common Display button. This produces a popup menu for enabling or disabling common editing for the various elements.
MT Common Display menu.png

Common Display, Control by Control

Layer Properties PD Layer Properties.png

Apply all layer-level properties on all tabs in the Plot Details dialog box to all plots, subject to conditions of the Apply to controls, except:

  • Controls on the Link Axes Scales tab.
  • The Layer Area group on the Size/Speed tab.
Plot Properties PD Plot Properties.png

Apply plot-level properties on all tabs in the Plot Details dialog box to plots of the same plot type, as specified in the accompanying drop-down list (All, Index, Name -- see next paragraph) and subject to conditions of the Apply to controls. Note that same plot type is key (e.g. you have a panel graph of line plots and you change one plot to a column plot. This will NOT change the other line plots to column plots. Note also that the available plot-level tabs to the right side in Plot Details may change depending on plot type).

By default, edits to properties will apply to All plots but you can limit changes to plots of the same plot Index (plotting order in the layer), or to plots with the same Name. When the Plot Properties group is defined by Name, click the flyout menu to the right of the text box and pick the bit(s) of book, sheet or column metadata that defines the group. Subsequent changes to plot properties will apply only to that group. For information on metadata syntax, refer to this List of @Options.

PD Plot Properties Name.png

In addition, when the Plot Properties drop-down is set to Name, Plot Details Group tab Edit Mode is set to Independent.

Axis Style Axis Style Properties.png

Apply all properties on all tabs in the Axis dialog except those on the Scale and Breaks tabs for the same axis (Bottom/Top/Left/Right), subject to conditions of the Apply to controls.

Axis Scale Axis Scale Properties.png

Apply all properties on the Axis dialog Scale and Breaks tabs for the same dimension (Horizontal/Vertical), subject to conditions of the Apply to controls.

Show/Hide Plots with Same Use the check box in conjunction with the drop-down to set conditions for showing or hiding plots of the same Name or Index, subject to conditions of the Apply to controls.

Since Origin 2020b, once you select Name for this middle drop-down box, you are allowed to enter the pattern of the name you want to match in the subsequent combination box; and, click the right-arrow button Button Arrow in Legend Tab.png next to the combination box to expand a fly-out menu with several frequently used pattern notations(@Options) to specify the matching name. Refer to the Text Label Options table for supported notations(Please note, if multiple patterns has been entered at one time, all patterns should be matched.). If no pattern entered, only the existing legend entries of plot will be used to match the plots.

Note that merely checking the box does not show or hide anything. Once you have set conditions, you can show or hide plots in these ways:

  • Checking or unchecking a box beside one plot in the left panel of Plot Details.
  • Checking or unchecking a box beside one plot in the Object Manager.

PD OM showHide.png

Panel Layout Applicable primarily to Double-Y Trellis Plots. Checking this box means that the following properties will be shared between layers, subject to conditions of the Apply to controls:

PD Layers CD Panel Layout.png


For more information on Trellis Plots, see Trellis Plots and the Plot Details Panel tab.

Apply to Defines the layers to which the Layer, Plot, Axis, Panel Layout and Show/Hide properties should apply, with the default being all layers in the window (page):
  • Layers: Select this button, to Include or Exclude a space-separated list of layers (identified by layer name or index) for Common Display. Layer name can be seen in Plot Details or Object Manager. Layer index is shown on the layer icon in the upper-left corner of the graph window (e.g. PD CD layerIcons.png).

PD CommonDisplay Apply To.png

  • Linked Layers: Modifications to a linked layer will only affect other linked layers (e.g. If Layer2 is linked to Layer1, and Layer4 is linked to Layer3, any modification to Layer1 will affect Layer2, but will not affect Layer3 and Layer4. Likewise, modifications to Layer2 will affect Layer1, but will not affect Layer3 and Layer4.

Apply to PD linkedLayers.png

Independent Layer/Binning Control

For the Scatter Matrix graph, check Independent Layer Control check box to release the common display control on Layer Properties at Layer level for all layers.

For the Scatter Matrix graph, check Independent Binnig Control check box to release the common display control on Binning in the Data tab for all Histogram/Box Chart in the diagonal layers. You can uncheck Automatic Binning to set different binning elements.


Drawing Order

Draw All Layers As a Single Composite forces display of data in both layers even if one or both layers have a background color.

Draw Layer by Layer will draw layer 2 after completely drawing layer 1, including the layer 1 background. If you specify a background color for layer 2 by selecting layer 2 from the tree structure in Plot Details, and choosing a color on the Background tab, then the background in the second layer will mask elements of the first layer. If you leave the background as None then the data in layer 1 will be visible through layer 2.

Set Active Layer by Layer Icon Only

Select this check box to ensure that a layer can be made active only by clicking on the layer icon in the upper left corner of the graph page.

Column/Bar/Box Gap Across Layers

Check this check box to enable control of the gap and offset between columns/bars/boxes at same X position but across layers.

This check box is available when the following conditions are met:

  1. Page has linked layers.
  2. X-axis has a Straight link to a parent layer(on the Link Axes Scales tab of the Plot Details dialog at the layer level).
  3. All linked layers' dimensions use % of Linked Layer and have Left set to 0 and Width set to 100 (on the Size tab of the Plot Details dialog at the layer level).

When this check box is selected, you can customize the columns'/bars'/boxes' gap or offset across layers on the Spacing tab of the Plot Details dialog of the first data plot in the parent layer linking to; the corresponding controls of the other plots will grey out.

Column/Bar/Histogram Side by Side inside Layer

When you plotted multiple column/bar/histogram plots in one layer, check this box to place the columns/bars/histograms at same X value side by side. Uncheck this box will plot them overlapped.