6.2 Importing Third Party Files


Methods of Third-party File Import

Origin can import data from a wide variety of third-party file formats. Many import routines are installed with the product. Others are available as free downloads.

There are three places in Origin where you can import third-party formats:

Main Menu: Data > Import from File

Common third part formats are available from this menu. There is also an Add/Remove File Types... sub menu which opens a dialog listing all pre-shipped file formats. You can use this dialog to customize the menu entries to only show formats that are relevant to you.

Main Menu: Data > Connect to File

Several Connectors for third-party files are available under this menu. There is also an Add New... sub menu which opens the App Center dialog and searches for Data Connectors that you can then download for free. Note that all installed Data Connector Apps are also accessible from the Connectors tab of the Apps Galley, normally docked to the right-side of the Origin workspace.

Apps Gallery

There are several Apps available for importing third-party file formats. These can be downloaded and added to your installation. To do this, go to the Apps Gallery which is docked on the right side of the interface (or use the View: Apps menu item). Then click the Add Apps button. In the App Center dialog, click on the Search tab on the left, and then enter the word import into the edit box and perform the search. You can then select which import Apps you want to download and install. The installed Apps will appear in the Apps bar for quick access.

Supported File Types

The following table lists various third-party formats supported by Origin:

Name File Type (Extension) Latest Supported Version How to Install How to Use
Binary 2D Array IMG,B2B Add to Menu... Data > Import from File
BRUKER BRUKER OPUS OPUS7.5 Add to Menu... Data > Import from File
Bruker BES3T DTA Download... Apps Gallery
C3D C3D Download... Apps Gallery
Chem Data SDF,SDF.GZ,MOL,CDX Download... Apps Gallery
Comma Delimited CSV Microsoft Office Excel 2019 Pre-installed Data > Import from File
Data > Connect from File or Apps Gallery
Common Data Format CDF File version: 3.3.1 Pre-installed Data > Import from File
Data Translation DCF, HPF DCF:1.0
HPF 1.2: Internal OriginC code support, no version specified.
Add to Menu... Data > Import from File
DICOM DICOM images Download... Apps Gallery
EarthProbe EPA Only support EPA file import Add to Menu... Data > Import from File
EDF EDF,BDF,REC,HYP Add to Menu... Data > Import from File
ETAS INCA MDF DAT, MDF INCA5.4(File version:3.0) Pre-installed Data > Import from File
European Data Format EDF,EDF+,BDF,REC,HYP Internal OriginC code support, no version specified. Pre-installed Data > Import from File
Excel XLS, XLSX, XLSM Microsoft Office Excel 2019 Pre-installed Data > Import from File
Data > Connect from File or Apps Gallery

See Also: Importing from Excel Chapter

Famos DAT, RAW Famos 7.2 R6 (File version: 2) Pre-installed Data > Import from File
FITS FIT,FITS Download... Apps Gallery
Gamry Voltammetry XLSX,DTA Download... Apps Gallery
Google Map Google Map images Download... Apps Gallery
Heka DAT PATCHMASTER 2x90.3 (File version:9) Add to Menu... Data > Import from File
Hierarchical Data Format H5,HE5,HDF5 HDF5 (File version:1.8.14) Pre-installed Data > Import from File
HDF or MATLAB file H5,HE5,HDF5,MAT HDF5 (File version:1.8.14)
MAT(File version: 7.3)
Download... Data > Connect from File or Apps Gallery

Another relevant App:
HDF5 Browser

HTML HTM,HTML Pre-installed Data > Connect from File or Apps Gallery
IgorPro PXP, IBW Igor Pro 8 Pre-installed Data > Import from File
JCAMP-DX DX, DX1, JDX, JCM File version: 6 Add to Menu... Data > Import from File
JSON JSON Pre-installed Data > Connect from File or Apps Gallery
KaleidaGraph QDA Internal OriginC code support, no version specified. Add to Menu... Data > Import from File
LeCroy trc Download... Data > Connect from File or Apps Gallery
LSM LSM Download... Apps Gallery
MATLAB Mat Matlab 2019b (File version: v7.3) Pre-installed Data > Import from File
Data > Connect from File or Apps Gallery
Minitab MTW, MPJ Minitab 13 Add to Menu... Data > Import from File
MZXML mzData, mzXML, mzML, imzML mzXML3.0
mzML:1.1.0
mzData:1.05
imzML:1.1.0
Add to Menu... Data > Import from File
NanoScope NanoScope Download... Apps Gallery
NetCDF NC Version: 4.7.0 (no DAP support) Pre-installed Data > Import from File
NI DIAdem DAT DIAdem 2019 Pre-installed Data > Import from File
NI TDM TDM DIAdem 2019 Pre-installed Data > Import from File
NMR fid,1r, 1i, 2rr, 2ii, 2ri, 2ir, 3rr, etc. Download... Apps Gallery
pCLAMP (ABF, DAT, AB?) pClamp 10.6 (ABF 2.06) Pre-installed Data > Import from File
PLEXON PL2 Download... Data > Connect from File or Apps Gallery
PLEXON's PLX PLX Download... Apps Gallery
PNRF PNRF Download... Apps Gallery
Princeton Instruments SPE SPE 3.0 Pre-installed Data > Import from File
Prism PZFX, XML GraphPad Prism 8 Pre-installed Data > Import from File
SAS SAS7BDAT, SD2 SAS 9.4 Add to Menu... Data > Import from File
Shapefile SHP Download... Apps Gallery
SigmaPlot JNB SigmaPlot 12.5 Pre-installed Data > Import from File
SPSS SAV SPSS 26 Pre-installed Data > Import from File
Somat SIE SIE InField 2.5 (File version:1.0) Add to Menu... Data > Import from File
Sound WAV 8/16/24/32 bit (PCM format) Pre-installed Data > Import from File
Tektronix ISF ISF Add to Menu... Data > Import from File
Tektronix WFM wfm Download... Apps Gallery
Thermo SPC, CGM File version: new Galactic SPC file Pre-installed Data > Import from File
Touchstone s1p,s2p,s3p,s4p,s5p,s6p,s7p,s8p,s9p,ts Touchstone version 2.0 Download... Data > Connect from File or Apps Gallery
Universal File UNV,UFF,UF Download... Data > Connect from File or Apps Gallery
VAMAS VMS Download... Apps Gallery
Word docx Microsoft Office Word 2019 Download... Data > Connect from File or Apps Gallery
XML XML Download... Data > Connect from File or Apps Gallery
XPORT XPT Download... Data > Connect from File or Apps Gallery

For more specific information on importing supported third party files by X-Functions(Tools under the Data > Import from File menu), see the X-Function Help file (click Help, and then click X-Functions, or press F1 while the dialog box is open).

For direct access to the documentation from the Command Window, type the following at the command prompt:

help X-FunctionName

If you have a third party file that isn't currently supported, you may be able to develop your own import routine using the Origin Import Wizard (requires some Origin C coding ability). For more information, see "Importing chapter" in Origin C Guide.

File Metadata

When you import a file, the file's date, name, and path are saved to the target workbook. Some third-party files contain additional metadata that is saved upon file import. For example, Origin will save time format information from an NI DIAdem .DAT file.

You can view the metadata associated with an imported file in the following ways:

  • View the information in the Workbook Organizer. To open the Organizer, right-click the workbook title bar and click Show Organizer in the menu.
  • View the information in the Insert Info Variables dialog box. Metadata associated with a given workbook may be inserted into a text object in that book, or into plots of workbook data, with a shortcut key combination. For more information see "Inserting Variables Extracted from Imported ASCII Files into Text Labels".
  • For basic information, enter the following script command in the Command Window:
page.info = <ENTER>
  • For more complete information, enter the following script command in the Command Window:
impinfo <ENTER>
  • View information in the Column Properties dialog box, User Tree tab. To open the Properties dialog box, double-click the column heading, then click the User Tree tab. Origin stores file information here but the tree can be edited by the user.

With some files (e.g., .WAV and Thermo .SPC/.CGM), parameters read from the file headers are added to the target worksheet for graphing or analysis purposes. For instance, the sampling interval of a .WAV file is written to the header row of the target worksheet. When you plot the imported data, the sampling interval is used to set the X axis increment.

Import Mode

For most supported third party files, you can set the import range using controls in the import dialog boxes. Import Mode options are:

  • Replace Existing Data: The data that exists in the target window will be cleared on data import.
  • Start New Rows: Append new rows, as needed.
  • Start New Columns: Append new columns, as needed.
  • Start New Sheets: Create a new sheet for each imported file.
  • Start New Books: Create a new book for each imported file.

Notes:

  • Some X-Function based third party import routines do not support these Import Modes.
  • For Princeton Instruments SPE data files, the target window type as chosen by Origin will depend upon the dimensions of the data. If the data files are one-dimensional, they will be imported into a workbook. Otherwise a matrix book will be used as a target window (even if a workbook is the active window).