6.11 Customizing Data: Import from File and File: Export Menu


As mentioned in the previous sections, you can select a file format from the Import from File' menu to run the X-Function that imports files of the specified format. Similarly, the Export menu can be used to export the active matrix, worksheet, or graph to a chosen format.

These two menus are constructed dynamically when Origin starts up, by scanning the X-Functions in following two folders:

1. The \Import and Export subfolder of the \X-Functions folder in the Origin program folder.

2. The \Import and Export subfolder of the \X-Functions folder in the user files folder.

The X-Functions in these two folders are listed in either of the menus, depending on their filenames:

1. Those that begin with "imp" are put in the Data : Import from File menu.

2. Those that start with "exp" are listed in the File : Export menu.

Note: Usage Context of an X-Function can affect whether the X-Function is shown in the menus. For more details on the Usage Context of X-Functions, please refer to the Creating X-Functions topic in the X-Function manual. (Only available in the digital Help document)

Because of the way in which menus are constructed, we can customize them by manipulating the X-Functions in the \Import and Export folder. To remove a menu or to hide the file formats that you will never use, simply move the unwanted X-Functions to any folder other than these two. On the other hand, if you have written some new importing or exporting X-Functions, you can rename them to imp*.oxf or exp*.oxf and then save them to the \Import and Export folder.

The scanning of the X-Functions is performed every time Origin starts up. Therefore, if the X-Functions in the \Import and Export folder are changed, you will see the updates on the Data : Import from File and File : Export menus next time you start Origin.

Import Menu Customization dialog

Origin allows you to specify what file types and import themes to show in Data : Import from File menu using the Import Menu Customization dialog, opened from menu Data: Import from File: Add/Remove File Types....

Customizing the File Import 01.png

Using this dialog, you can

  • Select File Type or User Theme from the drop-down list on the top-left corner to list all supported file types or saved dialog themes in the left panel. If you have saved any Import Wizard oif filter or any dialog theme for impASC tool, you can select User Theme from this drop-down list, select and add it to Import from File menu for quick reuse.
  • With the Left/Right arrow button, add/remove the File Type or Theme to/from the right panel to customize the Import from File Menu.
  • Reset the Import from File menu by clicking the Reset button and move the selected item in the right panel up/down by using the Up/Down arrow button.
  • Uncheck/Check the Show "Add/Remove File Types..." menu check box to specify whether to show the menu item Add/Remove File Types... in the Import from File Menu.
Note: Once the Show "Add/Remove File Types..." menu check box is unchecked, you only can open the Import Menu Customization dialog in the Import Filter Manager.