OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis                     
 
Skip Navigation Links
All BooksExpand All Books
Origin HelpExpand Origin Help
Origin BasicsExpand Origin Basics

2.4 Hotkeys/Accelerator Keys/Keyboard Shortcuts in Origin


In Origin, you can use a combination of keystrokes to quickly perform an action. The key combination consists of modifier key(s) (such as CTRL, ALT, or SHIFT) and an accompanying key (such as a character key, an arrow key, or a function key).

For Mac keyboard users, please note that some of the shortcut keys are not the same as those from Windows PC keyboard. You may refer to these comparison tables for such hot keys.

List of Hotkeys/Accelerator Keys/Keyboard Shortcuts in Origin

Project

Hot Key Menu/Action Context
Ctrl + E File : Open Excel Open the Open dialog.
Ctrl + N File : New... Open the New dialog.
Ctrl + O File : Open... Open the Open dialog.
Ctrl + P File : Print Open the Print dialog.
Ctrl + S File : Save Project Save current project. (If project has never been saved, then open Save As.. dialog)
Ctrl + F4 Close the active worksheet/graph/matrix window
Ctrl + F6 Go to Next window Activate the next window.
Alt + 1 View : Project Explorer Open the Project Explorer.
Alt + 2 View : Results Log Open the Results Log.
Alt + 3 View : Command Window
Window : Command Window
Open the Command Window.
Alt + 4 View : Code Builder Open the Code Builder.
Alt + 5 View : Quick Help Open the Quick Help.
Alt + 6 View : Messages Log Open the Messages Log.
Alt + 7 View : Smart Hint Log Open the Smart Hint Log.
Alt + 8 View : Object Manager Open the Object Manager.
Alt + 9 View : Apps Open the Apps.
Alt + Shift +3 Window : Script Window Open the Script Window.
Ctrl + Alt + Z Window : Return to Last Window Go back to the previous activated window.
F2 Project Explorer: right click on folder or window and choose Rename Rename selected item in Project Explorer. If window is selected, change window Short Name (SN)/Long Name (LN), depending on which name you set when last time you used the in-place edit mode to rename window. You can also use Ctrl+N to switch between LN and SN. See more here
Ctrl + N Switch between LN (Long Name) and SN (Short Name) toggle mode when in-place editing workbook name in Project Explorer.
F3 PE: Right-click on Folder(Find) Open the Find dialog for the selected folder when active Project Explorer.
Ctrl+Tab Navigate between different windows in the same folder.
Alt + Shift + R Right click the title bar of external Excel workbook and choose Update Origin. Update Origin from external Excel in Origin.

Tool

Hot Key Menu/Action Context
Ctrl + K File : Import : Single ASCII... Open the ASCII dialog. (Worksheet, Matrixsheet, Graph)
Ctrl + 3 File : Import Wizard Open the Import Wizard. (Worksheet, Matrix, Graph)
Ctrl + 4 File : Re-import Directly A data file has been imported to the active worksheet.
Ctrl + T View : Toolbars Open the Customize dialog.
Ctrl + U Tools : Options Open the Options dialog.
F7 Tool->Theme Organizer Open the Theme Organizer.
F8 Tool->Fitting Function Builder Open the Fitting Function Builder.
F9 Tool->Fitting Function Organizer Open the Fitting Function Organizer.
F10 Tool->X-Function Builder Open the X-Function Builder.
F11 Help: Origin Central Open the Origin Central.

Editing

Hot Key Menu/Action Context
Ctrl + F Edit : Find Open the Find tab of the Find and Replace dialog. (Workbook, Graph)

Open the simple Find dialog. (Notes)

Ctrl + G Edit : Go to Open the dlgRowColGoto dialog box. (Workbook)
Ctrl + H Edit : Replace Open the Replace tab of the Find and Replace dialog. (Workbook, Matrix)

Open the simple Replace dialog. (Notes)

Ctrl + V Edit : Paste (Also in many context menus) Paste from the Clipboard.
Ctrl + X Edit : Cut Cut the selected object(s). (May also add to Clipboard.)
Ctrl + Z Edit : Undo Undo the last action.
Ctrl + Alt + B Edit : Button Edit Mode Switch to the Button Edit Mode.
Ctrl + Alt + V Edit : Paste Link or Right-Click a cell (paste link) When an object has been copied.
Del Edit : Clear When an object has been selected.
Alt + Double-click Right-click on the object and select Properties When an object has been selected.
Alt + X When entering special characters into text labels and worksheet cells, enter the Unicode four-digit hex value and immediately press ALT + X. While editing text "in-place."
Copy
Ctrl + C Edit : Copy : Copy (Also in many context menus) When an object is selected.
Ctrl + Alt + C Edit : Copy : Copy (Full Precision)
(When Matrix/ Worksheet active)
Select cells in the matrix/ worksheet window.
Ctrl + Shift + C Edit: Copy : Copy (including label rows) When one or multiple columns are highlighted, copy the column(s) with label rows.
Ctrl + J Edit : Copy : Copy (formula) When one or multiple columns are highlighted, copy the column(s) with formula.
Ctrl + Shift + J Edit : Copy (label rows) When one or multiple columns are highlighted, just copy label rows of the column(s).
Ctrl + Alt + J Edit : Copy : Copy (formula + label rows) When one or multiple columns are highlighted, copy the column(s) with label rows and formula.
Ctrl + Shift + A Edit : Copy : Copy All When one or multiple columns are highlighted, copy the column(s) with data, label rows and formula.

Worksheet

Hot Key Menu/Action Context
Ctrl + D Column : Add New Columns... Open the Add New Columns dialog box. (Workbook, Matrix)
Ctrl + H Insert Info Variable With the text object selected in in-place editing mode, open the Insert Variable dialog.
Ctrl + M While editing cell contents, opens the Character Map.
Ctrl + Q Column : Set Column Values... Open the Set Values dialog. (Worksheet, Matrix)
Ctrl + Y Analysis : Fitting : Nonlinear Curve Fit Open the NLFit dialog. (Worksheet, Graph)
Ctrl + Shift + Q Column : Set Multiple Columns Values... Open the Set Values - Multiple Columns dialog. (Worksheet)
Ctrl + Shift + U Right-click on gray space of the worksheet, View: F(x) Hide/show formula row in the worksheet.
F4 Format->Worksheet Open the Worksheet Properties dialog.
Ctrl + Home / End Go to the cell of the first/last row and first/last column in the worksheet.
Ctrl + PageUp / PageDown Navigate between different worksheets within the current workbook.
Ctrl + UP / DOWN Arrow Go to the first/last row of active column.
Ctrl + LEFT / RIGHT Arrow Go to the first/last column of active row.

Matrix

Hot Key Menu/Action Context
Ctrl + Q Column : Set Column Values... Open the Set Values dialog. (Worksheet, Matrix)
Ctrl + Shift + C View->Show Column/Row When a matrix is active
Ctrl + Shift + D View->Data Mode When a matrix is active in image mode.
Ctrl + Shift + I View->Image Mode When a matrix is active in data mode.
Ctrl + Shift + N Show Image Thumbnails When Matrix is active
Ctrl + Shift + T Tools->Region of Interest Tools When a matrix or image is active
Ctrl + Shift + X View->Show X/Y, when a matrix is active Show the real X/Y value in current matrix.

Graph

Hot Key Menu/Action Context
Ctrl + A Select all layers in current graphs.

If the window is Layout, then select all objects(label, graph, worksheet...).

Ctrl + Enter Exist in-place editing mode With the text object selected in in-place editing mode.
Ctrl + G File:Export Graphs:Open Dialog Open Import and Export:expGraph (graph export) dialog for current graph window.
Ctrl + H Insert Info Variable With the text object selected in in-place editing mode, open the Insert Variable dialog.
Ctrl + J Edit : Copy Page With Graph or Layout window active.
Ctrl + L Graph : Reconstruct Legend Reconstruct a Graph Legend. (Graph).
Ctrl + R Graph : Rescale to Show all Adjust scales to show all data in graph. (Graph)
Ctrl + M Open the Symbol Map dialog With a text object selected in in-place editing mode.
Ctrl + Y Analysis : Fitting : Nonlinear Curve Fit Open the NLFit dialog. (Worksheet, Graph)
Ctrl + 1 View : Page View When a Graph window or Layout window is active.
Ctrl + 2 View : Print View When a Graph window or Layout window is active.
Ctrl + 4 Sets cursor to Data Selection mode When a Graph window is active.
` (backquote, aka acute key) Scale Out When a Graph window is active. If Scale In tool has been used, Scale Out once for each Scale In step.
1 Sets cursor to Scale In mode When a Graph window is active.
2 Sets cursor to Screen Reader mode When a Graph window or layout window is active. Click on page to read coordinates.
3 Sets cursor to Data Reader mode When a Graph window is active. Click on data point to read data coordinates.
4 Sets cursor to Data Selection mode When a Graph window is active. Click on dataplot to draw markers. Position then double-click or press Enter to set.
5 Sets cursor to Draw Data mode When a Graph window is active. Double-click on graph to set a data point. Repeat as needed. Press Esc when done.
6 Sets cursor to Add Text Tool When a Graph window is active. Click on graph to establish text location and type. Click outside text object when done.
7 Sets cursor to Arrow Tool When a Graph window is active. Click and drag in graph to draw an Arrow object.
8 Sets cursor to Curved Arrow Tool When a Graph window is active on current graph window.
9 Line Tool(with graph active) When a Graph window is active. Start to add line on current graph window.
F2 Format->Page Properties Open the Page Properties page of Plot Details dialog for current graph window.
Enter the in-place editing mode. With the text object selected.
F5 Graph : Refresh the graph Refresh the graph window after redrawn(Graph)
F12 Graph->Layer Contents Open the Layer Contents dialog for current graph window.
Ctrl + Shift + J View->Full Screen When a graph is active.
Up/Down switch plot When the data reader is being used on graph window.

Zoom, Pan and Scale

With respect to the graph page, these actions can be separated into (1) those that change axis scales and (2) those that do NOT change axis scales. For actions that change axis scales (e.g. Scale In/Out), reset the view of the graph by pressing CTRL + R; for actions that do NOT change axis scale (e.g. Zoom In/Out), reset by pressing CTRL + W. CTRL + W works for 3D openGL graphs, layout pages and matrix images, too.

For the following table, assume that the Pointer tool Button Pointer.png is selected unless otherwise indicated.

Hot Key Menu/Action Context
Panning on the Graph, Layout, Matrix in Image View
A + arrow keys
Button Panning.png + arrow keys
Panning the graph page When you press "A" and hover on an active window, the Pointer tool Button Pointer.png changes to Panning Mode 01.png to indicate pan mode.
Zoom In/ Out the Graph, Layout, Matrix in Image View
Ctrl + I View : Zoom In Puts cursor in Zoom In mode which activates upon Click.
Ctrl + M View : Zoom Out Zoom out of the page.
A + "+" / "-" keys
A + Wheel
Zoom In and Out When you press "A" and hover on an active window, the Pointer tool Button Pointer.png changes to Panning Mode 01.png to indicate pan mode.
Ctrl + Wheel Keep pressing the Ctrl key and roll up/down the mouse wheel to zoom in/out active page.
Button Panning.png + Wheel Click on the Zoom-Panning Tool button Button Panning.png and roll up/down the mouse wheel to zoom in/out on active page.
Button Panning.png + "+"/"-" key Click on the Zoom-Panning Tool button Button Panning.png and press "+"/"-" to zoom in/out on active page.
Ctrl + W View : Whole Page Restore page to 100% view. (91% for Layout page).
Button Panning.png + Z + "Home" Restore page to 100% view. (91% for Layout page).
Hint: "Home" is to the right of Insert/Delete keys.
Panning on the Graph Layer
X + Wheel / Mouse-drag
X + Right/ Left Arrow key
X + "+" / "-" key
Panning in X direction only With graph active and with Pointer tool selected on Tools toolbar
X + Shift + Wheel / Mouse-drag
X + Shift + Up/ Down Arrow key
X + Shift + "+" / "-" key
Panning in Y direction only With graph active and with Pointer tool selected on Tools toolbar
Button Rescale Tool.png + Mouse-drag Panning in both directions With graph active and Rescale Tool selected on Tools toolbar
Scale In or Out on the Graph Layer
Z + Wheel
Z + "+"/ "-" key
Scale in or out in X direction only With graph active and with Pointer tool selected on Tools toolbar
Button Rescale Tool.png + Wheel With graph active and Rescale Tool selected on Tools toolbar
Z + Shift + Wheel
Z + Shift + "+"/ "-" key
Scale in or out in Y direction only With graph active and with Pointer tool selected on Tools toolbar
Button Rescale Tool.png + Shift + Wheel With graph active and Rescale Tool selected on Tools toolbar

Graph Animation

Hot Key Menu/Action Context
Q Add a frame When use the Video Builder tool to create the video.

Resize, Rotate and Skew the 3D Graph

This floating toolbar can be activated for 3D openGL graphs by clicking once inside the graph layer (hint: do not click on the actual data plot).

Pressing Ctrl + A selects all graph layers and in a 3D openGL graph, this has the effect of showing the 3D floating button group. Once the button group is displayed, use the TAB key to cycle through available tools.

Hot Key Menu/Action Context
Fix position of 3D floating button group.
N/A Fix position of toolbar. Pin the 3D floating button group to the upper-right corner of the graph layer.
3D Floating FixPos.png


Move the graph layer.
Arrow keys Move the graph layer (including all attached objects) on the graph page. When this button is active, hovering inside the 3D "cube" changes the Pointer tool to a 3D cursor move.png. Drag with the mouse or use the arrow keys to move the layer vertically or horizontally.
3D Floating Move.png


Resize a 3D graph with aspect ratio retained.
X + Arrow key Resize the 3D graph in the X direction. When this button is active, XYZ axes appears at the middle of the 3D cube. Use the listed key combinations to increase or decrease the size of the layer in the page.
3D Floating Resize.png


Y + Arrow key Resize the 3D graph in the Y dimension.
Z + Arrow key Resize the 3D graph in the Z dimension.
Shift + X + Arrow key Resize the 3D graph in the YZ plane.
Shift + Y + Arrow key Resize the 3D graph in the XZ plane.
Shift + Z + Arrow key Resize the 3D graph in the XY plane.
W + Arrow key Resize the 3D graph in any dimension.
Rotate 3D graphs with the 3D floating buttons.
X + Arrow key Rotate the 3D graph around the X axis. When this button is active, a set of 4 rotation radii (X,Y,Z,screen) appear in the middle of the 3D cube. Use the listed key combinations or hover on a rotation radius and drag with your mouse to rotate the graph on the page.
3D Floating Rotate.png


Y + Arrow key Rotate the 3D graph around the Y axis.
Z + Arrow key Rotate the 3D graph around the Z axis.
Q + Arrow key Rotate the 3D graph in screen.
W + Arrow key Rotate the 3D graph around any axes.
Rotate 3D graphs using the R key.
R + Mouse Drag to rotate the 3D graph in an arbitrary direction. Press "R" before pressing other keys.

Hovering on a 3D graph while pressing "R" changes the Pointer tool Button Pointer.png to a 3D RKey rotate cursor.png. Press Ctrl and/or Shift as needed, and rotate by (a) dragging with your mouse or (b) pressing the arrow keys on your keyboard.


R + Ctrl + Mouse/Arrow key Rotate the 3D graph around the X axis.
R + Shift + Mouse/Arrow key Rotate the 3D graph around the Y axis.
R + Ctrl + Shift + Mouse/Arrow key Rotate the 3D graph around the Z axis.
Shear the 3D graph in X/Y direction.
X + Arrow key Shear the 3D graph in X direction. When this button is active, you can shear the graph layer in the X or Y direction.
3D Floating Shearing.png

Note: This toolbar button will not display unless you have checked Enable Shearing on the Miscellaneous tab (layer level) of Plot Details.

Y + Arrow key Shear the 3D graph in Y direction.
Switch the operation button.
Tab Switch the operation button on the 3D floating button group (Move or resize the area button/Resize button/ Rotate button/ Skew button) With graph layer active
Control the increment speed factor.
i Increase the speed factor in increment of 5% With graph layer active
d Decrease the speed factor in increment of 5% With graph layer active

Directional Lighting of the 3D Graph

Hot Key Menu/Action Context
S + Mouse/Arrow key Change lighting angles in horizontal and vertical planes. Press the "S" key while hovering on the 3D openGL graph. The cursor will change modes. Drag with your mouse or use arrow keys to change lighting source direction.

Hold "S" + Wheel to Zoom in/out on 3D openGL graphs. Hold "S" + Drag to change lighting direction.

Gadgets

Hot Key Menu/Action Context
O Output the current result. With gadget on graph, press O will create new output. If there are multiple gadgets in graph, one needs to be selected first.
N Output the results for all curves in active layer. Apply the same operation for all curves in active layer and output results.
L Output the results for all layers. Apply the same operation for all curves in all layers of the graph and output results.

Format

Hot Key Menu/Action Context
Ctrl + B Toggle Bold on & off When worksheet or matrix cells are selected, or text object is in edit mode.
Ctrl + G Greek interpretation of characters With text object selected in in-place editing mode, this key toggles. When selecting entire text, all becomes Greek.
Ctrl + I Toggle Italic on & off When worksheet or matrix cells are selected, or text object is in edit mode.
Ctrl + U Toggle Underline on & off When worksheet or matrix cells are selected, or text object is in edit mode.
Ctrl + Shift +">" Sel Text: Increase Font (or Ctrl+Shift+".") Select text in in-place editing mode.
Ctrl + Shift + "<" Sel Text: Decrease Font (or Ctrl+Shift+",") Select text in in-place editing mode.
Ctrl + "+" in Num keyboard

Ctrl + Shift + "+"

Sel Text: Superscript Select text in in-place editing mode.
Ctrl + "=" Sel Text: Subscript Select text in in-place editing mode.
Ctrl + "-" in Num keyboard Sel Text: SuperSubscript Select text in in-place editing mode.
Ctrl + '
Ctrl + P
Add a full height prime symbol. When in-place edit mode is turned on for text label or rich text format is selected for worksheet. And if superscript is already turned on, it will be added as a combining prime.
Ctrl + Shift + '
Ctrl + Shift + P
Add a full height double prime symbol. When in-place edit mode is turned on for text label or rich text format is selected for worksheet. And if superscript is already turned on, it will be added as a combining double prime.

Markers

Hot Key Menu/Action Context
Ctrl + Alt + M Data->Mark Data Range Select data plot in graph window.
Ctrl + Alt + N Data->Clear Data Markers With a data range marked in graph window.
Ctrl + Shift + M Data->Analysis Markers->Hide When a range of data is marked and do an analysis

Move Lock Position

Hot Key Menu/Action Context
Ctrl + Shift + F Data->Lock Position->First Point After performing fitting on graph
Ctrl + Shift + K Data->Lock Position->Layer Icon After performing fitting on graph
Ctrl + Shift + L Data->Lock Position->Last Point After performing fitting on graph
 

© OriginLab Corporation. All rights reserved.