OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis                     
 
Skip Navigation Links
All BooksExpand All Books
Origin HelpExpand Origin Help
Common Analysis FeaturesExpand Common Analysis Features

12.1 Analysis Report Sheets and Columns

Analysis operations, such as those performed with the nonlinear curve fitter or with any of Origin/OriginPro's statistical tools, create detailed analysis report sheets. These sheets contain tables that are organized in a tree structure. You can expand or collapse each branch to show or hide each table. The figure shows a typical analysis report sheet generated during a session with the Nonlinear Fitting tool.

Analysis Report Sheets and Worksheet Columns-1.png

Viewing, editing and copying report tables

Note that the information in each branch can be operated on independently via a number of shortcut menu commands. Click on the down arrow after the branch title or right-click on one cell of the table to access the shortcut menu.

Analysis Report Sheets and Worksheet Columns-2.png Analysis Report Sheets and Worksheet Columns-5.png
Shortcut menu command Comments

User comments

Add comments for any table in the report worksheet. To add comments, right-click on a branch title and select User Comments. Enter your comments into the text box.

Copy Footnote

The footnotes immediately below the report table include information on statistical test conclusions, curve fitting status, etc. Note that you cannot copy the footnotes directly but you can use this shortcut menu command to copy footnote content to the Clipboard.

Copy Table

Use the Copy Table menu command to copy the table content and paste it into a graph window, a worksheet or a layout window. When pasting the table into a graph or worksheet, you can Paste or Paste Link.

The table pasted into a graph is editable. You can double-click it to open the table edit dialog and make any changes as you want. After that, you can click the Update Table button to close the dialog and update the changes to the table on the graph.

Create Copy As New Sheet

Use the Create Copy As New Sheet menu command to copy table content to a new sheet. Origin adds a sheet to the book and pastes in the table content.

Create Transposed Copy As New Sheet

The Create Transposed Copy menu command does much the same as Create Copy but, in this case, the pasted table is transposed.

Expand

Expands all branches.

Collapse

Collapses all branches.

Reset All Graphs

Reset the all embedded graphs to apply the default settings.

Dataset Identifier

Change the dataset identifier showing in the report tables. Select <Custom>... from the context menu, you are allowed to use the @ Substitution to specify a custom identifier.

Arrange Plots of Same Type in One Graph

Arrange the plots of same type into one graph. This option is only available when there are multiple graph windows in an output graph branch.

Copy/Paste Format

You can use the Copy Format menu command to copy table format settings from a table and apply these settings on another table using the Paste Format menu command (see next).

Digits...

Open the Digits in Report dialog to specify the digits of numeric data in the current table. Checking the Save as Default check box in the Digits in Report dialog, the digit settings will be passed to the Digits in Report group in the Numeric Format tab of Option dialog, and applied to all report sheets.

Note: After nonlinear curve fitting or peak analyzing, in the report sheet, you are not allowed to update the digits of the Parameters table using this control. You should open the Change Parameters dialog, go to Parameters tab and do changes in the Significant Digits column.

View

Table row and column headers are hidden by default. Select Column Header or Row Header to turn them on (check mark present) or off (check mark cleared).

Select Row Grids or Column Grids to turn table grid lines on or off.

Editing report sheet graphs

The analysis report sheet frequently contains embedded graphs, such as this one:

Analysis Report Sheets and Worksheet Columns-3.png

This embedded graph is a fully-editable Origin graph. You can open it in a temporary window by double-clicking on it. Once you've made your changes in the temporary graph, click the Return Analysis Report Sheets and Worksheet Columns-4.png button at the window title bar. This will close the temporary graph and update the embedded report sheet graph.

Results written to worksheet columns

Instead of, or sometimes in addition to, creating analysis report sheets, some analysis operations simply create ordinary worksheet columns for output (for example X and Y columns for fit curve values). These output columns will be marked with a lock symbol (if the recalculation mode is set to Manual or Auto). The lock symbol denotes columns that are locked to editing.

Specifying Digits in Report Sheet

In the Digits in Report dialog, you can specify the digits of numeric data in the current table.


To open this dialog:

  • Click on the down arrow after the branch title or right-click on one cell of the table in the report sheet.
  • Select Digits... in the context menu.
Digits in Report.png

Digits

Default Decimal Digits

Display digits in the current table as determined by the Number of Decimal Digits combination box value on the Numeric Format tab of the Options dialog box (Tools: Options).

Set Decimal Places = The number of digits that display after the decimal place. Type or select the decimal place value in the Decimal Number text box. This value = the maximum number of digits displayed after the decimal point.
Significant Digits = The number of digits displayed. Type or select the value in the Significant Digits text box.

Save as Default

Select this checkbox to save the digits setting as this analysis' default. All report sheets generated by this analysis tool that after will use this digits setting. Note that it will Not overrides the Digits in Report setting on the Numeric Format tab of the Options dialog box.

 

© OriginLab Corporation. All rights reserved.