The Origin Forum
File Exchange
The Origin Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ | Send File to Tech support
Username:
Password:
Save Password
Forgot your Password? | Admin Options

 All Forums
 Origin Forum
 Origin Forum
 Baseline Correction: "No Data Selected"
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic Lock Topic Edit Topic Delete Topic New Topic Reply to Topic

RyanPitt

USA
4 Posts

Posted - 02/21/2012 :  2:58:33 PM  Show Profile  Edit Topic  Reply with Quote  View user's IP address  Delete Topic
Origin Ver. and Service Release: OriginPro 8.6.0 Sr1
Operating System: Windows 7 32 bit

I have entered a data set and have normalized the values of the y-axis. I want to perform a baseline subtraction on my data set. I highlighted my data then went to analysis, then peaks and baseline, and peak analyzer.... I get an error message each time saying that no data is selected. I have tried highlighting both x and y axis data and just the normalized y data. I get the no data selected error each time. I have also tried to do this when on the plot's screen and still no luck. Why is the program saying that I do not have data selected even though I have it highlighted? Does anyone have any ideas?
Thank you.

easwar

USA
1853 Posts

Posted - 02/22/2012 :  10:36:53 AM  Show Profile  Edit Reply  Reply with Quote  View user's IP address  Delete Reply
Hi Ryan,

Does this happen with any data, or one particular project? If one particular project, can you send that to tech support? Use the "Send File to Tech Support" link on top right of this page.

Easwar
OriginLab
Go to Top of Page

RyanPitt

USA
4 Posts

Posted - 02/22/2012 :  11:22:15 AM  Show Profile  Edit Reply  Reply with Quote  View user's IP address  Delete Reply
I just recently purchased OriginPro. I have tried to perform the listed operations on multiple data sets of the same type with the same results. I will send one of the projects to tech support. Thank you for your time.
Go to Top of Page

greg

USA
1361 Posts

Posted - 02/22/2012 :  4:53:09 PM  Show Profile  Edit Reply  Reply with Quote  View user's IP address  Delete Reply
Removing the double quotes (or changing them to single quotes) in the Long Name of your X column will resolve the problem.

The Peak Analyzer always checks that the active data is valid according to the formal syntax which is
[BookName]SheetName!(XShortName"XLongName",YShortName"YLongName")
e.g.
[Book1]Sheet1!(A"My "Sample X"",B"Y Data")
in a case where my X column Long Name is My "Sample X".

Normally, double quotes within the Long Names of X or Y are not a problem, but you have stumbled upon a specific case where it IS a problem:
When the column long name contains a single pair of double quotes where the last character in the Long Name is a double-quote, then Peak
Analyzer thinks the data is not valid and puts up the Attention! box with "No data selected".

Recorded as a bug. Thanks for the catch.
Go to Top of Page

RyanPitt

USA
4 Posts

Posted - 02/22/2012 :  5:08:45 PM  Show Profile  Edit Reply  Reply with Quote  View user's IP address  Delete Reply
Thank you very much! This solved the problem.
Go to Top of Page

easwar

USA
1853 Posts

Posted - 02/22/2012 :  5:08:58 PM  Show Profile  Edit Reply  Reply with Quote  View user's IP address  Delete Reply
Hi Ryan,

If you are setting the long name while importing, assign this information to the comments instead of long names, this way the information can stay, and you will still be able to use the tool. Options exist in ascii import or import wizard etc to assign subheader lines to comments instead of long name.

Easwar
OriginLab
Go to Top of Page
  Previous Topic Topic Next Topic Lock Topic Edit Topic Delete Topic New Topic Reply to Topic
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
The Origin Forum © 2008 Originlab Corporation Go To Top Of Page
Snitz Forums 2000