The Origin Forum
File Exchange
The Origin Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ | Send File to Tech support
 All Forums
 Origin Forum
 Origin Forum
 Bug in bar graph

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Anti-Spam Code:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
Check here to subscribe to this topic.
   

T O P I C    R E V I E W
SteffenG Posted - 01/16/2012 : 04:51:22 AM
OriginPro 8.5.1G SR2 and 8.6.0G
Operating System: Win XP

Hello,

there seems to be a bug in Origins bar graphs. If you use a bar graph and you scale your y-axis from somewhat different from zero an additional x-axis appear at an artificial level of zero.

You can check this with the following steps:
Within a worksheet fill in the first column with 1; 2; 3 in the first 3 rows.
Fill the second column with 75; 80; 85.
Mark the second column and choose the bar graph symbol to draw a bar graph.
Within the bar graph change the lower y-scale from 0 to 10.
You will see an additional line below the x-axis.

Maybe this bug could be solved within the next SR.
Best regards,
Steffen
7   L A T E S T    R E P L I E S    (Newest First)
SteffenG Posted - 04/12/2012 : 08:59:37 AM
Hello asp,

thanks a lot for this work around. This works also in 8.6.0 SR2.

Best regards,
Steffen
asp Posted - 01/30/2012 : 11:23:56 AM
Let me suggest workaround. For the example you suggested try first plot scatter plot and than being in the graph window change plot type to bar. It worked for me in 8.5.1.
SteffenG Posted - 01/27/2012 : 03:58:23 AM
Hi all,

thanks for your comments. May be I have to point out that I see an additional line below the X-axis. The Y-axis looks good. It looks like that the x-axis is doubled. I receive a x-axis at the right position and a line below the x-axis at the artificial level of zero. You will see this if you follow my error description in my first post.

Right now my work around is the following. I disabled the x-axis and draw a horizontal line at the Y1-coordinate.

Best regards,
Steffen



quote:
Originally posted by easwar

Hi Steffen,

How about, in Axis dialog:
1> Go to Title and Format tab
2> Select "Left" in the left panel
3> Change the "Axis Position" drop-down to "Left"
Then the axis will be drawn always on the left end of the layer, irrespective of the from and to values. Then, optionally, you can also turn on the Y=0 check box in Gridlines tab if desired (if the range of values go both positive and negative for instance).

Does this do what you want?

Easwar
OriginLab

easwar Posted - 01/20/2012 : 12:23:38 PM
Hi Steffen,

How about, in Axis dialog:
1> Go to Title and Format tab
2> Select "Left" in the left panel
3> Change the "Axis Position" drop-down to "Left"
Then the axis will be drawn always on the left end of the layer, irrespective of the from and to values. Then, optionally, you can also turn on the Y=0 check box in Gridlines tab if desired (if the range of values go both positive and negative for instance).

Does this do what you want?

Easwar
OriginLab
Hideo Fujii Posted - 01/20/2012 : 10:40:18 AM
Dear Steffen,

> I can write every value into the "at position" field.
>This doesn't change the additional line at the artificial level of zero.

hmmm...strange - Could you please try either of the following?

1) When you set 0 to "At Position=", instead of hitting "Apply" button, press "OK" button.

2) Set "% from Left" (instead of "At Position=") to 0 for the Axis Position.

3) Click-and-drag the vertical axis to move it to the right position.

Any one of them worked?

--Hideo Fujii
OriginLab
SteffenG Posted - 01/20/2012 : 06:19:37 AM
Dear Hideo Fujii,

thanks for your suggestion for the work around. Unfortunately this doesn't work for me. I can write every value into the "at position" field. This doesn't change the additional line at the artificial level of zero.

Best regards,
Steffen
Hideo Fujii Posted - 01/17/2012 : 12:35:11 PM
Dear Steffen,

Thank you very much for pointing out the problem of positioning the vertical axis when the scale is changed. I have reported the problem so that our developers can look at the issue to fix it.

For a meantime, as a work-around, open X Axis dialog, choose Title & Format tab, choose "Left" axis, and select "at Position=" for Axis Position, and enter 10 (i.e. "From" value of the axis scale) for the "Percent/Value" field to put the vertical axis at the correct position.

--Hideo Fujii
OriginLab

The Origin Forum © 2008 Originlab Corporation Go To Top Of Page
Snitz Forums 2000